Wlan 5g not starting most of the time


#61

So… Good news :laughing:
Up and running. So far stable and no issues with default config (2 hrs testing so far card was delivered just today).
iPerf on my S7 edge gives peaks of 530 Mbps, average cca 480Mbps. It is very comparable result to default 5G radio but to measure advantage of MU-MIMO I need more testing).
Card is pretty hot.

As expected problem was board-2.bin file.
Both default repo (non-ct and ct) of kmod and firmware are not working.
There are several options possible:
1) use default repo and just replace board-2.bin by Candela: (https://www.candelatech.com/downloads/ath10k-9984-10-4/board-2-ct.bin / referer: https://www.candelatech.com/ath10k-10.4.php)

(https://github.com/kvalo/ath10k-firmware/tree/master/QCA9984/hw1.0/3.4 is the same firmware as omnia default but board-2.bin is not working)


2) replace both default repo files by Candela files:

I’ll keep you posted how it performs. I run CT non-commercial now.

Edit:
Router was rebooting so I went for option 1) and now it’s solid stable. iPerf from mobile between 500 and 570Mbps.


mPCIe slots and 802.11AC wave 2
#62

Hi,

as far as I can see you are testing WLAN ac 2 card…

On which distance do you get 500Mbps to your mobile phone?

Basically said it needs some additional development?

thanks


#63

From couch to router :laughing:
It’s about 3m. But over 2 walls (10m) I can get still around 450Mbps. I use default settings.
I think it’s mobile limitation so I plan to check throughput on RT-AC87U (Quantenna SOC). MU-MIMO performance gain I did not test so far but soon I will.


#64

Thank you very much, sounds great.
With standard ac card that came with router after 2 walls ( not concrete but wood) there are significant losses.


#65

As you now had several days of normal-life-testing - is it still pretty stable?
How did you manage the 4th antenna - as the 2,4GHz-card still needs 2 antennas the TO is lacking a fith hole for RP-SMA, right?

Did you do throughput-testing?
I’m eagerly waiting for the Intel 9260 to become available - with that one could fully unleash the wave 2-power :heart_eyes:

edit: could you give instructions for beginners how to install the necessary drivers?


#66

Yes it is stable with default firmware-5.bin and CT mod of board-2.bin.
Today I downloaded new firmware-5.bin_10.4-3.4-00104 https://github.com/kvalo/ath10k-firmware/tree/master/QCA9984/hw1.0/3.4 so far stable and now it reports TX Rate properly.

It was necessary to buy additional antennas (the same as on omnia): http://www.gpsmorava.cz/Items/ItemDetail.aspx?id=AW-A2458G-FSRPK-B

Installation is quite easy:
Just install firmware from CLI or Luci and then replace files as mentioned earlier in this thread

ls /lib/firmware/ath10k/QCA9984/hw1.0/
board-2.bin     firmware-5.bin

#67

QCA988X needs to be uninstalled first, right?


#68

Best is to keep QCA988X and use it as 3x3@2.4GHz and remove the half-sized AR9287 which is 2x2@2.4GHz only.
You will need to use one antenna for 2.4GHz only and use both diplexers for 5GHz.
In my case the QCA988X is faulty (not detected in warm state) so I kept the half-sized 2GHz radio installed instead of QCA988X.


#69

Do you think it would also work with 3 antennas leaving the 4th connector unconnected as I don’t necessarily want to drill holes and buy new antennas and pigtails?


#70

I think you can disable antenna manually in config. But why if you can buy directly the same card but with 3x3 only:
https://www.compex.com.sg/product/wle1000v5-20/

It is not needed to drill holes there are 5 holes already but 2 with plastic insert which is easy to remove.


#71

bought the wle1000v5-20 from compex not but it features a qca9882 chip (not qca9884) I was unable to find a driver at https://github.com/kvalo/ath10k-firmware/ repo.

But I also found this wiki https://wikidevi.com/wiki/Ath10k which states that qca9882 should be in-kernel.

I’m totally confused now how to get this card working. Do I have to modify board2-bin and firmware-5.bin from somewhere or not?

Thanks for any help as I have the card now laying around without use.


#72

Try board-2.bin first (there’s readme).
http://downloads.compex.com.sg/download/dXBsb2Fkcy9ib2FyZERhdGEvRm9yX0J1aWxkaW5nX05ld19GaXJtd2FyZS9sZWRlLWJ1aWxkLnppcA==/h/526899560099021341c11fb986f1654f
This should work with new HW versions. If not then from Compex product page navigate to download and find board files for older HW version.


#73

I can understand your frustrations if the card is not working. If you will have problems to set it up and running then let me know I’ll try to give you more detailed how-to during this weekend…


#74

Hi Thanks for that Link. I just installed ct driver from cli in luci and replaced board-2.bin from the download you provided. Worked perfectly fine after rebooting.It also seems that this card boots up just fine after a router reboot whereas the pre-installed card ws faulty and always needed 2-3 reboots to get wifi back up and running.

The only thing I still have is that I don’t see signal strength and “Mbit Rate” and Luci locks up when I trying to look at the details page of one of the 2 WLANs If configured on the card “internal & guest”. But this strangely also happens when I try to look at the details page of the 2,4Ghz card. Don’t know what error that is.

Performance of the card is fine, it’s just the missing information. But I halso had that problem with the pre-installed card and to be honest I don’t look onto this page very often. So if it can be easily fixed even better but if not, no big deal

Thanks for you help


#75

Congratulations. Just note it is not 9882 as you mentioned but 9982.
Did you try non-ct default firmware? How it works?
For Luci - what do you mean by “lock up”? In my case some Luci tabs loads more than 30s for example. Try to wait longer there are people reporting that sometimes must wait even few minutes before the page loads.


#76

I just installed my copy.
PCIe #1: RouterBOARD R11e-2HPnD
PCIe #2: WLE1216V5-20
Uninstalled ath10k-firmware-qca988x.
Then installed ath10k-firmware-qca9984 and replaced files with CT mode board-2.bin and firmware-5.bin_10.4-3.4-00104.

edit:
Wifi comes up and I can configure SSIDs from luci.
But now I still cannot choose 80+80MHz from luci - does that work for you? When setting ‘VHT160-80PLUS80’ via /etc/config/wireless the bandwidth will always be 20MHz…
And VHT160 does not work for me either - my Intel 9260 and also other WAVE 1-cards don’t even recognize the network anymore. And what I also observerd - the network is constantly coming up and shutting down again.
And on VHT80 I only get the following TX/RX as maximum:
grafik
What wifi-card are you using in your client?


#77

What I just came across:
Seems as if I’m now not able anymore to adjust the interface via luci or it doesn’t come up anymore?

And: Could you please post your wireless config? Is “option type ‘mac80211’” correct?


#78

VHT160 is not supported as far as I know (hostapd).
Try connect some client 4x4 then you should have NSS 4 / 1733.3 Mbps reported.

Try original board file from compex:
http://downloads.compex.com.sg/download/dXBsb2Fkcy9ib2FyZERhdGEvRm9yX0J1aWxkaW5nX05ld19GaXJtd2FyZS9sZWRlLWJ1aWxkLnppcA==/h/526899560099021341c11fb986f1654f

my config is following (nothing unusual):

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option country 'CZ'
        option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option txpower '23'
        option channel '36'
        option htmode 'VHT80'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'Turris_5G'
        option key 'password'
        option disabled '0'
        option network 'lan'
        option encryption 'psk2+ccmp'
        option wpa_group_rekey '86400'

I don’t know what problem you might have with luci for me everything works fine. Maybe you misconfigured something in config file and then luci can not load the page due to wrong option types from config.


#79

Seems I had a corrupted firmware-5.bin installed. It works as long as I do not set up SSIDs via SSH but only via luci.

I searched for hostapd not being capable of VHT160 but couldn’t find a source - where did you learn about that?
The only thing I found is a luci-bug - you can set up VHT160 or VHT160-80PLUS80 even if the card is not capable of VHT160/VHT80+80.

looking to iw phy0 info it reports

[...]
VHT Capabilities (0x339b79fa):
                        Max MPDU length: 11454
                        Supported Channel Width: 160 MHz, 80+80 MHz
[...]

So at least the driver reports the capability of VHT160.

I bought this card to get a wireless connection with 2SS at 160MHz as the Intel 9260 just became available which supports that bandwidth…


#80

I don’t remember exactly where but it was openWRT/ LEDE/ ath10k/ mwlwifi forums. I remember that both mac80211 and hostapd needs to be patched for VHT160. In addition there were some patches on github showing enabling DFS scan for 160 MHz if I remember well.
As you can see in code below it seems that current hostapd version is patched and should support [VHT160-80PLUS80] but I really don’t know it’s just based on text output.

I did not spend so much time to investigate as VHT160 is not needed for me. I just tried to replace wpad by hostapd and wpa-supplicant directly but no success.
Anyway you’re free to investigate and please let me know what you find.

This is part of my hostapd generated file (see vht_capab):

driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
country_code=CZ
ieee80211d=1
ieee80211h=1
hw_mode=a
channel=36


ieee80211n=1
ht_coex=0
ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40]
vht_oper_chwidth=1 // this changes to =2 when VHT160 is set //
vht_oper_centr_freq_seg0_idx=42
ieee80211ac=1
vht_capab=[RXLDPC][SHORT-GI-80][SHORT-GI-160][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][VHT160-80PLUS80][MAX-MPDU-11454][MAX-A-MPDU-LEN-EXP7]

Q: In Luci you can see option to set “VHT160-80PLUS80”? I see just “20/40/80/160 MHz”. What country code and channel you have set?

@HomerSp Mathias is VHT160 working to you?

edit:
iw phy0 info:

valid interface combinations:
		 * #{ managed } <= 1, #{ AP, mesh point } <= 16,
		   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

Here I would expect 160 Mhz so (as mentioned before) maybe there is some problem with DFS.

Log:

notice netifd[]: radio0 (21123): wlan0: interface state HT_SCAN->DFS
notice netifd[]: radio0 (21123): wlan0: DFS-CAC-START freq=5180 chan=36 sec_chan=1, width=2, seg0=50, seg1=0, cac_time=60s
notice netifd[]: radio0 (21123): DFS start_dfs_cac() failed, -1
notice netifd[]: radio0 (21123): Interface initialization failed
notice netifd[]: radio0 (21123): wlan0: interface state DFS->DISABLED
notice netifd[]: radio0 (21123): wlan0: AP-DISABLED 
notice netifd[]: radio0 (21123): wlan0: interface state DISABLED->DISABLED