Wlan 5g not starting most of the time


#41

Same here - try editing your /etc/modules.d/55-ath10k to look like this:

ath10k_core skip_otp=1
ath10k_pci irq_mode=1

That plus some of the remove and rescan and rebooting seems to have gotten mine back up. Look up in this thread for my post on how to do those. I unfortunately didn’t make a note of the order I did things to get it up, it took a lot of tries and reboots.


#42

After the update to 3.5.2 for me the poweroff trick don’t work for 2-3 times, then I got angry, I cut it off for 10 mins and after poweron it start working again. Now its even more weird then before.


#43

I ran into a similar problem. Updating the firmware by replacing ath10k-firmware-qca988x-ct with ath10k-firmware-qca988x seems to have solved complete 5G unavailability for me (I hope), but it’s still quite unstable, and I have to restart hostapd manually a few times to bring it back sometimes.


#44

Hi Jason, no offense meant but I tried to run the rescan stuff when you posted it. Also see above. Turned out that what you posted simply didn’t work on the TO on official release (at least not without installing additional software, but I don’t know which one). Unless it’s bash related which I don’t think, you have to explain how to make this commands work.

I asked you how to make it work back then but never got an answer.

Would be great if somebody else could also try it and post results just to be sure that I’m not the only one which can’t run you’re commands for some strange reasons.


#45

I will try with those module parameters, when I have some time. Thanks @Jason_A.

After 30 mins powered off, it start to work again. Thanks @Weafyr

Yesterday was a bad day. But I insist this is a big issue. It prevent to automatic updates too, when the update require reboot.


#46

No offense taken, I will log everything I do the next time it happens. I am reluctant to try to recreate it though due to all the problems of getting it started again.

I’m not even sure if the commands I’m using or parameters I’m setting are helping or if it’s still just random. Since there have been several reports of it working after 10 or 30 minutes, maybe it’s just a timing thing.


#47

Hi Guys,

As I posted 3rd Jan, so some while ago, I request turris to replace my card as at that time it was nor clear if it was a hardware or a software issue the the card is not starting fine.

Meanwhile we have seen various different firmware versions, some better, some worse but the problem never got solved. It seems like the devs are playing around trying different things.

Interesting thing is: Today I received my replacement card finally and guess what. The new card works like a charm. I can soft reboot the router as many times I want. The card always comes up fine working perfectly.

Which brings is back to the initial question. Is it really a software issue or are some few cards (like mine) just faulty?

If I were you I would also request your card to be replaced by omnie cause if it’s really a hw issue, the devs can probably play around as much as they want, it will never be fixed.

The support address were I requested a new card can be found above my post from 3rd of Jan.

Hope your problems are also solved soon.


#48

Thanks for info, I just sent the email, I will post new’s there, but for now the auto-generated email says that they are overloaded :wink:


#49

same problems persist for me after the latest update caused a reboot. 5ghz card not showing up, and have done several soft and hard reboots so far and haven’t been able to get it to work.

I’m still getting this failure when the module loads:

ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
...
ath10k_pci 0000:02:00.0: failed to receive control response completion, polling..
ath10k_pci 0000:02:00.0: Service connect timeout
ath10k_pci 0000:02:00.0: failed to connect htt (-110)
ath10k_pci 0000:02:00.0: could not init core (-110)
ath10k_pci 0000:02:00.0: could not probe fw (-110)

but then I did this:

root@betelgeuse:/sys/bus/pci#echo "1" > devices/0000:02:00.0/remove
root@betelgeuse:/sys/bus/pci#rmmod ath10k_pci
root@betelgeuse:/sys/bus/pci#rmmod ath10k_core
root@betelgeuse:/sys/bus/pci#echo "1" > rescan
root@betelgeuse:/sys/bus/pci#insmod ath10k_core skip_otp=y
root@betelgeuse:/sys/bus/pci#insmod ath10k_pci irq_mode=1
root@betelgeuse:/sys/bus/pci#dmesg

which showed this different loading:

ath10k_pci 0000:02:00.0: limiting irq mode to: 1
ath10k_pci 0000:02:00.0: pci irq legacy oper_irq_mode 1 irq_mode 1 reset_mode 0
... <cut the usual board loading stuff>
ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
ath10k_pci 0000:02:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1

I don’t understand why my /etc/modules.d/55-ath10k isn’t making it load this way though, I have this in the file

ath10k_core skip_otp=y
ath10k_pci irq_mode=1

any ideas on how to correctly pass options to modules?

after all this, my device showed up as wlan6 instead of wlan0 and i couldn’t figure out how to rename it and bring it up correctly


#50

Think I solved it - I noticed that the skip_otp parameter was being recognized but not the irq_mode. it seems to only recognize the parameter in the first module listed, so I broke out my files like this:

root@betelgeuse:/etc/modules.d#cat 55-ath10k
ath10k_core skip_otp=y

root@betelgeuse:/etc/modules.d#cat 56-ath10k-pci
ath10k_pci irq_mode=1

rebooted and 5ghz card came up immediately. could be a coincidence, but it’s working for me.


#51

Am I the only one still having problems with 5ghz starting? My previous solution isn’t consistently holding, I got this now doing the same thing I did before:

ath10k_pci 0000:02:00.0: limiting irq mode to: 1
ath10k_pci 0000:02:00.0: pci irq legacy oper_irq_mode 1 irq_mode 1 reset_mode 0
ath10k_pci 0000:02:00.0: failed to request legacy irq 255: -22    
ath10k_pci 0000:02:00.0: failed to request irqs: -22
ath10k_pci: probe of 0000:02:00.0 failed with error -22

is this some sort of pci irq problem unrelated to the board, or have i created this problem using irq_mode=1? i also tried reset_mode=1 but hasn’t helped yet. if it’s just me, i suppose i’ll contact them to see about a replacement.


#52

I have same trouble, after the Turris team replaced my 5GHz wifi card by a hardware fail on it.

The latest response to my open issue on Turris support is:

We tested this particular configuration of cards again and came to the conclusion that there might be some kind of interference between the mSATA card and the 5GHz WiFi card. This is something that happens with some mSATA discs. We are not yet sure on what level this is, but we are invetigating the issue. In the mean time, we think it would help if you switched the small and the big WiFi card. The middle pigrail will be too short, but if you move the midle antenna to the hole on the left (remove the plastic plug first) it should work.

Your trouble with 5GHz wifi card continue? Have you some mSATA disk connected on Turris Omnia?

My mSATA disk is a: Kingston SMS200S3/120G


#53

No mSATA card installed in mine.

My 5Ghz card has worked more consistently lately but I have had to reboot to get it to come up sometimes.


#54

I have translated your answer, @Jason_A, to Turris support.

Thanks very much.


#55

I also installed a Kingston ms200 120GB installed recently (in PCI slot 1 where the 2,4 Ghz card was installed) moving it to PCI 3 and installing the msata in Slot 1 as shown in setup video. I then changed the /etc/config/wireless to match the PCI slot and everything was fine again. So I’m not sure if the Kingston Flash Drive is the issue.


#56

Ive got same issues … some times i need restart omnia router


#57

The issues are also not solved for me even though my cards were replaced. Interestingly it worked for some time it worked after my cards were replaced WLAN was fine after each restart and started to believe it’s a hardware issue.

But meanwhile the issues are back so it was not a hardware issue. I often have to restart turris 1-2 times before both wlan cards start, very often both are just dead (lights dark, not showing up in ifconfig). So even after quite a long time the device still has issues with Wifi drivers and it seems turris is either unable to fix them or have no interest in investigating this issue. They say that they are unable to reproduce it, but then why do so many people have problems and of course nobody with this problems wants to send back the router because of shipping costs and because most people don’t have a replacement they could use till the issue is resolved (including me). In my opinion turris should provide a replacement unit and have the other unit shipped to them after the replacement is received with unchanged configuration (so the one that causes the issues and just start rebooting the device multiple times) but I guess they are too lazy or the costs are too high to really go this way and fix it once and for all.

Luckily I meanwhile use a separate Highspeed Wifi Access Point in Bridge Mode (so it’s transparent) and I only use the Turris WLAN for some not so important devices and Guest network. For alle my Tables, Phones, etc I use the access points which works reliably.

If I had known that turris has such huge WLAN issues I probably would have ordered the device without WLAN.


#58

In my case the card shows up only when is not hot (so every second reboot).

But! Recently I put inside my omnia old notebook fan (just because I can there was no other reason) and what a surprise - my 5G radio is working like a charm. Then due to the noise from fan I removed it and my 5G was the same - not booting up when hot. As a compromise I removed radio top cover and attached my old raspberry pi passive cooler. It works great and in 99% the card shows up after reboot except cases when the card was intensively used before reboot (like maxed oud by iperf).

[passive cooling - not actual photo later changed to slighty bigger block]

According manufacturer spec. the card operating temperature is -20ºC to 70ºC (https://www.compex.com.sg/product/wle900vx/) but industrial grade version should work up to 90° (https://www.compex.com.sg/product/wle900vx-industrial-grade/).

Considering board temperature of omnia somewhere between 60°-90° and heating of 5G itself I think that some cards might be on the edge of reliability so bit of cooling can help like in my case.

Anyway I ordered already this beast https://www.compex.com.sg/product/wle1216v5-20/ so I hope it will work better.


#59

Let us know please in this thread if you get this beast working, my question is: where do you connect the 3 antennas because you have much more connectors and also if you have decent drivers that work


#60

I ordered 5 spare external antennas and pigtails. One will be not connected I just want symmetrical look :slight_smile:
In addition I ordered this flatant https://www.compex.com.sg/product/flatant-4x4-dual-band-6dbi/ to hide it inside and maybe remove all antennas from behind. In my experience internal antennas are not worse than external so I’ll try both and then see what is better. My house is one floor so I don’t need to steer beaming angle.

Delivery should be this thursday so after weekend hunting board-2.bin files :rage: I hope to give you some feedback…