Wlan 5g not starting most of the time


#1

Hi,

I just received my turris omnia and started configuring it, installing some software etc. After the next reboot suddenly my Wireless “ac” card (5ghz) was gone, In Luci it said it was disabled but pushing on enable/disable didn’t solve it and in foris it was completely invisible.

checking ifconfig showed that I wlan0 didn’t even exist as device. I rebooted the router around 3-4 times and suddenly 5g was back and working fine. Unfortunately on next reboot it was gone again.

What I also notice is that PCI2 doesn’t start blinking and also the router seems to be stuck somehow. If the WLAN fails to start also all DHCP functionaly and other stuff is now working.

What can I do to fix this?


#2

Use reset mode 4 and flash firmware from https://api.turris.cz/openwrt-repo/omnia/omnia-medkit-latest.tar.gz
How to: https://www.turris.cz/doc/en/howto/omnia_factory_reset


#3

This sounds to me like a contact issue of a not fully inserted card.

I suggest opening the box and reseat the wifi card (and check the screws) as well. Some people reported loose screws.


#4

This issue has been already discussed:




For me actually setting the right country in Luci via Edit -> Advanced settings and rebooting solved the issue:


#5

Yeah this is extremely extremely frustrating. I cannot believe I paid $300 for a device that is so piss-poor right out of the box. The first time I noticed the issue with the 5G card not coming up, I removed it and put it into a debian netbook I have (Lenovo X120e) and it was detected fine and worked every boot. Then I suspected the actual TO board / card slot, which others have pointed out, don’t let the cards sit parallel with the board, so I reseated it a few times and tried minutely adjusting the angle of the card to ensure the slot pins and the card pads were dead on. Given that cz.nic was able to design this device from the ground up, there’s no excuse for the cards not sitting more properly in the slots, and it seems like they just made a poor choice with the standoffs and decided to just go with it versus doing it correctly.

I tried reflashing with the medkit image (which you will notice is dated November 7th – it’s now December 1, and there are several critical-path bugs reported on these forums so why the hell have these not been rolled up into a new restore image?)

I entered the bootloader and set my regdomain ( US ) but even seeding this info into the pre-boot environment hasn’t helped with the issue. On inspecting the serial console during boot there are error messages regarding the ath10k firmware files (will paste them at the of this reply) so I believe problem is a firmware issue, although I have tried another two versions of the ath10k firmware blobs that was linked to GitHub on another post I’ve seen on these forums reporting this issue.

CZ.NIC – you pulled in over a million dollars USD on this design-build project but you delivered a garage-sale quality device. Unacceptable. I should have known better than to trust a small software shop / TLD host to perform the job of and deliver a device on par with the other major manufacturers in the segment.

If you could at least roll up the current fixes from TO’s Foris, openwrt and the ath10k projects and provide us a new ‘medkit’ image that actually heals this device, I think we’d all appreciate it very much.

Thanks,

Sean

snip from serial console @ boot:

[ 13.011928] pci 0000:00:02.0: enabling device (0140 -> 0142)
[ 13.017963] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0
[ 13.194174] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[ 13.204561] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.214435] firmware ath10k!cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
[ 13.230979] ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[ 13.240225] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[ 13.249986] ath10k_pci 0000:02:00.0: firmware ver 10.2.4.70-2 api 5 features no-p2p crc32 b722ec09
[ 13.299101] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
[ 13.309570] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.319285] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
[ 13.328259] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[ 14.458453] ath10k_pci 0000:02:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
[ 14.544735] cfg80211: Regulatory domain changed to country: US


WLE900VX is often not detected
#6

I have the same errors in the kernel logs and the WLAN 5GHz works so I don’t think they have any relevance on the issue.

My understanding of the messages is that the kernel tries to load the firmware file but fails because the file doesn’t exist (-2) and then delegates the firmware download to the user space.


#7

I also have those kind of errors, but my 5 GHz is working oke.

My reg code is set on NL and i have put in the rc.local also to change it to NL might something happen and change it to another country.

That being said, in the /etc/config/wireless i have also set the countries on NL and the last thing i had to do that i had no issues anymore is…keep it on channel 36. I have no problems anymore with channel hopping because it has been fixed on that channel. The output is a steady 292-400 Mbit. MAYBE it should be even higher in reality, but coming from 60-150 Mbit this is a BIG step forward for me.

Try to change to that channel and see if things change. If they still don’t …try to change to another country such as NL (Netherlands) i can confirm that mine is working oke…on channel 36. This will do till we see further changes in the future.


#8

OK so, I reseated the card again and restored to factory again. The card seems solid, physically now. That said, as soon as I try to change the regdomain to US from CZ, the card goes disabled. I am just going to keep the regdomain as CZ until a fix is available. This also has now persisted one ‘reboot’ (via halt issued on serial root console)


#9

I suspect that the region code has A LOT to do with this whole problem. When i was experimenting with it by changing it for example to US, i also experienced what you saw…that the card disabled it self.

The second thing when i did change to NL as region code. Did not know back then that weather-radar uses certain channels 120, 124, 128. I used channel 128 back then. The following morning it hopped to channel 149, which the Netherlands does NOT support. They support up to channel 140. When i again configured the 5 GHz card and just left it on channel 36…well till now nothing has changed or happened.

IF things change…for example the system somehow turns to regdomain changes to US or so…just use

iw reg set CZ

in the rc.local. Just to be sure…you never know.


#10

Newest update does not fix WLAN problems

Just installed the newest Turris update (which also included a new kernel) but on restart 5G card again got disabled. My country code /etc/wireless/config is fine (both set to “CH”) and also Luci shows this in “Edit”->“Advanced” and also “iw reg get” shows that my region is set to “CH”. Of course reseating the card did not help (as in most cases reported here) I tried that too.

So it’s a total gambling if 5G card comes up or not. I really hope that turris will look into this issue asap. It’s a actually a bug that causes so much frustration and it requires me to always watch if 5G is coming up or not after a reboot.

But somehow I got the feeling that the creators do not pay a lot attention to the forums and to the problems as well.


#11

Could you also give me the output of some commands.

ifconfig

cat /etc/config/wirelss

Do keep in mind to remove wifi SSID and password.


#12

Of course, here’s the output of /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'VHT80'
        option txpower '20'
        option country 'CH'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+tkip+aes'
        option key '...'
        option ssid '...'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option country 'CH'
        option hwmode '11g'
        option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option disabled '0'
        option hidden '0'
        option encryption 'psk2+tkip+aes'
        option key '...'
        option ssid '...'

and here’s ifconfig

br-lan    Link encap:Ethernet  HWaddr D8:58:D7:00:5C:D3
          inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fda6:7fef:b222::1/60 Scope:Global
          inet6 addr: fe80::da58:d7ff:fe00:5cd3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7983 errors:0 dropped:97 overruns:0 frame:0
          TX packets:7049 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1165191 (1.1 MiB)  TX bytes:3058574 (2.9 MiB)

eth0      Link encap:Ethernet  HWaddr D8:58:D7:00:5C:D3
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6944 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5954 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:1197717 (1.1 MiB)  TX bytes:1837093 (1.7 MiB)
          Interrupt:37

eth1      Link encap:Ethernet  HWaddr D8:58:D7:00:5C:D4
          inet addr:178.82.30.225  Bcast:178.82.31.255  Mask:255.255.252.0
          inet6 addr: fe80::da58:d7ff:fe00:5cd4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:27016 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7074 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:10334323 (9.8 MiB)  TX bytes:1190848 (1.1 MiB)
          Interrupt:38

eth2      Link encap:Ethernet  HWaddr D8:58:D7:00:5C:D5
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:710 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2981 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:81567 (79.6 KiB)  TX bytes:398344 (389.0 KiB)
          Interrupt:40

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1184 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1184 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:99497 (97.1 KiB)  TX bytes:99497 (97.1 KiB)

wlan1     Link encap:Ethernet  HWaddr 04:F0:21:23:23:D0
          inet6 addr: fe80::6f0:21ff:fe23:23d0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1113 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4222 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:170428 (166.4 KiB)  TX bytes:1773645 (1.6 MiB)

This is with ‘5G’ not coming up. Sadly since the update that was installed yesterday (new kernel 4.4.38-34abcd5e548fc8ed5390269f3a31d173-1) ‘5G’ is now completely broken. It’s no coming up again anymore. I rebooted at least 5 times with no success. Seems that turris omnia is really having serious issues and they are making things worse. I will post another topic on SW Problems about my ‘5G’ not coming up again anymore.


#13

Hi big_boss,

finally my ‘5G’ come up. Don’t know if it was pure luck or if it was because I did run “iw reg set cz” and did set the country in Luci of both cards to ‘CZ’ or not. Interestingly after a reboot, an “iw reg get” now shows ‘CH’ not ‘CZ’ anymore so it was reverted for whatever reasons, also my /etc/config/wireless was reverted to ‘CH’ as country. Very strange. ATM ‘5G’ and ‘2G’ are running so here’s my ifconfig when wlan0 actually exists and is working:

br-lan    Link encap:Ethernet  HWaddr D8:58:D7:00:5C:D3
          inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fda6:7fef:b222::1/60 Scope:Global
          inet6 addr: fe80::da58:d7ff:fe00:5cd3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4653 errors:0 dropped:41 overruns:0 frame:0
          TX packets:4483 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:706461 (689.9 KiB)  TX bytes:4082967 (3.8 MiB)

eth0      Link encap:Ethernet  HWaddr D8:58:D7:00:5C:D3
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2256 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1602 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:416936 (407.1 KiB)  TX bytes:403458 (394.0 KiB)
          Interrupt:37

eth1      Link encap:Ethernet  HWaddr D8:58:D7:00:5C:D4
          inet addr:178.82.30.225  Bcast:178.82.31.255  Mask:255.255.252.0
          inet6 addr: fe80::da58:d7ff:fe00:5cd4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11155 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3724 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:4524763 (4.3 MiB)  TX bytes:607121 (592.8 KiB)
          Interrupt:38

eth2      Link encap:Ethernet  HWaddr D8:58:D7:00:5C:D5
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:300 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1072 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:46121 (45.0 KiB)  TX bytes:175331 (171.2 KiB)
          Interrupt:40

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:154 errors:0 dropped:0 overruns:0 frame:0
          TX packets:154 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:17797 (17.3 KiB)  TX bytes:17797 (17.3 KiB)

wlan0     Link encap:Ethernet  HWaddr 04:F0:21:23:AA:4E
          inet6 addr: fe80::6f0:21ff:fe23:aa4e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:325 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1069 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:52718 (51.4 KiB)  TX bytes:244303 (238.5 KiB)

wlan1     Link encap:Ethernet  HWaddr 04:F0:21:23:23:D0
          inet6 addr: fe80::6f0:21ff:fe23:23d0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2859 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4854 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:514262 (502.2 KiB)  TX bytes:4143503 (3.9 MiB)

Don’t know if this helps. What I also did was replace firmware with non -CT version as describe in this thread Ath10k after upgrade to 3.3

I will not reboot the device ATM as it currently runs. God knows what happens on next reboot :rage:


#14

:laughing: , don’t worry bro. Even if you would reboot, there is something that is just missing.

If in the future again wlan0 goes offline. Try to set in the rc.loca (LuCi—>startup–>(all the way down)) Put just above exit 0

iw reg set CZ

Off course also the wireless configuration files the country code on CZ. If your wlan0 somehow doesn’t go up, try

ifconfig wlan0 up

to see if anything happens. (ifconfig off course to check what interfaces are active)


#15

When it is not there, can you run lspci to test whether it is driver issue?


#16

Is this being actively worked on, or not? I don’t see anything related to wifi at all on the bugtraq. Just trying to determine if I need to abandon ship here. After waiting so long I don’t have time to ‘hope’ the base promised features will actually be delivered.


#17

In my case issues coming after install a mSATA (Kingston SSDnow mS200). Now if I do a reboot, the Wlan 5G doesn’t work and a “lspci” doesn’t show it. If I do a full power cycle, the Wlan 5G do work and a “lspci” show it.

I hope this can help to locate the bug.


#18

OK, as you said it’s probably not a firmware issue I reverted back to the “-ct” driver.

Still having the problem that 99% of the time wlan0 (5G) does not come up. I had to do 8 reboots until 5G card came up. I counted it this time.

When I do a “ifconfig wlan0 up” I just get a “ifconfig: SIOCGIFFLAGS: No such device” message. Strangely the output of lspci is not always the same.

the first time when I ran lspci I got:
00:01.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:02.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:03.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
01:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
02:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter

So it seems that both pci cards were detected. But still the device wlan0 was not created.

On the next reboot (where wlan0 was still disabled) I got:
00:01.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:02.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:03.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
01:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

So I ran a lspci after every reboot up to the 8th one, the results are strange:
reboot 2 & 4: both cards were detect but only 2G started working (LED for PCI2 & 3 are both off)
reboot 1,3,5,6,7: only 2G card detected and working (LED for PCI3 blinking)
reboot 8: both cards are detected and working and both LEDs PCI2 & PCI3 blinking.

During my tests I also had the country set to ‘CZ’ in /etc/config/wireless and rc.local, apparently I did not help as I needed 8 reboots. Also switching back to “-ct” firmware did not fix anything.

I also did all dmesgs for all 3 states although I had to shortedn it a bit at the top oth:

Here’s the dmesg when card is not even detected (most common):
[ 11.401117] procd: - watchdog -
[ 11.404497] procd: - ubus -
[ 12.409619] procd: - init -
[ 12.473047] marvell-cesa f1090000.crypto: CESA device successfully registered
[ 12.485827] NET: Registered protocol family 38
[ 12.502489] md: linear personality registered for level -1
[ 12.508372] md: raid0 personality registered for level 0
[ 12.514475] md: raid1 personality registered for level 1
[ 12.520790] md: raid10 personality registered for level 10
[ 12.526847] async_tx: api initialized (async)
[ 12.534555] md: raid6 personality registered for level 6
[ 12.539883] md: raid5 personality registered for level 5
[ 12.545227] md: raid4 personality registered for level 4
[ 12.552626] FS-Cache: Loaded
[ 12.555980] md: multipath personality registered for level -4
[ 12.563140] NET: Registered protocol family 8
[ 12.567508] NET: Registered protocol family 20
[ 12.576222] device-mapper: ioctl: 4.34.0-ioctl (2015-10-28) initialised: dm-devel@redhat.com
[ 12.587194] Key type dns_resolver registered
[ 12.594668] NET: Registered protocol family 33
[ 12.599126] Key type rxrpc registered
[ 12.602809] Key type rxrpc_s registered
[ 12.610131] kAFS: Red Hat AFS client v0.1 registering.
[ 12.615338] FS-Cache: Netfs ‘afs’ registered for caching
[ 12.653916] RPC: Registered named UNIX socket transport module.
[ 12.659854] RPC: Registered udp transport module.
[ 12.664583] RPC: Registered tcp transport module.
[ 12.669296] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 12.680301] ntfs: driver 2.1.32 [Flags: R/O MODULE].
[ 12.690520] RxRPC: Registered security type 2 ‘rxkad’
[ 12.707503] tun: Universal TUN/TAP device driver, 1.6
[ 12.712594] tun: © 1999-2004 Max Krasnyansky maxk@qualcomm.com
[ 12.723035] sit: IPv6 over IPv4 tunneling driver
[ 12.731439] gre: GRE over IPv4 demultiplexor driver
[ 12.737153] ip_gre: GRE over IPv4 tunneling driver
[ 12.757094] Installing knfsd (copyright © 1996 okir@monad.swb.de).
[ 12.765655] PPP generic driver version 2.4.2
[ 12.773010] ip6_tables: © 2000-2006 Netfilter Core Team
[ 12.782385] Loading modules backported from Linux version wt-2016-10-03-1-g6fcb1a6
[ 12.789978] Backport generated by backports.git backports-20160324-9-g0e38f5c
[ 12.872726] cryptodev: driver 1.8 loaded.
[ 12.881608] u32 classifier
[ 12.884323] input device check on
[ 12.887991] Actions configured
[ 12.891924] Mirror/redirect action on
[ 12.899636] netem: version 1.3
[ 12.908631] fuse init (API version 7.23)
[ 12.936623] usbcore: registered new interface driver cdc_wdm
[ 12.945350] Ebtables v2.0 registered
[ 12.949737] ip_tables: © 2000-2006 Netfilter Core Team
[ 12.961914] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[ 13.144121] Netfilter messages via NETLINK v0.30.
[ 13.149698] PPP MPPE Compression module registered
[ 13.155046] NET: Registered protocol family 24
[ 13.161167] usbcore: registered new interface driver ums-alauda
[ 13.167944] usbcore: registered new interface driver ums-cypress
[ 13.174874] usbcore: registered new interface driver ums-datafab
[ 13.181693] usbcore: registered new interface driver ums-freecom
[ 13.188564] usbcore: registered new interface driver ums-isd200
[ 13.195491] usbcore: registered new interface driver ums-jumpshot
[ 13.202433] usbcore: registered new interface driver ums-karma
[ 13.209442] usbcore: registered new interface driver ums-sddr09
[ 13.216287] usbcore: registered new interface driver ums-sddr55
[ 13.223240] usbcore: registered new interface driver ums-usbat
[ 13.235214] usbcore: registered new interface driver usbserial
[ 13.241106] usbcore: registered new interface driver usbserial_generic
[ 13.247672] usbserial: USB Serial support registered for generic
[ 13.262593] xt_time: kernel timezone is -0000
[ 13.270175] usbcore: registered new interface driver cdc_ether
[ 13.280496] ctnetlink v0.93: registering with nfnetlink.
[ 13.289423] usbcore: registered new interface driver qmi_wwan
[ 13.296468] usbcore: registered new interface driver rndis_host
[ 13.310774] pci 0000:00:01.0: enabling device (0140 -> 0142)
[ 13.403321] ath: EEPROM regdomain: 0x0
[ 13.403325] ath: EEPROM indicates default country code should be used
[ 13.403328] ath: doing EEPROM country->regdmn map search
[ 13.403332] ath: country maps to regdmn code: 0x3a
[ 13.403334] ath: Country alpha2 being used: US
[ 13.403337] ath: Regpair used: 0x3a
[ 13.415158] ieee80211 phy0: Selected rate control algorithm ‘minstrel_ht’
[ 13.416532] ieee80211 phy0: Atheros AR9287 Rev:2 mem=0xf1800000, irq=108
[ 13.425114] usbcore: registered new interface driver option
[ 13.430765] usbserial: USB Serial support registered for GSM modem (1-port)
[ 13.438442] usbcore: registered new interface driver qcserial
[ 13.444249] usbserial: USB Serial support registered for Qualcomm USB modem
[ 21.711605] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 21.792331] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 21.795795] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
[ 23.374152] device eth0 entered promiscuous mode
[ 23.375145] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 23.396648] device eth2 entered promiscuous mode
[ 23.482182] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 24.812094] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 24.813063] device wlan0 entered promiscuous mode
[ 24.878144] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 24.878201] br-lan: port 3(wlan0) entered forwarding state
[ 24.878220] br-lan: port 3(wlan0) entered forwarding state
[ 24.878265] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 25.370648] mvneta f1030000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[ 25.370674] br-lan: port 1(eth0) entered forwarding state
[ 25.370692] br-lan: port 1(eth0) entered forwarding state
[ 25.380694] mvneta f1070000.ethernet eth2: Link is Up - 1Gbps/Full - flow control off
[ 25.380709] br-lan: port 2(eth2) entered forwarding state
[ 25.380724] br-lan: port 2(eth2) entered forwarding state
[ 26.097800] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[ 26.870674] br-lan: port 3(wlan0) entered forwarding state
[ 27.370633] br-lan: port 1(eth0) entered forwarding state
[ 27.380636] br-lan: port 2(eth2) entered forwarding state
[ 28.481056] mvneta f1034000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
[ 28.481072] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 40.883142] random: nonblocking pool is initialized


Here’s the dmesg if card is detected but not started:
[ 11.451439] procd: - watchdog -
[ 11.454816] procd: - ubus -
[ 12.459880] procd: - init -
[ 12.523421] marvell-cesa f1090000.crypto: CESA device successfully registered
[ 12.536159] NET: Registered protocol family 38
[ 12.552776] md: linear personality registered for level -1
[ 12.558653] md: raid0 personality registered for level 0
[ 12.564740] md: raid1 personality registered for level 1
[ 12.571034] md: raid10 personality registered for level 10
[ 12.577005] async_tx: api initialized (async)
[ 12.584722] md: raid6 personality registered for level 6
[ 12.590050] md: raid5 personality registered for level 5
[ 12.595395] md: raid4 personality registered for level 4
[ 12.602792] FS-Cache: Loaded
[ 12.606137] md: multipath personality registered for level -4
[ 12.613220] NET: Registered protocol family 8
[ 12.617588] NET: Registered protocol family 20
[ 12.626338] device-mapper: ioctl: 4.34.0-ioctl (2015-10-28) initialised: dm-devel@redhat.com
[ 12.637311] Key type dns_resolver registered
[ 12.644851] NET: Registered protocol family 33
[ 12.649310] Key type rxrpc registered
[ 12.653006] Key type rxrpc_s registered
[ 12.660475] kAFS: Red Hat AFS client v0.1 registering.
[ 12.665689] FS-Cache: Netfs ‘afs’ registered for caching
[ 12.704503] RPC: Registered named UNIX socket transport module.
[ 12.710440] RPC: Registered udp transport module.
[ 12.715168] RPC: Registered tcp transport module.
[ 12.719881] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 12.730915] ntfs: driver 2.1.32 [Flags: R/O MODULE].
[ 12.741171] RxRPC: Registered security type 2 ‘rxkad’
[ 12.758318] tun: Universal TUN/TAP device driver, 1.6
[ 12.763398] tun: © 1999-2004 Max Krasnyansky maxk@qualcomm.com
[ 12.773885] sit: IPv6 over IPv4 tunneling driver
[ 12.780557] gre: GRE over IPv4 demultiplexor driver
[ 12.786193] ip_gre: GRE over IPv4 tunneling driver
[ 12.805940] Installing knfsd (copyright © 1996 okir@monad.swb.de).
[ 12.815670] PPP generic driver version 2.4.2
[ 12.823237] ip6_tables: © 2000-2006 Netfilter Core Team
[ 12.833144] Loading modules backported from Linux version wt-2016-10-03-1-g6fcb1a6
[ 12.840768] Backport generated by backports.git backports-20160324-9-g0e38f5c
[ 12.921888] ath10k driver, optimized for CT firmware, probing pci.
[ 12.928406] pci 0000:00:02.0: enabling device (0140 -> 0142)
[ 12.934103] ath10k_pci 0000:02:00.0: enabling device (0140 -> 0142)
[ 12.940576] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[ 13.113410] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[ 13.124151] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.133859] firmware ath10k!pre-cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
[ 13.142971] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[ 13.153369] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.162947] firmware ath10k!cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
[ 13.171687] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:02:00.0.txt failed with error -2
[ 13.182257] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.191748] firmware ath10k!fwcfg-pci-0000:02:00.0.txt: firmware_loading_store: map pages failed
[ 13.200735] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with error -2
[ 13.211471] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.221134] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed
[ 13.230172] ath10k_pci 0000:02:00.0: could not fetch firmware file ‘ath10k/QCA988X/hw2.0/firmware-5.bin’: -11
[ 13.240172] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-4.bin failed with error -2
[ 13.250912] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.260322] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed
[ 13.269382] ath10k_pci 0000:02:00.0: could not fetch firmware file ‘ath10k/QCA988X/hw2.0/firmware-4.bin’: -11
[ 13.279371] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with error -2
[ 13.290113] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.299539] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed
[ 13.308607] ath10k_pci 0000:02:00.0: could not fetch firmware file ‘ath10k/QCA988X/hw2.0/firmware-3.bin’: -11
[ 13.325661] ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[ 13.334943] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 1 testmode 0
[ 13.344340] ath10k_pci 0000:02:00.0: firmware ver 10.1.467-ct-_fW-018-a857715 api 2 features wmi-10.x,has-wmi-mgmt-tx,txstatus-noack,wmi-10.x-CT,ratemask-CT crc32 e76ac366
[ 13.387316] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
[ 13.397789] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.407486] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
[ 13.416445] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[ 15.300712] ath10k_pci 0000:02:00.0: failed to receive control response completion, polling…
[ 16.300707] ath10k_pci 0000:02:00.0: Service connect timeout
[ 16.306381] ath10k_pci 0000:02:00.0: failed to connect htt (-110)
[ 16.391429] ath10k_pci 0000:02:00.0: could not init core (-110)
[ 16.397381] ath10k_pci 0000:02:00.0: could not probe fw (-110)
[ 16.404742] cryptodev: driver 1.8 loaded.
[ 16.413634] u32 classifier
[ 16.416349] input device check on
[ 16.420017] Actions configured
[ 16.423991] Mirror/redirect action on
[ 16.431757] netem: version 1.3
[ 16.440477] fuse init (API version 7.23)
[ 16.468227] usbcore: registered new interface driver cdc_wdm
[ 16.476990] Ebtables v2.0 registered
[ 16.481408] ip_tables: © 2000-2006 Netfilter Core Team
[ 16.493579] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[ 16.684205] Netfilter messages via NETLINK v0.30.
[ 16.689771] PPP MPPE Compression module registered
[ 16.695128] NET: Registered protocol family 24
[ 16.701257] usbcore: registered new interface driver ums-alauda
[ 16.708037] usbcore: registered new interface driver ums-cypress
[ 16.714974] usbcore: registered new interface driver ums-datafab
[ 16.721844] usbcore: registered new interface driver ums-freecom
[ 16.728718] usbcore: registered new interface driver ums-isd200
[ 16.735627] usbcore: registered new interface driver ums-jumpshot
[ 16.742554] usbcore: registered new interface driver ums-karma
[ 16.749562] usbcore: registered new interface driver ums-sddr09
[ 16.756395] usbcore: registered new interface driver ums-sddr55
[ 16.763362] usbcore: registered new interface driver ums-usbat
[ 16.775305] usbcore: registered new interface driver usbserial
[ 16.781210] usbcore: registered new interface driver usbserial_generic
[ 16.787777] usbserial: USB Serial support registered for generic
[ 16.802775] xt_time: kernel timezone is -0000
[ 16.810353] usbcore: registered new interface driver cdc_ether
[ 16.820741] ctnetlink v0.93: registering with nfnetlink.
[ 16.829669] usbcore: registered new interface driver qmi_wwan
[ 16.836738] usbcore: registered new interface driver rndis_host
[ 16.851103] pci 0000:00:01.0: enabling device (0140 -> 0142)
[ 16.943416] ath: EEPROM regdomain: 0x0
[ 16.943421] ath: EEPROM indicates default country code should be used
[ 16.943423] ath: doing EEPROM country->regdmn map search
[ 16.943427] ath: country maps to regdmn code: 0x3a
[ 16.943430] ath: Country alpha2 being used: US
[ 16.943432] ath: Regpair used: 0x3a
[ 16.955238] ieee80211 phy1: Selected rate control algorithm ‘minstrel_ht’
[ 16.956616] ieee80211 phy1: Atheros AR9287 Rev:2 mem=0xf1a40000, irq=108
[ 16.965172] usbcore: registered new interface driver option
[ 16.970832] usbserial: USB Serial support registered for GSM modem (1-port)
[ 16.978510] usbcore: registered new interface driver qcserial
[ 16.984328] usbserial: USB Serial support registered for Qualcomm USB modem
[ 25.245293] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 25.322418] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 25.325901] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
[ 26.887942] device eth0 entered promiscuous mode
[ 26.889061] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 26.908114] device eth2 entered promiscuous mode
[ 26.992113] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 28.270792] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[ 28.271711] device wlan1 entered promiscuous mode
[ 28.336931] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[ 28.336988] br-lan: port 3(wlan1) entered forwarding state
[ 28.337005] br-lan: port 3(wlan1) entered forwarding state
[ 28.337050] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 28.880727] mvneta f1030000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[ 28.880754] br-lan: port 1(eth0) entered forwarding state
[ 28.880772] br-lan: port 1(eth0) entered forwarding state
[ 28.900721] mvneta f1070000.ethernet eth2: Link is Up - 1Gbps/Full - flow control off
[ 28.900735] br-lan: port 2(eth2) entered forwarding state
[ 28.900751] br-lan: port 2(eth2) entered forwarding state
[ 30.330707] br-lan: port 3(wlan1) entered forwarding state
[ 30.880707] br-lan: port 1(eth0) entered forwarding state
[ 30.900705] br-lan: port 2(eth2) entered forwarding state
[ 30.991131] mvneta f1034000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
[ 30.991144] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 47.311217] random: nonblocking pool is initialized
[ 51.835886] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[ 68.660831] device wlan1 left promiscuous mode
[ 68.660905] br-lan: port 3(wlan1) entered disabled state
[ 68.882119] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[ 68.883063] device wlan1 entered promiscuous mode
[ 68.883098] br-lan: port 3(wlan1) entered forwarding state
[ 68.883115] br-lan: port 3(wlan1) entered forwarding state
[ 68.948315] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[ 70.880753] br-lan: port 3(wlan1) entered forwarding state
[ 77.960763] device wlan1 left promiscuous mode
[ 77.960804] br-lan: port 3(wlan1) entered disabled state
[ 81.726917] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[ 81.727890] device wlan1 entered promiscuous mode
[ 81.793505] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[ 81.793567] br-lan: port 3(wlan1) entered forwarding state
[ 81.793591] br-lan: port 3(wlan1) entered forwarding state
[ 83.790701] br-lan: port 3(wlan1) entered forwarding state


see next post for dmesg when card is working.

I hope this helps. Just one question, is it possible that a small batch of ‘5G’ cards bought from the manufacturer are just faulty? Why else would only a few people have this problems and the others not? I mean my turris is still in stock configuration, I did not add anything except of re-socketing the ‘5G’ card twice with no luck. Also when card is not started or not even detected (dmesg also not showing any message at all) the behaviour seems totally random.


#19

this is a followup to my previous reply.

Here’s the dmesg if both cards are working:
[ 12.601853] md: raid5 personality registered for level 5
[ 12.607175] md: raid4 personality registered for level 4
[ 12.614555] FS-Cache: Loaded
[ 12.617903] md: multipath personality registered for level -4
[ 12.624989] NET: Registered protocol family 8
[ 12.629357] NET: Registered protocol family 20
[ 12.638027] device-mapper: ioctl: 4.34.0-ioctl (2015-10-28) initialised: dm-devel@redhat.com
[ 12.648999] Key type dns_resolver registered
[ 12.656479] NET: Registered protocol family 33
[ 12.660951] Key type rxrpc registered
[ 12.664619] Key type rxrpc_s registered
[ 12.672074] kAFS: Red Hat AFS client v0.1 registering.
[ 12.677264] FS-Cache: Netfs ‘afs’ registered for caching
[ 12.716715] RPC: Registered named UNIX socket transport module.
[ 12.722685] RPC: Registered udp transport module.
[ 12.727399] RPC: Registered tcp transport module.
[ 12.732123] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 12.743212] ntfs: driver 2.1.32 [Flags: R/O MODULE].
[ 12.753517] RxRPC: Registered security type 2 ‘rxkad’
[ 12.770543] tun: Universal TUN/TAP device driver, 1.6
[ 12.775635] tun: © 1999-2004 Max Krasnyansky maxk@qualcomm.com
[ 12.786066] sit: IPv6 over IPv4 tunneling driver
[ 12.792822] gre: GRE over IPv4 demultiplexor driver
[ 12.798290] ip_gre: GRE over IPv4 tunneling driver
[ 12.817891] Installing knfsd (copyright © 1996 okir@monad.swb.de).
[ 12.826346] PPP generic driver version 2.4.2
[ 12.833744] ip6_tables: © 2000-2006 Netfilter Core Team
[ 12.843547] Loading modules backported from Linux version wt-2016-10-03-1-g6fcb1a6
[ 12.851173] Backport generated by backports.git backports-20160324-9-g0e38f5c
[ 12.932221] ath10k driver, optimized for CT firmware, probing pci.
[ 12.938748] pci 0000:00:02.0: enabling device (0140 -> 0142)
[ 12.944644] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[ 13.123342] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[ 13.134075] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.143801] firmware ath10k!pre-cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
[ 13.152934] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[ 13.163325] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.172924] firmware ath10k!cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
[ 13.181671] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:02:00.0.txt failed with error -2
[ 13.192233] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.201667] firmware ath10k!fwcfg-pci-0000:02:00.0.txt: firmware_loading_store: map pages failed
[ 13.210644] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with error -2
[ 13.221374] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.231057] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed
[ 13.240093] ath10k_pci 0000:02:00.0: could not fetch firmware file ‘ath10k/QCA988X/hw2.0/firmware-5.bin’: -11
[ 13.250090] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-4.bin failed with error -2
[ 13.260826] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.270309] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed
[ 13.279384] ath10k_pci 0000:02:00.0: could not fetch firmware file ‘ath10k/QCA988X/hw2.0/firmware-4.bin’: -11
[ 13.289371] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with error -2
[ 13.300098] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.309657] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed
[ 13.318705] ath10k_pci 0000:02:00.0: could not fetch firmware file ‘ath10k/QCA988X/hw2.0/firmware-3.bin’: -11
[ 13.335756] ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[ 13.345032] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 1 testmode 0
[ 13.354425] ath10k_pci 0000:02:00.0: firmware ver 10.1.467-ct-_fW-018-a857715 api 2 features wmi-10.x,has-wmi-mgmt-tx,txstatus-noack,wmi-10.x-CT,ratemask-CT crc32 e76ac366
[ 13.397391] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
[ 13.407859] ath10k_pci 0000:02:00.0: Falling back to user helper
[ 13.417483] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
[ 13.426437] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[ 14.326273] ath10k_pci 0000:02:00.0: wmi print ‘P 128 V 8 T 410’
[ 14.332325] ath10k_pci 0000:02:00.0: wmi print ‘msdu-desc: 1424 sw-crypt: 0’
[ 14.339477] ath10k_pci 0000:02:00.0: wmi print ‘alloc rem: 27208 iram: 27120’
[ 14.392179] ath10k_pci 0000:02:00.0: htt-ver 2.1 wmi-op 2 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
[ 14.481875] ath: EEPROM regdomain: 0x0
[ 14.481881] ath: EEPROM indicates default country code should be used
[ 14.481883] ath: doing EEPROM country->regdmn map search
[ 14.481887] ath: country maps to regdmn code: 0x3a
[ 14.481890] ath: Country alpha2 being used: US
[ 14.481892] ath: Regpair used: 0x3a
[ 14.485056] cryptodev: driver 1.8 loaded.
[ 14.495192] u32 classifier
[ 14.497907] input device check on
[ 14.501591] Actions configured
[ 14.505500] Mirror/redirect action on
[ 14.513285] netem: version 1.3
[ 14.522311] fuse init (API version 7.23)
[ 14.550403] usbcore: registered new interface driver cdc_wdm
[ 14.559252] Ebtables v2.0 registered
[ 14.563713] ip_tables: © 2000-2006 Netfilter Core Team
[ 14.575815] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[ 14.724109] Netfilter messages via NETLINK v0.30.
[ 14.729670] PPP MPPE Compression module registered
[ 14.735011] NET: Registered protocol family 24
[ 14.741131] usbcore: registered new interface driver ums-alauda
[ 14.747910] usbcore: registered new interface driver ums-cypress
[ 14.754830] usbcore: registered new interface driver ums-datafab
[ 14.761646] usbcore: registered new interface driver ums-freecom
[ 14.768516] usbcore: registered new interface driver ums-isd200
[ 14.775442] usbcore: registered new interface driver ums-jumpshot
[ 14.782388] usbcore: registered new interface driver ums-karma
[ 14.789399] usbcore: registered new interface driver ums-sddr09
[ 14.796242] usbcore: registered new interface driver ums-sddr55
[ 14.803203] usbcore: registered new interface driver ums-usbat
[ 14.815142] usbcore: registered new interface driver usbserial
[ 14.821039] usbcore: registered new interface driver usbserial_generic
[ 14.827606] usbserial: USB Serial support registered for generic
[ 14.842538] xt_time: kernel timezone is -0000
[ 14.850110] usbcore: registered new interface driver cdc_ether
[ 14.860464] ctnetlink v0.93: registering with nfnetlink.
[ 14.869401] usbcore: registered new interface driver qmi_wwan
[ 14.876452] usbcore: registered new interface driver rndis_host
[ 14.890728] pci 0000:00:01.0: enabling device (0140 -> 0142)
[ 14.983018] ath: EEPROM regdomain: 0x0
[ 14.983023] ath: EEPROM indicates default country code should be used
[ 14.983026] ath: doing EEPROM country->regdmn map search
[ 14.983029] ath: country maps to regdmn code: 0x3a
[ 14.983032] ath: Country alpha2 being used: US
[ 14.983035] ath: Regpair used: 0x3a
[ 14.994850] ieee80211 phy1: Selected rate control algorithm ‘minstrel_ht’
[ 14.996224] ieee80211 phy1: Atheros AR9287 Rev:2 mem=0xf1a40000, irq=108
[ 15.004696] usbcore: registered new interface driver option
[ 15.010334] usbserial: USB Serial support registered for GSM modem (1-port)
[ 15.018034] usbcore: registered new interface driver qcserial
[ 15.023839] usbserial: USB Serial support registered for Qualcomm USB modem
[ 23.285336] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 23.362333] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 23.365861] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
[ 24.974700] device eth0 entered promiscuous mode
[ 24.976413] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 24.999702] device eth2 entered promiscuous mode
[ 25.082253] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 25.441927] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[ 25.442831] device wlan1 entered promiscuous mode
[ 25.442867] br-lan: port 3(wlan1) entered forwarding state
[ 25.442885] br-lan: port 3(wlan1) entered forwarding state
[ 25.442909] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 25.508422] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[ 26.970656] mvneta f1030000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[ 27.000739] mvneta f1070000.ethernet eth2: Link is Up - 1Gbps/Full - flow control off
[ 27.401651] ath10k_pci 0000:02:00.0: wmi print ‘P 128 V 8 T 410’
[ 27.401674] ath10k_pci 0000:02:00.0: wmi print ‘msdu-desc: 1424 sw-crypt: 0’
[ 27.402264] ath10k_pci 0000:02:00.0: wmi print ‘alloc rem: 27208 iram: 27120’
[ 27.440634] br-lan: port 3(wlan1) entered forwarding state
[ 28.391972] ath10k_pci 0000:02:00.0: ath10k_pci ATH10K_DBG_BUFFER:
[ 28.391983] ath10k: [0000]: 00008306 17FC0005 31102070 00000008 00000080 0040F7B8 00060001 00008310
[ 28.391989] ath10k: [0008]: 0FFC5C08 004460C4 00000008 00000080 00008310 0FFC5C06 0040F7B8 00446CBC
[ 28.391993] ath10k: [0016]: 00000019 00008310 0FFC5C06 00000009 00446CBC 009C8358
[ 28.391998] ath10k_pci 0000:02:00.0: ATH10K_END
[ 28.458134] ath10k_pci 0000:02:00.0: htt peer map vdev 0 peer 04:f0:21:23:aa:4e id 201
[ 28.458143] ath10k_pci 0000:02:00.0: htt peer map vdev 0 peer 04:f0:21:23:aa:4e id 249
[ 28.458588] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 28.458723] br-lan: port 1(eth0) entered forwarding state
[ 28.458742] br-lan: port 1(eth0) entered forwarding state
[ 28.458788] br-lan: port 2(eth2) entered forwarding state
[ 28.458799] br-lan: port 2(eth2) entered forwarding state
[ 28.459944] device wlan0 entered promiscuous mode
[ 28.616176] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 28.616228] br-lan: port 4(wlan0) entered forwarding state
[ 28.616248] br-lan: port 4(wlan0) entered forwarding state
[ 28.616736] ath10k_pci 0000:02:00.0: htt peer map vdev 0 peer 04:f0:21:23:aa:4e id 153
[ 29.207922] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[ 29.391974] ath10k_pci 0000:02:00.0: ath10k_pci ATH10K_DBG_BUFFER:
[ 29.391982] ath10k: [0000]: 00008709 0BFC0C10 0110298A 00000003 00008709 03FC0C13 00008711 0FFC4C23
[ 29.391987] ath10k: [0008]: 00000001 00000001 00000001 00008718 0FFC4C23 00000001 00000001 00000001
[ 29.391991] ath10k: [0016]: 0000871F 0FFC4C23 00000001 00000001 00000001 00008726 0FFC4C23 00000001
[ 29.391995] ath10k: [0024]: 00000001 00000001 0000872D 0FFC4C23 00000001 00000001 00000001 00008734
[ 29.391999] ath10k: [0032]: 0FFC4C23 00000001 00000001 00000001 0000873B 0FFC4C23 00000001 00000001
[ 29.392003] ath10k: [0040]: 00000001 00008742 0FFC4C23 00000001 00000001 00000001 00008742 07FC640C
[ 29.392007] ath10k: [0048]: 00000001 00008749 0FFC4C23 00000001 00000001 00000001 00008749 0C002009
[ 29.392012] ath10k: [0056]: 0043ED6C 00000002 00000000 00008749 0C005C06 00000008 00446CBC 009C8360
[ 29.392016] ath10k: [0064]: 00008749 0C002809 71106661 0043ED6C 0043F3D4 00008749 0C002809 71106660
[ 29.392020] ath10k: [0072]: 0043ED6C 0043F3D4 00008749 08005C08 0043ED6C 004460EC 00008749 0C005C06
[ 29.392024] ath10k: [0080]: 00000011 00446CBC 009C8368 00008749 0C005C04 81100003 0043ED6C 00000000
[ 29.392028] ath10k: [0088]: 00008749 08002802 00000003 00000003 00008749 04002802 00000003 00008749
[ 29.392033] ath10k: [0096]: 14004C4F 000000C9 0041E4BC 00437860 00000000 00000000 00008749 14004C4F
[ 29.392037] ath10k: [0104]: 000000F9 0041E4F4 00437860 00000000 00000001 00008749 14004C56 00437860
[ 29.392041] ath10k: [0112]: 009BC7C8 00000011 00000000 00003D20 00008749 14004C56 00437860 009BC810
[ 29.392045] ath10k: [0120]: 00000012 00000000 00002D20 00008749 14004C56 00437860 009BC858 00000010
[ 29.392049] ath10k: [0128]: 0000000A 00003D40 00008749 14004C56 00437860 009BC8A0 00000013 00000000
[ 29.392053] ath10k: [0136]: 00003D20 00008749 14005C03 00000001 2321F004 00004EAA 009BA754 00437860
[ 29.392057] ath10k: [0144]: 000087E4 1000200B 0043ED6C 00000000 00000000 0000000A 000087EB 04002007
[ 29.392061] ath10k: [0152]: 0043ED6C 000087EB 14004C09 00000000 01000000 000000FF 00000001 00000080
[ 29.392065] ath10k: [0160]: 000087EB 08004C07 00000000 00000000 000087EC 14004C4F 00000099 0041E52C
[ 29.392069] ath10k: [0168]: 00437860 00000001 00000001 000087EC 10004C1D 00437860 00000001 00000004
[ 29.392073] ath10k: [0176]: 00000040
[ 29.392077] ath10k_pci 0000:02:00.0: ATH10K_END
[ 30.081062] mvneta f1034000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
[ 30.081080] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 30.450639] br-lan: port 2(eth2) entered forwarding state
[ 30.450671] br-lan: port 1(eth0) entered forwarding state
[ 30.610636] br-lan: port 4(wlan0) entered forwarding state
[ 39.045796] random: nonblocking pool is initialized
[ 58.084218] mvneta f1034000.ethernet eth1: Link is Down
[ 60.081065] mvneta f1034000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off


#20

I’ve been having this issue as well and have been reading the archives at http://lists.infradead.org/pipermail/ath10k/ - seems it’s not just the T-O with the problem, although it might be related to pci-e on this board as there have been several patches relating to this problem. I don’t know if the firmware we’re using includes them though, I haven’t tried compiling it myself from kvalo’s source.

I did find a possible temporary workaround - at least it worked on my first soft reboot:

in /etc/modules.d/50-ath10k-ct I changed 2 lines to pass these parameters:

ath10k_core skip_otp=1
ath10k_pci irq_mode=1

I don’t entirely know what those modes do except that they were mentioned in some of the email archives and that the irq interrupt stuff may be related. I initially had a typo in the skip_otp line so it was only passing the irq_mode=1 and that resulted in different messages but the 5g card still did not load. I did not try the skip_otp parameter by itself.