Wlan 5g not starting most of the time


#21

Tried it on stable branch. Next 2 reboots wifi 5G was down again. So it didn’t really help. I hope they will soon release 3.5 branch which seems to be on nightly build currently. I read in the software bugs thread that some people had good results with it. But I think it’s too early to think it’s solved. I’m tempted to switch to nightlies therefore.


#22

I just tried the nightlies where they switch back to the non “-ct” drivers and ath10k. But with absolutely zero improvement. They only way to more or less reliably get-up my wifi is to pull the power plug wait 10 secs or so and put it back in. But on every reset, ‘5G’ card is not coming up again and as described earlier I need like 5-10 reboots until it comes up fine. Sometimes it doesn’t even get detected by lspci, but even if card is there it wont start 90% of the time.


#23

tried this too, i think it has improved some things but still having trouble with 5g interface.

it shows up most often from my roku3 and android phone [oneplus]. the connection is good- then dropped. android phone seems better, but i’ll have to see over time.

tried dropping -ct drivers, to non-ct drivers. not better.

tried to switch to dailies, but didn’t have right credentials. this was probably a benefit for me. so i changed to ‘rc’ instead. updated ath10k which returned me to -ct drivers.

if devs want more help with debugging or whatever, please feel free to ask me.

i still love my turris router even with this difficulty. :signal_strength:


#24

I think yours wifi card inside your Omnia could be faulty. First you need to contact tech(dot)support(at)turris(dot)cz


#25

Thx. I contacted them, let’s see what they say.


#26

OK after a few reboots, mine didn’t come up again. I found something else interesting, after doing a soft reboot, my 5g was gone and I was able to get the next soft reboot to bring it up by doing this before I initiated the reboot:

cd /sys/bus/pci/devices/0000:02:00.0
echo “1” > remove

then when I soft rebooted, it came up. Might be another coincidence but it worked once. I have also been able to get it to reappear sometimes by echoing “1” to /sys/bus/pci/rescan after removing it, but seems intermittent, and sometimes the device would appear but wifi wouldn’t start.


#27

Just wanted to add my expierence as well for future reference. My 5G suddenly stop working the same way that has been mentioned by the earlier post with TX power 0. Tried reboot twice and played with the region setting and finally it works again after reverting the region back to CZ, save & apply followed by a reboot.


#28

Well it seems there’s two different issues. One with the region and one that even region is correct card does not start. I can set whatever region I’d like. Tried ‘CH’ (local county code), CZ and NL. All of them behave exactly the same. So setting to CZ did not help at all. No matter which region was set I have to reboot 7-8 times until card comes up. Interestingly restarting by pulling the plug works always, then both cards come up fine. It’s just the soft reboot which is broken somehow.


#29

I want to share my experience too. My 5G wifi stop working after switch position to mpcie with sim-card. I tried all things mentioned there, country code, drivers, iwlist, and so on… The card was not mentioned in kernel log and neither in lspci. I thought I broke something, so I disassemble TO again, get the card out, and try it on my Laptop - all worked flawlessly. So I put it again to TO and it started to work.

It could be end of story, but sadly not.

One week later same problem. The card just stop show up, and now I was pretty sure it is not by broken card. So I try restart TO again, nothing change - 5G still not visible, but I notice interesting thing - The diodes. After restart they not glow at full power, but with last setting of brightness. So I plug TO out of power completely for a few minutes, and voila - after start of TO the diodes start with maximum brightness and 5G card start work.

I hope this help to someone simulate and maybe solve this problem.

PS: I thing I have kernel logs saved somewhere, so I can try to find them out if they are needed.


#30

Hi Jason,

How did you make this actually work

When I try “echo 1 > /sys/bus/pci/rescan” I get: “-bash: echo: write error: Invalid argument”. What am I doint wrong. didn’t want to remove the card yet, just rescan but how?


#31

I continue with this problem after update to 3.5, am I the only?

Curious, trying yesterday, in one of the reboots the 5g appear it but disappear the 2,4g.


#32

My problems got fixed by the last update - well at least for now as the problem usually appeared after few days.


#33

For me still the same after 3.5 update (with difference, that I did not install ssd, but m-pcie sata controller)


#34

No you’re definitly not the only one. I’m experiencing exactly the problems same too. But somehow the people experiencing this problems like me are out of ideas and nobody of the devs seems to have interest in looking deep into it. I mean we provided lspci, kernel-log and more but still they are not able to fix it because because they do not experience the problem as it seems.

So what can we do more. I don’t know. Either the devs should tell us or start digging into it.

I actually requested a replacement card but after their first e-mail asking me for serial number I didn’t hear a word if they will replace the card or not. If they would I could tell if the cards are faulty or if it’s a sw problem as soon as I get it.

I know it feels like shit if nobody seems to give a damn and nobody has solution to the problem and also if you don’t hear anything from the devs…


#35

To be honest, I am too lazy trying to do something with this issue, its happen once/twice a week and plug out of electricity for 10 seconds will solve it every time. I can write to tech.support[at]turris.cz and as I live in Prague I can even provide my device to team to look at it, but this would take time, and its something I don’t have much now.


#36

Hi, according to someones experience (in Czech section of the forum) it’s the result of overheating in some cases so maybe that’s your case too.


#37

Lets merge it.

@Jerry describe there that problems are USB and write that router is “hot”. At least I don’t experience that my router would be hot, and I don’t think, that 10 sec without power would be helpful. Also he have Turris 1.0, not Omnia

To me it seems to, that this cut of power is doing something like hard reset - leds start at max brightness and 5GHz work, instead of soft-reboot where leds are at same state like before reboot and 5GHz is continue not working.


#38

I agree that pulling the power for 10 secs or so also solves the problems on my side, so somehow a soft reboot is not the same as pulling the plug.

Also since 3.5 it seems the situation has improved at least. I tested now 6 reboots. On 1st, 3rd and 5th reboot it failed on 2nd, 4th and 6h card came up fine. Seems the the 2nd soft reboot fixes what was wrong on 1st reboot. With 3.4 and lower I had to reboot 5-6 times until card came up (or pull the plug, which was easier).

If they can pin down what’s not correctly resetted in soft reboot the issue should be solved.


#39

Same issue.

Hard reboot brought wlan0, 5ghz ac card back up.


#40

After last update (3.5.2) the Wlan 5G is always “disabled or not associated” now the full power cycle do not doing the trick. I will do some tries more, but I can tell you @miska, @vorner, @cynerd THIS IS COMING TO BE A BIG PROBLEM FOR ME.