Reboot doesn't work

As to me easiest is to power off/on using DIY power cord with switch (made early upon my MOX arrival) and/or issuing reboot command via CLI.

ah, interesting…over here the reboot issue only happens after changing something on the software side?

Just remote tried to reboot the mox after the update, no go. latest patch

Same for me, unfortunately. MOX after update to HBS 5.2.7 hangs after required reboot… otherwise it seems to work.

I do have exactly the same experience. MOX got frozen during reboot, with latest patch (version 4) and right after upgrade to 5.2.7.

1 Like

What is new with this issue?

What is the status of the reboot hang issue?

I have a Mox running 5.3.4 and it still hangs after rebooting after automatic updates.

I found this experimental firmware - is this still the best way forward?

1 Like

there is several releases of the workaround available, and yes, it is still the best way forward.

1 Like

Is that still the best way, but user experience shows that workaround probably does not solve the problem. But it’s definitely good to try and then possibly wait for the new version.

Yey, v4 seems to work for me. I’ll have to wait until there’s an update to know for sure.

1 Like

Unfortunately, v4 workaround still didn’t fix the reboot problem for me :frowning:

1 Like

I took MOX to a company where I don’t normally go and do everything remotely. Everything worked beautifully after the configuration but until the update and automatic restart where I had to go to the company. So now I found out that MOX has been solving a problem with restarts since 2019 and I’m rather surprised and disappointed. I can see in the settings that I can only postpone the automatic restart for 10 days, can the automatic restart be turned off completely?
Should I return the company to Mikrotik again if the developers haven’t moved on with this problem since 2019?

1 Like

I agree with Kospas. For me It is essential to update & reboot the router automatically. My blue Turris 1.0 works like a charm and I’m disappointed MOX just stops working and waits for the human touch. I love Turris MOX but if this issue will not be solved soon I will get rid of it… :frowning:

1 Like

I’ve just tried reboot-issue-workaround-v4 but the reboot failed again. I have one of the first MOXes (Indiegogo backer #312).

1 Like

When will be avaliable new version of workaround or better - the final solution?

We are not giving up, @viktor, we are trying more workarounds and if something will be promising, we will share it with the community.


Meanwhile the team is working may I suggest a hackish workaround.

It is certainly not for everyone but with a solder iron and a couple of compoments and a script you can automate the hard reboot.
And if your router is far away etc etc it could be worth the effort as a ”crazy” workaround.

  |          |
MOX <gpio> RELAY
  |          |
  |________  -  _____<POWER>
1 Like

So where is the problem? Isn’t that the board design?

No, it’s the software/firmware provided by marvell.

Edit: well, I stand corrected, it’s not closed source.


It seems that this issue is gone with TurrisOS 6.0 (right now in branch HBL). At least for me. :partying_face: