Reboot doesn't work

not really an error - it is planned that way (the last cmd line you’ve entered has a condition … first try to write to an “a53-firmware” device, if that’s failed (in your case), write to “u-boot”. The latter one was OK, so you’re good … :wink:

Thanks for explanation. For the moment about 20 reboots in row OK…

I too had the hang after reboot problem, and it’s now solved with the linked firmware update.

I’ve tried the experimental fw too (Reboot doesn't work) . And now it looks working, finally after such a long time :slight_smile:

Interestingly, after a recent update (about Apr 16, HBT) both v2 and v3 workarounds are not working for me anymore…

@pepe I am afraid that I can confirm what @Shulyaka reports.
After upgrading to 5.2.0 the issue is back and my MOX doesn’t reboot :frowning:

I would bet that this line “Turris MOX: Update firmware for SDIO card” in the release notes is the culprit.
It wouldn’t be the first time I have seen bugfix rolled out to customers and then basically reverted by the next release as someone forgot to merge the bugfix into stable :smiley:

It is not related to updating FW for the SDIO card. :100: What we observed and confirmed by the community is that workaround helps improve the state while doing reboots. Sometimes it works, sometimes it does not help. We are aware of this situation, and kernel developers are investigating this issue, which does not depend on the Turris OS version.

To add my personal experience on this : my Turris Mox was originally rebooting fine when I bought it.
I had even scheduled a weekly reboot (with crontab, as a workaround for some wifi issues).

Since the upgrade to 5.2.0, the software reboots fail : the Turris shuts down but does not restart. It just stays off. So I had to remove my scheduled reboot, and need to manually unplug/plug the device when I need to reboot it.
Upgrades to 5.2.1 and 5.2.2 did not solve the issue.

I never installed any experimental firmware.

To me, it’s a regression, that appeared at the same time as Turris OS 5.2.0 deployment.

I have the same problem. V3 (a53) of the experimental firmware doesn’t resolve it :frowning:

My MOX always reboots when instructed to do so shortly after powerup. However, if I want to reboot it after a day or so, it will always hang and only unplugging would fix it. I tried all three workaround firmwares, no change for me. My MOX is in Pocket Wi-Fi configuration and running on hbl branch.

Is it still recommended to install the experimental firmware as per reboot-issue-workaround-v3 · Turris / MOX boot-builder · GitLab if one is having problems with reboots with the MOX?

Besides not restarting properly after a reboot, Automatic Updates seem to almost always fail.

Well I installed the v3 firmware and it did not fix the reboot issue for my Mox

Unfortunately the same here. Once I though it helped as I tried to reboot several times to check if it hangs, but not - every update requiring reboot I need to go physically power off and on the device to recover

just installed the latest one for my mox so i can’t say it works with an update yet…
What is the actual issue cz is trying to tackle, is it MOX cpu hardware related?
If that is the case i would rather suggest a replacement main board unit with modified or updated HW

Update: After the 5.2.6 the mox needed a hard reboot. The interesting part here is that when i got the mox from the crowd funding phase, it had no reboot issues. Always used auto update and reboot without any issues… It started basically after 5.1.x and up.

The config is here very simple…openvpn, adblock, Basic wifi, and thats it. The only thing that is not standard is a custom made vlan on the WAN side.

My experience is identical. I also bought the MOX as part of crowd funding and automatic reboot used to work OK. Hence, the firmware is capable, but there is a compatibility issue with some recent versions of the OS… I am not in a hurry to try the experimental firmware if it doesn’t really bring improvements.

There is a 4th version of the experimental firmware
I flashed it two days ago, at first it behaved like the old one, i.e. it could successfully be restarted immediately after booting but would hang if restarted after several hours uptime (the shortest I tried was 4hrs, usually i tried after approx. 20 hrs). I then tried if it could successfully handle multiple reboots in a row (simply put sleep 300 && reboot in the local startup script and let it reboot for 3 hrs without any problems.
Today I tried again after maybe 15 hrs uptime and the reboot succeeded, I will keep trying if the reboot problem can be reproduced now with the latest firmware, maybe someone else wants to try as well and give feedback.

i will try this later today. But at the current state my MOX does reboot normally, only when an update arrives, or when i (de)activate a package or something it has reboot issues?

Okay, apparently no change, a reboot after 18hrs uptime hangs… that’s really disappointing for a router of this price point - I am giving up on this for the moment, hopefully they can find a real fix for this problem soon…

See my note in another thread: Turris OS 5.2.6 is now in the Testing branch - #19 by jada4p

I tested it more times after installing v4 patch later, mostly it is working. It is improvement, but unfortunately not absolutely reliable.

me think the most easy test is to in or deinstall some package, and see if the reboot works?

edit, installed. but no time fo fidle…