Reboot doesn't work

Yes it works for me ( as already said here )

1 Like

Hi, I tried the experimental firmware on my MOX, and it did not fix the hung reboot problem for me… Can I collect any more information for you? Specific versions of things?

TurrisOS 5.1.0
Linux 4.14.180


Also, I can’t run rescue mode anymore…
gpio: pin GPIO221 (gpio 57) value is 1
SF: Detected w25q64dw with page size 256 Bytes, erase size 4 KiB, total 8 MiB
device 0 offset 0x190000, size 0x670000
SF: 6750208 bytes @ 0x190000 Read: OK
Uncompressed size: 15717072 = 0XEFD2D0
Wrong Image Format for bootm command
ERROR: can’t get kernel image!

1 Like

Hello @jblakey,

I’m so sorry to hear that you are still having reboot issues with your Turris MOX.

In the first version of the experimental workaround as you pointed out, there is an issue with rescue mode. Can you please try this newer experimental firmware and let us know if it works for you?

Trying it out right now, thanks!


First reboot after installing it succeeded, second reboot failed to complete. Hung here:

[ 133.715382] br-lan: port 5(wlan0) entered disabled state
[ 134.111096] mvneta d0030000.ethernet eth0: Link is Down
[ 139.283167] reboot: Restarting system

but “run rescue_bootcmd” seems to be working again, which is a bonus!:slight_smile:


Can you please send me output from the serial console before it tries to load kernel? It would be really to helpful.

Hi, here you go,


CZ.NIC Turris Mox Secure Firmware version v2021.01.22 (Jan 22 2021 17:10:27)
Initializing DDR... done
NOTICE:  Booting Trusted Firmware
NOTICE:  BL1: v2.4(release):v2.4-199-g986f8330e (Marvell-devel-18.12.2)
NOTICE:  BL1: Built : 17:10:48, Jan 22 2021
NOTICE:  BL1: Booting BL2
NOTICE:  BL2: v2.4(release):v2.4-199-g986f8330e (Marvell-devel-18.12.2)
NOTICE:  BL2: Built : 17:10:48, Jan 22 2021
NOTICE:  BL1: Booting BL31
NOTICE:  BL31: v2.4(release):v2.4-199-g986f8330e (Marvell-devel-18.12.2)
NOTICE:  BL31: Built : 17:10:48, Jan 22 2021

U-Boot 2021.01-00012-g0e5db52d8f (Jan 22 2021 - 17:10:30 +0100)

DRAM:  1 GiB
WDT:   Started with servicing (60s timeout)
Comphy-0: SGMII1        3.125 Gbps
Comphy-1: PEX0          5 Gbps
Comphy-2: USB3_HOST0    5 Gbps
PCIE-0: Link up
MMC:   sdhci@d8000: 0
Loading Environment from SPIFlash... SF: Detected w25q64dw with page size 256 Bytes, erase size 4 KiB, total 8 MiB
Model: CZ.NIC Turris Mox Board
Net:   eth0: neta@30000
Turris Mox:
  Board version: 22
  RAM size: 1024 MiB
  Serial Number: 0000000D3000824D
  ECDSA Public Key: 0300d2e05187e4c758adb789727b7a7458e69b9dc82fe1f405bc9821e6e91703df62f79455cafd83b69368fca8c51f33c501900dc50829ca583623189012d5dbb2a383
  SD/eMMC version: SD
Module Topology:
   1: Mini-PCIe Module
   2: Topaz Switch Module (4-port)

SF: Detected w25q64dw with page size 256 Bytes, erase size 4 KiB, total 8 MiB
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
2070 bytes read in 76 ms (26.4 KiB/s)
## Executing script at 04d00000
19412 bytes read in 56 ms (337.9 KiB/s)
10309640 bytes read in 495 ms (19.9 MiB/s)
Moving Image from 0x5000000 to 0x5080000, end=5aa9000
## Flattened Device Tree blob at 04f00000
   Booting using the fdt blob at 0x4f00000
   Loading Device Tree to 000000003fafe000, end 000000003fb05bd3 ... OK

Starting kernel ...

Oh, and with the new firmware “run rescue_bootcmd” does not work anymore…

@Pepe just let you know that the second exp. firmware didn’t fix the reboot issue for me, reboots via ssh are still a no go …

I just successfully rebooted my MOX since I bought it over a year ago.

Thank you…
Thank you…
Thank you…

My MOX just performed it’s first reboot after two years stubbornly refusing to do so! :wink:

Is it recommended to install this firmware?
My MOX is located in a remote location where I would really benefit from working automated reboots (as I would like to have automated updates running).

The firmware is not known to break anything.
But you will have to restart the board if you want to know if it solves the reboot issue for you, which it may not, and in that case if your board is in a remote location, you will have to go there.

1 Like


After my MOX hung again after upgrade to 5.1.10 I installed the firmware right now and directly the first reboot (after the again hanging reboot after installation) and each of the following ~15 worked flawlessly. I will update this post if the issue reoccurs.

Hi all,

on my MOX classic reboot works properly now, I can recomend this firmware update !
Thx for solving this annoying bug !

1 Like

Hi! Just wanted to report that the reboot-issue-workaround-v2 fix also works for my MOX. Before applying the fix almost every reboot had this issue, and after applying the fix there were no issues so far. Thank you so much!


@pepe V3 of the experimental firmware did the trick for me (at least for my mox board). The first reboot after flashing didn’t work, but after a power cycle all test reboots (via ssh, (Re-)Foris & LuCI) are working fine … will test more this week. Thanks for the efforts to nail this down! :wink:

For reference:

By a chance I learned that there is another attempt to solve this puzzle (sorry @pepe you didn’t know about this to those which announced this trouble :wink: Anyhow, I followed instructions at above mentioned link, and even though I experienced some errors


mtd write trusted-secure-firmware.bin secure-firmware
Unlocking secure-firmware …
Writing from trusted-secure-firmware.bin to secure-firmware …
root@turris:~# mtd write a53-firmware.bin a53-firmware || mtd write a53-firmware
.bin u-boot
Could not open mtd device: a53-firmware
Can’t open device for writing!
Unlocking u-boot …
Writing from a53-firmware.bin to u-boot …

after reboot it seems to work - i.e. after repeated reboots (from ssh) all 10 cases were successfull!

CONGRATS!!! (hoping not too early)