Wifi problems – where to start troubleshooting?

I have intermittent wifi problems and am hoping you can help with suggestions on where to start troubleshooting.

  1. DNS lookup from time to time takes a very long time or doesn’t work at all. Software that connects directly, using ip-addresses like my email client, continues to work as normal.
  2. Sometimes all traffic stops totally. But my computer never loose the wifi connection.
  3. Turning of wifi on the client and reconnecting restores everything, both access to the admin interface and all other internet connections as well. Without any delay, as soon as my Macbook is connected to the wifi again all traffic resumes.
  4. Recently, while trying to find the cause for all this, I’ve noticed that when I’m experiencing the problems on my clients, the admin interface is unavailable as well. When trying to access, the request times out.
  5. Wifi signal is around -50 dB.
  6. While I’m experience some problems when using my iOS devices, I think they are more severe when using my Macbook Pro.

Any ideas?


This sounds similar to issues I’ve been experiencing this week as well.

Please try to use 2 different SSID names, one for 5Ghz and one for 2.4Ghz.

Connect the client with more problems to one network, and forget the other one.
Verify which frequency give you problems.

I think that’s just what everybody is experiencing. Those are the same issues I have. There are other threads in this forum dealing with these troubles. I think I tried everything but nothing resolved the issues 100%.

I will wait while being disappointed. After spending 320€ I expected something that was hackable beyond “getting it to work as advertised”.

1 Like

There is planned update for next week, which should fix wifi problems and if it doesn’t, there will be another update (? - probably) at the end of January

I would sound harsh if I added anything to this discussion. It’s just such an essential feature, you know? I don’t want it next week, I want it two weeks ago.

I know. I’m just giving you informations what I heard.
I had also wifi issue, but I switched to nightly and problem was gone.
Some users from IRC doesn’t have any issues with nightly. You can try it and let us know your result.

AFAIK: @Vaclav said in Czech section:
"WiFi issue is really complicated (pretty specific) and most users doesn’t have this issue"
and some others members said to him that almost everybody has this issue.
Also it is mention again in Czech on their twitter - some other user complained about it and he is pissed off like you.

Also Vaclav mention that they’re working on bug list, which would be connected with support team.

Back to OP post:
3. Should be solved with TurrisOS 3.5 (temporary solution for now switch to nightly branch, but its not recommended by Turris team)
4. same as 3.

As I said, don’t get me wrong, I like the project and the idea and everything. I work as a systems administrator, I know how badly things can go awry, it’s not a very thankful occupation from time to time. This time it hit someone else :relieved:

Has this problem, or a similiar, surfaced over the last month. Me and my family is once again having wifi-problems. Our devices, all Apple products, suddenly looses the internet connection but are still on the wifi network. Turning wifi off and then on again is all that’s needed to continue browsing the web etc.

Any ideas?

I am experiencing a similar issue - my Apple devices using Wifi periodically lose their internet connection.
In this situation also my ESP8266 based IoT devices do not connect at all to the Wifi network.
A reconnection for the network adapter (not Wifi) solves the issue most of the times for a couple of hours (in the GUI: Network->Interfaces->Reconnect this interface). A reboot of the turris always solves the issue for a couple of hours ;-(
I have the feeling that this issue started to surface after the KRACK fixes were applied …
Somebody experienced the same ?

I too am having the same WiFi issue since the beginning and the only solution is to reboot the router… When the hell will this be fixed???

(I’ve been quiet thinking this will be resolve, but not…)

I have the same problem with WiFi, iPad device, the solution is to turn off/on WiFi on iPad. The problem started before KRACK fix (maybe after last big update). Omnia router.

Try to sign in to LuCI (then at the top) > Network > Wireless > radio0:… > Wireless Security > Cipher = Force CCMP (AES) > Save & Apply

And do it again for all SSIDs (radios) that you have set.

If it helps to solve the problems for the rest of us then just remember that you have to change the password for Wi-Fi in LuCi and not in Foris because the settings would return to the original TKIP and CCM (AES).

For the last couple of months, I’m having this problem a lot again: My devices and laptops are connected to the wifi network, but can’t communicate with the internet. Any ideas for a permanent solution?

perhaps running a traceroute could shed some light where the dead end lies, both from the router (LuCI) and the client(s). To see whether it might be an DNS issue suggest to traceroute ip addresses (e.g. and fully qualified domains.

Just did – and now it’s worse than before. I can’t even log in into Luci at and traceroute from the client fails as well. So, wifi is connected, network is not.

Are the clients actually getting dhcp leases from the router?

For a while at least, internet connectivity is working for some timme after I connect to the WiFi. What’s the best way to check if my devices (iOS/MacOS) looses their network settings?

When my computer loose connectivity with internet, I can ping all the ip addresses I try, but can’t do a traceroute to any of them. Is that a hint of any sort?

If you can ping WAN addresses from the clients then they got basic inet connectivity (and dhcp). ping and traceroute are using different methods and different protocols.

Either there is a routing problem, or a DNS problem or protocols (tcp/udp) being blocked. See if you can connect a client with a lan cable to the router and whether that makes a difference. Start troubleshooting at the router (LuCI -> Network -> Diagnose). If the router can ping and traceroute wan ip addresses and domain names then the issue is between router and clients. Also ping/traceroute lan addresses from the router.

If there is an DNS issue on the WAN try disabling DNS forwarding and/or DNSSEC through foris.

If the issue is on the lan side check the firewall settings of the router (zones and bindings to interfaces and rules).

And see to the router’s log (LuCI) for any hints/pointers to the issue.