Wifi problems – where to start troubleshooting?

I had a completly different cause for a weak and instabe wifi …

Up to recently I used an internal SSD only and everything was fine. Then, recently, in order to use PaKon, I activated Storage and installed an USB 3.0 stick. The frequency interference of the USB stick caused the instable and weakended wifi. I tried various different USB sticks and both USB ports on the Turris Omnia - no progress. Finally, the use of a well shielded cable to distance the USB stick from the router did the job.

I don’t have an ethernet adapter for my Macbook Pro available at them moment. But when the connection just died again, I tried to ping the router and got response from – but can’t access Foris/Luci on Can any conclusions be drawn from that fact?

could be a firewall issue, either on the client and/or the router, where ICMP (ping) is allowed but tcp/udp are not

But why would that issue not be present all the time?

that is a bit difficult to debug with the information at hand.

one more thing - how is the TO connecting to the inet - via fibre or a (a/v)dsl modem? If latter there might be routing conflict between modem and TO router, perhaps you could see IP address assigned but no internet connection

When connection dies, I can ping but not traceroute to from my clients.

ping is point-to-point (aside from using ICMP) and finding, which could be either the TO router or the (a/v)dsl WAN modem, if latter is present.

traceroute is looking for nodes/hoops (aside from using UDP) and not finding any.

So, it is either a routing issue for traceroute, meaning a conflict between the TO router address and the (a/v)dsl WAN modem, if latter is present.
Or, TCP/UCP protcols/ports are being blocked somewhere.

My Omnia’s WAN is connected to a fiber converter. Guess that could be an equivialent of a DSL-modem in this case?

Thanks for your suggestions so far, I’ll bring my ethernet adapter home from my office next week and investigate further.

but I did just realized that there is one circumstance that makes it more probable that the problem is somewhere in the client/the Omnia rather than the Omnia/fiber converter: When one of my devices get a connection problem, all other still works just fine.

To my humble understanding they serve different purposes and thus that should not be the culprit, also considering

Suppose that the lan devices are all dynamic dhcp as opposed to static? If latter case however you might want to check whether a static ip is assigned twice (to different clients)

Yes, all devices get a dynamic IP address from Omnia’s DHCP server.

what happens if you set a dns server manually on the macbook, e.g., overriding the TO router (and supposedly the IPS’s dns server).

That’s what I’ve already. Did just remove my custom settings, to see what happens.

Had been thinking but not voicing it that the issue might perhaps be related to (particular) Apple products, respectively particular iOS/macOS (versions). However after reading this, albeit the WAN setup is different, it seems a (distant) possibility

Thanks for the link to that thread. I haven’t thought about timing, if this happens at the same time past a full hour or similar. Will keep an eye on that, as well as to wether things resolves by themselves after a few minutes.

Hello @Tom,
I rather discussed your issue with my colleague and can we know which USB 3.0 stick are you using?
In your case, there is a possibility that this can happen, if you’re using a cheap device, which also transmits some signal. The workaround with USB extension cable sounds good, but even cheap/unknown USB 3.0 extension cable should do it, too.

I’m curious that nobody from here asks you, if it happens on 2.4 GHz or 5 GHz frequency.

Hello Pepe,

I used/tested rather expensive - high quality and very fast USB 3.0 sticks from major brands.

  • Verbatim 49173 32GB Store n Go V3 USB 3.0


  • SanDisk Ultra Flair 32GB USB-Flash-Laufwerk USB 3.0

But by the way, the initial attempt to remedy this weakended wifi signal problem with an extension cable
(I used: “deleyCON [1m] USB 3.0 Super Speed Kabel”) did not really solve the issue. I was mistaken.

So finally, I re-partitioned my TurrisOmnia internal mSATA SSD (Samsung 1TB 850 EVO) into two drives. One large ext4 formatted as my original NAS and a smaller new one (30GB) btrfs formatted for /srv. This solved the weakened wifi signal issue for good - so I’m happy now with this solution.


any news on this ? For me this happens on my 5Ghz wifi and I’m seriously thinking about getting a new router by now. I’m on Mac and iOs mostly, but the one Android and Windows device seem to have a similar problem.
Sometimes it recovers (see screenshot) sometimes a have to switch wifi on and off.

The thing to note is it’s not all devices experience this at the same time.
I also have tried setting “Cipher = Force CCMP (AES)” as siuugested above, but no luck.

Currently on:

Turris OS version 3.10.1
Kernel version 4.4.131-a2dbf3bef3d0c1f725e0a5f0801935a1-2

So what’s the advice currently? Upgrade to new version? Check particular logs ?



My problem seems very similar. Generally, the router works well. I am currently using it as a basic router with default configuration. After a random amount of time (hours, days, or weeks), the device (tested Macbook Pro, Android devices, Chromecast, and Denon AVR) has very slow internet, but still strong signal. Disconnecting and reconnecting the device usually fixes it. If it doesn’t, rebooting the router fixes the problem. From time to time, DNS lookup becomes slow. Usually:
$ time nslookup forum.turris.cz

Non-authoritative answer:
forum.turris.cz canonical name = proxy.turris.cz.
Name: proxy.turris.cz
real 0m0.013s
user 0m0.003s
sys 0m0.005s


$ time nslookup forum.turris.cz

Non-authoritative answer:
forum.turris.cz canonical name = proxy.turris.cz.
Name: proxy.turris.cz
real 0m6.028s
user 0m0.006s
sys 0m0.009s

Six seconds is a long time to wait for DNS resolution, and web pages load intermittently and slowly. Disconnecting and reconnecting usually solves it. If not, rebooting the router always solves it.

Things I checked:
The 2.4 and 5 Ghz radios have different SSIDs. It happens more on the 5 Ghz radio.
I have not modified the router hardware (except carefully screwing in the antennas which were loose)
No USB ports used
The cable modem is in bridge mode (Rg Passthrough) specifying the Turris Omnia MAC Address
It is using default settings for everything I know, but I haven’t tried a factory reset yet.
We have a couple dozen devices connected to the router, including roku, AVR, lock, power outlet switch, thermostat, etc.

Unless someone can suggest a better way to investigate, I’ll probably just try a factory reset first.