Vfat partition always mounts to /tmp/run/mountd/sda1

solved

#1

I have added an mSATA card to my Turris router.

On this card I have placed a vfat partion and one for LVM.

I don’t want to mount the vfat partition.

Now the vfat is always automatically mounted to /tmp/run/mountd/sda1 regardless what I do.

My last idea was to specify my own mountpount (e.g. /mnt/sda1) and to check how the system will behave.

Now the system behaves very strange: I have two mounts now: one in /tmp/run/mountd/sda1 and one in /mnt/sda1.

What can be done to convice the Turris not to mount my vfat partition?


Omnia Apple Mac NAS - Sharing HFS+ Drives [MacOS/OS X, non-APFS] (e.g. Time Machine, Shared Folder, ..)
#2

May i ask what you going to use vfat partition for? Or why you even choose vfat as filesystem?

Could you give the output of this command:

cat /etc/config/fstab


#3

Currently it looks like this:

config global
option anon_swap '0’
option anon_mount '0’
option delay_root '5’
option check_fs '0’
option auto_mount '0’
option auto_swap ‘0’

config mount
option uuid '1253373f-d88b-4286-b7ba-4e2b14ad9d73’
option enabled '1’
option target ‘/srv’

config swap
option enabled '1’
option device ‘/dev/mapper/vgTurris-swap’

config mount
option uuid '6075-3484’
option target '/mnt/sda1’
option enabled ‘1’


#4

Oke, could you also give me the output of this.

blkid


#5
/dev/mmcblk0p1: UUID="4f32477e-ac11-415f-9699-60e865844b2f" UUID_SUB="ddfcf721-a3dc-45a7-93a5-84cebe621d5a" TYPE="btrfs" PARTUUID="4989f88a-01"
/dev/sda1: UUID="6075-3484" TYPE="vfat" PARTLABEL="boot" PARTUUID="e9f23244-bdcd-47d8-9f96-2a234798fa96"
/dev/sda2: UUID="k5By8V-0Y53-k1Sp-Iy2R-YgWv-Ph1X-ZXpXTM" TYPE="LVM2_member" PARTLABEL="data" PARTUUID="2ead8d5e-d857-4e43-b625-27f4cb7aa819"
/dev/mapper/vgTurris-lxc: UUID="809c478d-e359-4b52-9d7c-fc9a6a493b93" UUID_SUB="1253373f-d88b-4286-b7ba-4e2b14ad9d73" TYPE="btrfs"
/dev/mapper/vgTurris-swap: UUID="5f020abd-fc43-4f24-9ca5-d64c04a0d03a" TYPE="swap"
/dev/mmcblk0: PTUUID="4989f88a" PTTYPE="dos"

#6

In your /etc/config/fstab file,

change

config mount
option uuid '6075-3484'
option target '/mnt/sda1'
option enabled '1'

to

config mount
option uuid '6075-3484'
option target '/mnt/sda1'
option enabled '0'

#7

Same result.

Filesystem                Size      Used Available Use% Mounted on
/dev/mmcblk0p1            7.3G      2.1G      5.2G  29% /
tmpfs                  1011.2M    732.0K   1010.5M   0% /tmp
tmpfs                   512.0K      4.0K    508.0K   1% /dev
/dev/mapper/vgTurris-lxc
                        100.0G    889.9M     98.2G   1% /srv
/dev/sda1                 1.0G      4.0K      1.0G   0% /tmp/run/mountd/sda1

#8

Did you give the Omnia a reboot?


#9

Yes - I rebooted the device after this change.


#10

Just a moment. Gonna take a look around.

Could you give the output of this…

cat /etc/config/mountd


#11
config mountd mountd
option	timeout		60
option	path		/tmp/mounts/

#12

I thought i had read this issue somewhere else…

LuCi–>Startup–>mountd click on “enabled” (which disables it on startup and click on “stop” all the way to the right to stop the process now)

Let me know how it went.


#13

I did this:

/ec/init.d/mountd disable

After reboot I was rid of this mount.

Thank you!


Partitions on the SSD disk mounted twice
#14

Very nice!! GREAT SUCCESS!!


#15

Please mark this topic as “solved”.


Po aktualizaci - restartu, se odpojí NTFS NAS
#16

But it also stops the automatic mounting of USB keys, no? (I have the same problem and I do not want to disable automatic mounting.)


#17

go to LuCI > Mount Points > Anonymous Mount

Honestly mountd should never get installed since it’s a legacy package


closed #18