Turris OS 6.0.4 is now released

Dear Turris users,

This time, we prepared a huge last hotfix for Turris OS 6.0 series despite it contains one breaking change, which is not actually the breaking change, because these packages were empty and they could not be used as they were removed in Linux kernel 5.3, but it is possible that some of you have it installed, so we wanted to be sure that you know about it. Also, it is quite unusual that hotfix releases include new features, but we made an exception on this thing since Christmas is coming. We changed our Christmas package to work with the recent LED changes! :christmas_tree:

We wanted to provide users a simple way to get firmware for Wi-Fi 6E cards. Our user wanted to have the Snowflake package, so we fulfilled the wish, and it is included there as well. Among other things, we added LibreSpeed packages so that we can start working on Turris OS 6.1 and Turris OS 6.2. releases.

Here are the release notes for Turris OS 6.0.4:
:boom: Breaking Changes
• Dropped packages for old ISDN4Linux

:rocket: New Features
• Added 10k passwords from Turris Sentinel to common passwords
• Added packages for LibreSpeed
• Added package Snowflake
• Added firmware package for AsiaRF AW7916-NPD
• Added branch name to automatic snapshots

:bug: Bug Fixes
• Fixed network diagnostics module
• Fixed lighttpd module for rrdtool
• Fixed inaccessible router through hostname when a client didn’t send its hostname
• Fixed crashing Sentinel FWLogs

:pushpin: Updates
• Christmas updated to be working with recent LEDs change
• Linux kernel updated to 5.15.82 and 5.10.158
• PHP7 updated to 7.4.33
• PHP8 updated to version 8.0.25
• OpenSSL updated to 1.1.1s
• wolfSSL updated to 5.5.3 (CVE 2022-42905)
• SQLite3 updated to 3.40.0
• cronie updated to 1.6.1
• golang: updated to 1.18.9

Your device will be automatically updated to this version unless you are using approvals/delayed updates or you have SDIO card plugged on your modular router.

As always, if you find any bugs, please don’t hesitate to reach out to us.


Known bugs:

This is great, will update my TO ASAP, but what about MOXes with SDIO? They are more and more lagging behind with any kind of fix or feature and I don’t see any progress at all there. That would be a great christmas gift :worried:. What’s the point of automatic upgrades and latest security fixes when your entire device lineup is stuck on a stale sidetrack branch?

1 Like

MOX classic, HBK branch, .5 GB, 2x WiFi, simple config, all seems OK. (*)(%)(+)
TO 2016, HBT branch, 2 GB, 2x WiFi, HaaS, RIPE Atlas, Sentinel, lxc, simple config, all seems OK (*)

(*) for my simple case is rainbow working
(%) except SDIO WiFi.
(+) USB 3 flash not recognized

When christmas is enabled it always set LEDs to the highest brightness even when I set it directly with button on Omnia.

MOX start (1GB, E module, no wifi) after update completely dead, did not boot up (I tried couple power cycles). I did factory reset to 6.0.3 and tried update to 6.0.4 from factory reset, but again, MOX was dead. Eventually I prepared fresh install of 6.0.4 on second SD card and it seems to work so far.

Nextcloud is still not working, initial setup still fails with this error message (like it did with all Turris 6 versions so far):

Error while trying to create admin user: Failed to connect to the database: An exception occurred in the driver: SQLSTATE[HY000] [2002] No such file or directory

Please fix this bug!

We would like to, but bugs shouldn’t be reported here but through the official channels Issues - Turris Documentation. Otherwise, we need to know more details and the forum is not meant to be a bug tracker, so sometimes it can be lost here in many posts. However, I know that @mvasilek was looking into Nextcloud.

Turris has after this update an open web server to the Internet again in the similar way how it was in case of disaster during initial version 6 release.
Luckily now it needs to a login name and password; I don’t know what login name is required …

That’s HAAS honeypot (minipot), nothing to worry about…

Sorry, @Pepe , but if someone official reads and responds to that I expect that the bug has been noticed by the staff - especially as the page you linked offers no posibility to report bugs and instead hints me to gitlab where I cannot post without the need to register.

The bug itself was mentioned by several users before in the forum - and for me Nextcloud was the reason that made me join the Mox campaign. But sadly Nextcloud on Mox never reached a usable slate - and the fact that the provided Nextcloud versions are always outdated is also bad. As far as I can see it in the install data Mox Nextcloud is stil on 22, while Nextcloud itself just dropped support for 23.

Question: why is registering to report a bug that big an issues (btw, you can login via github)? I think that if reporting a bug one should be responsive for follow-up questions and maybe even tests, so anonymous bug-reports are not really cutting it in that regards (I wish the turris team would have enough resources and man-power to follow up on any hint of things going wrong, but realistically they are limited in what they can tackle and so need to prioritize what they work on, personally I do not consider “reachable bug-reporter” a show-stopper, but that is my subjective take on this).


Nextcloud only supports updating one version at a time and we don’t want to do such big changes in patch releases, so every minor Turris OS version gets one update. Turris OS 6.1.0 will get Nextcloud 23, 6.2.0 will get 24, etc.
I am aware of the database connection issue, but I was not able to reproduce it on my Omnia, so I don’t know under which conditions this is happening. It would be nice to have an issue created from someone who has this problem.


@jondifool Update to this release solved my Problem.
I rolled back to 5.4.4 and updated to 6.0.4. The reboot after the update need a lot of time. But now luci and reforis work again. :muscle: :slightly_smiling_face: :+1:

1 Like

This is not the case. The forum reports were about a different Nextcloud bug introduced with TOS 6 which was promptly identified and fixed in TOS 6.0.2.

Your issue is related to the fact that Nextcloud can’t connect to the database, either because it’s not running or it hasn’t been installed/configured (properly). Same as @mvasilek above I wasn’t able to reproduce your issue by installing NC on TOS 6.0.4 and I don’t see any other related reports. Likely it is an individual problem you are encountering.

You can fix the ‘not running’ issue quite easily by issuing the following two commands:

/etc/init.d/mysqld enable
/etc/init.d/mysqld start

If that results in an error message or doesn’t fix the problem I suggest uninstalling and then reinstalling Nextcloud. Backup any Nextcloud data first.

Rainbow still does not work correctly, if I set …

  • Transmit on
  • Link off
  • Receive off
    … so any scheduled LED brightness change
0 07 * * * /usr/bin/rainbow brightness -p 10
00 09 * * * /usr/bin/rainbow brightness -p 30
00 17 * * * /usr/bin/rainbow brightness -p 10
00 18 * * * /usr/bin/rainbow brightness -p 5

activates “Link on” again.

Regarding rainbow (which I consider purely cosmetic, so an observation not a bug report): I noticed that after a reboot the LEDs come up at maximum brightness, but the system seems to remember the last state. In my case I operate the LEDs at minimum brightness (but not off) and it normally takes 8 button presses to cycle through all brightness levels, same after a reboot, indicating that the nominal state was already minimum brightness.


MOX A+D update from 6.0.3 → 6.0.4 - smooth sail.
Reboot worked - fantastic (as I didn”t have to go down to the basement :))

Great work team👍

1 Like

I can confirm this. Would be great if this could be fixed :wink:


Thank you mate, I will try that.