Turris OS 4.0 beta7 is released!

I don’t know … when I am at home, I will test it.

same ( mox classic ) here. emial notifications ( over SMTP turris ) does not work, but it does sent a test notification to the notification section.

I was able to reproduce it in beta7 release. Just to be sure, would you mind to send me output of the command sentinel-certgen mailpass or confirm me that you have the same issue as I do?

In my case, it ends on this output:

FileNotFoundError: [Errno 2] No such file or directory: '/etc/sentinel/mailpass'

As a hotfix you can create a folder /etc/sentinel by this command:

mkdir -p /etc/sentinel

More details about this issue can be found on our Gitlab:

Where you can check that this is already fixed in upcoming beta8 release, which will be released soon.

1 Like

This bug was reported to us earlier in this thread, we found the culprit and it is already fixed in beta8.

Would it be possible to tell us more details about it? So we would be able to look at it. I am not able to reproduce it on my end as Pakon is running pretty solid here. Does it crash? If yes, it should be restarted itself automatically, but there should be something in logs. If not, you don’t see new data in Foris? Are they present in CLI from command pakon-show?

We are not developers nor maintainers of Adblock in OpenWrt. Adblock among the other packages is pulled directly from OpenWrt packages repository as they are. What I can do for you is to see if I am able to reproduce it and if yes then cooperate with the developer to get it fixed.

Why it wouldn’t? What will be necessary is to add manually token, which you need to get from
https://haas.nic.cz/ and fill it to file /etc/config/haas.

1 Like

hi there, thank you fotr the answers.
Problem is that it took me ( a linux nOOb) a week to get the mox classic with 4B7 to work with a VLAN PPPoE connection. It works now steady in Luci, but in the forris section it gives me errors in the WAN & network interfaces section.
And since it is steady now, i can;t fiddle around with the risk to have it offline again, workwise.

So, within a week or so i am able to do & continue the beta stuff, sorry for that.

Best, Dikke.

Also, is the honeypot option safe to use in this version?

“'Why it wouldn’t?”’

Well, since this in my humble opinion ( but what do i know ) a true beta release. Thats why.
But thanks for the answer.

by the way, this is what forris tells me at /foris/config/main/wan/

1 Like

Maintenance->Enable notifications, SMTP provider Turris, valid Recipient’s email->Send testing message.

Sending of the testing message failed, your configuration is possibly wrong.

Same for automatic notification.

This error is repaired in TurrisOS 4.0-beta8 … https://forum.test.turris.cz/t/turris-os-4-0-beta8-is-released/10734

Please, upgrade your system.

Beta 8 is available … it was released with small delay yesterday evenings

Not for my MOX. Automatic and manual update does not report anything.

BusyBox v1.28.4 () built-in shell (ash)

      ______                _         ____  _____
     /_  __/_  ____________(_)____   / __ \/ ___/
      / / / / / / ___/ ___/ / ___/  / / / /\__
     / / / /_/ / /  / /  / (__  )  / /_/ /___/ /
    /_/  \__,_/_/  /_/  /_/____/   \____//____/

 TurrisOS 4.0-beta7, Turris Mox

I still have beta 7.


Maybe there’s an old banner.

1 Like

Very very old :slight_smile:

Is it beta8?


Powered by LuCI branch (git-19.203.83308-6b53805) / TurrisOS 4.0-beta7 d4ba1f0

Next issue: Restart via LuCI hangs MOX.

You are right … but I had beta8 on my MOXes yesterday evening … on Wednesday was released beta 8 version in HBT branch (aka RC) and this version worked me fine … with mail notification too.

Incredible! :slight_smile:

And the pkgupdate tells me … targetOS beta8 ???

1 Like