Turris OS 4.0 beta7 is released!

Dear Turris users,

We received a security notice in Python2 and Python3, where was found CVE-2018-20852, but after checking it, we saw that in OpenWrt 18.06, there is a vulnerable version. We fixed it in openwrt/packages repository in all branches together with updating Python2 and 3 to their latest versions. We would like to have your routers secure and that’s why we are releasing a new version of Turris OS 4.0 to you, which is just security release.

Release notes:

  • python3: updated to version 3.6.9
  • python2: updated to version 2.7.16
  • python{2,3}: fix for CVE-2018-20852

When you are using our previous release - Turris OS beta6, you should be updated to this version within a few hours automatically. We appreciate any feedback for this release.

Enjoy the release.


Known bugs:

Turris Omnia specific

  • Second CPU ethernet port to switch chip is disabled, only one of two ethernet ports between CPU and switch is in use.
  • Old version of libmariadb when using Nextcloud from Turris OS 3.11.x.

Turris 1.x specific

  • Currently not working because of kernel issues. Please do not test this release on Turris 1.x.

I have had problem with animation in FORIS in that version (TurrisOS 4.0 beta7).
Test connection in WAN, test DNS in DNS tab, run speedmetr in Netmetr tab etc.

And don’t work sending test email from Maintenance tab via SMTP server Turris too.

1 Like

Potentially known issue

1 Like

I confirm the fix in Chrome (Omnia with Turris OS 3.11.5 and Mox with Turris OS 4.0 beta7).

Hello everybody, I have this on Turris Mox (turris OS 4.14.132) and it Turris Mox cannot reboot after inserting reboot command from command line or from web interface … it looks like system is shutting down, but… reboot will not continue. Red diod is not flashing and it is needed to unplug power supply for few seconds and connect it again - then router correctly boots into Turris OS.
Has anybody the same problem or not ?

1 Like

+1 for the reboot issue from me

I have sometimes the same problem. But SW is still only beta version, so it is probably can happens

Thanks for reporting. It will be fixed in Turris OS 4.0 beta8 release. If you are using HBK/HBD/master branches, it will be there working within a few hours.


running 4b7 on mox, openvpn LAN access is not working. vpn to MOX works, but no LAN.
Also issues with PPPoE & reconnect after reboot. I need to restart the network interface, save in forris the WAN setup before it finally goes back connecting.
most of the ‘testing’ functions in forris like DNS check and ipv4/6 connection check do not work.
Pakon stopped working after 1 hour.
Ad block is in the luci menu, but when activated, does not download the lists.

So far :slight_smile:

1 Like

What is the upstream connectivity with the ISP - DSL via external modem?

you could enable debug reporting for ppp in /etc/ppp/options
- #debug
+ debug

That would get ppp chatty in the system log and may provide a hint of the issue.

It is a fiber connection that is using PPPoE as the method of connecting.
Works like a charm with the older synology 2600, but the MOX 4B7 has some issues.
Also, no clou how to activate what you describe above :slight_smile:

If you want to help with debugging the issue you reported you could look into the system log about potential error messages pertaining to ppp(oE). To increase the verbosity in the log you could alter the file /etc/ppp/options via ssh(browser app).

Having same problem with openvpn and sometimes with adblock.

This is what forris shows, and the MOX is connected to the internet.

another bug, losing static leases after reboot.

Update : openvpn >LAN works now, might had and have to do with WAN VLAN issues i have.

Also, is the honeypot option safe to use in this version?

I didn’t check forum and router since beta6, which I have installed.
The update for beta7 is waiting for my approve, but I didn’t get an email with a notification from my router, to check it out.
There is nothing even in the notification tab.

There is a probably problem with email notifications via SMTP Turris server (look at this post in this thread)

At that time, right? Because the test notification, I sent today, worked just fine.