Turris OS 4.0 beta3 is now released!

Dear Turris users,

We want to let you know that we released Turris OS 4.0 - beta3! This release is for Turris Omnia and Turris MOX.

Release notes for this release are:

  • improved netboot to support remote management
  • syslog-ng: fix for service stop
  • updater: packages removal happens now at the same time as packages installation
  • fosquitto: simplified init and respawn
  • knot updated to version 2.7.7.
  • kernel: CVE-2019-11477, CVE-2019-11478, CVE-2019-11479

When you were using our previous release (Turris OS 4.0 beta 2), you should be updated to this version within a few hours.

If there is someone who wants to set up your router from scratch and would like to try this beta release instead of Turris OS 3.11.5, you would need to download medkit and by using re-flash method, which is described our documentation, it will erase all your data including settings and then it will write the system image from the USB flash to the internal storage. Also, you can use schnapps, which is a tool for managing snapshots.

Enjoy the release and let us know about any feedback for this release.

1 Like

Known bugs:

Turris Omnia specific

  • Second CPU ethernet port to switch chip is disabled, only one of two ethernet ports between CPU and switch is in use.
  • Old version of libmariadb when using Nextcloud from Turris OS 3.11.x.

Turris 1.x specific

  • Currently not working because of kernel issues. Please do not test this release on Turris 1.x
  • Old version of libmariadb when using Nextcloud from Turris OS 3.11.x.

Does this imply you cannot upgrade your nextcloud from tos3? What do we lose with this?

After the update Foris stopped working with 500 - Internal Server Error … Luci works fine, reboot doesn’t help, can’t see anything wrong in the logs. :sweat:

1 Like

In Turris OS 3.11.x, we are using a newer verion of libmariadb than which one is in OpenWrt 18.06. Some users told us that they can not use their Nextcloud installation from Turris OS 3.11.x, because of this issue. I will try to fix it in a new version of Turris OS 4.0.

Can you please tell me if you did a restart of your router? If not, would you please do it and tell me if it works?

Restart doesn’t help, tried 3 times, at first it throws 503 - Service not available, after refresh it’s 500.

1 Like

OK. Thank you for doing that. Can you please send us an email with diagnostics to our support, which is available on email address tech.support@turris.cz, so we can look what’s going on in your case?

Same exact problem here. Did a reboot from Luci and it’s still the same. I’ll try and check if I can figure out what’s going on and will send an email to support.

How does one generate those diagnostics without access to a working foris? I ask as I see the same issue and would like to help. Neither dmesg nor logread fro the command line reveal anything like a smoking gun.

Check /var/log/lighttpd/error.log, does that have connection refused to some foris fastcgi socket for you as well? Pretty sparse on details, unfortunately, but it’s something to go on.

1 Like

The following repeats around every two seconds:

2019-06-21 22:18:16: (gw_backend.c.333) child exited: 1 unix:/tmp/fastcgi.foris-config.socket-0 
2019-06-21 22:18:16: (gw_backend.c.480) unlink /tmp/fastcgi.foris-config.socket-0 after connect failed: Connection refused 

The diagnostics can be also generated in CLI. Once you are logged to the SSH server of the router, you can do these two following commands:

/usr/share/diagnostics/diagnostics.sh -o /tmp/diagnostics.txt && gzip /tmp/diagnostics.txt

After a while, you can see file diagnostics.txt.gz in folder /tmp. Download it and send it to us. The diagnostics file will be removed after reboot as it is stored in RAM or you can remove it.

Great help.

Done, should be in your inbox soon (with you I mean you all and not specifically you Pepe)

As always thanks for the development and great responsitivity.

I confirm too with 500 error on Foris

Could you please try to restart fosquitto if it happens? /etc/init.d/fosquitto restart

Here to

server error 500

In addition to what Moeller0 reported i see

2019-06-22 10:21:52: (http-header-glue.c.1273) read(): Connection reset by peer 12 10 
2019-06-22 10:21:52: (gw_backend.c.2147) response not received, request sent: 885 on socket: unix:/tmp/fastcgi.foris-config.socket-0 for /foris/config?, closing connection 

whenever i want to log in to Foris.

Right, believe I’ve found the issue. Could you all try logging in to ssh and run: “mkdir /usr/lib/python3.6/site-packages/foris/locale”
Rebooting shouldn’t be necessary - it should just work after doing that.

1 Like

Progress. Now the login screen appears and i can login to Foris. Foris seems to work fine now.
Thanks HomerSP.

Remark: I had to reboot to make Foris work. After the login I received only 404’s.

BTW: Foris is still on v100.0, the same as 4B2.

Ok, guys, I think that I have everything that I need to be able to fix the error 500, which someone of you is having. It happens when you don’t have any other language than English.

As the fix is currently on the review. Right now, what you can do is to install, for example, foris-l10n-de and reboot your router.