Turris Omnia Out of Box Issues Cant do anything

  1. unbox omnia
  2. go through set up
  3. choose a few updater options like open vpn and nextcloud
  4. tells me to reboot
  5. gets in infinite circle that reads “trying to reboot”
  6. have to manual reboot
  7. try to go back to interface at 192.168.1.1 “500 internal service error”

I would just like to use my router and be able to access it after an update

this thing has been nothing but problems right out of the box. No Openvpn client, cant even update without this boot loop internal service error…what the heck?

1 Like

Maybe you should calm down a bit. Based on your multiple posts in this forum within a short period of time it seems like you are a beginner and lack some basic knowledge about Linux, OpenWRT and networking in general. This is totally fine, everybody starts at some point, but you should reconsider your general approach.

Did you find the Turris docs located here?
https://docs.turris.cz/
There you can find instructions on how to update your router, how to install some software and how to recover from failure. There even is a section about „Getting help“ that you should read carefully: https://docs.turris.cz/basics/support/

Take some time and get to know your device. If you have some specific questions this forum is the right place to ask them and there are many community members willing to help. But spamming multiple threads with imprecise questions and accusations is not the way to go… Ask precise questions and describe your problem as exactly as you can.

What software version is running on your Omnia? Maybe you should update to the latest version (4.0.3) before adding software.

3 Likes

Very sorry , noob rage fail, ill be more respectful

looked through the docs while.troubleshooting

Yes i ran the full setup wizard and updated to latest version but often ran into a " attempt to reboot after install - boot loop" and i would have to manually reboot on the turris (1 led reset).

Just want to put wan into.it and get lan out of it easily, maybe even run my very own vpn config file via the gui and route who gets what connection

Okay, so this is strange. Are you sure you waited long enough? Rebooting the Omnia is something I expect to „just work“…

Turris MOX has some reboot problems that are beeing investigated by Turris team at the moment but the omnia should reboot just fine.

Maybe you could try to reflash your router with latest firmware, while resetting it to factory settings always goes back to the software version the router was shipped with, this brings you to latest firmware. See section „Re-flash router“ here: https://docs.turris.cz/hw/omnia/rescue_modes/

If this doesn‘t help so that your omnia reboots at least it may be some hardware failure, so it might be helpful to contact support then… (See link „Getting help“ above)

Do you mean you want some clients route through vpn and some not? If yes, search this forum for „policy based routing“ but be warned that this topic is quite advanced…

Try setting it up initially without update options may succeed, then reboot and take it from there.

TOS provides a feature schnapps through which the user can create a snapshot for a working configuration and rollback to it if something goes awry later on, thus not necessarily having to start from scratch all over again.
That said it is not a silver bullet.

Currently schnapps is accessible only via ssh but not Foris and being a feature implemented by TOS it is not available via LuCI either.


That seems a bug of sorts indeed, also

is somewhat odd.

Had similar if not the same user experience like you with my Turris MOX. And I am doing Linux, OpenWRT, and networking for over a decade. Go figure! Especially that 500 error forced my to use one of the rescue modes as I did not enable the shell.

In other words, there is an issue, perhaps a software bug which needs to be tracked down. If you are able to reproduce your issue, would be interesting to get your

  1. Turris OS version, and
  2. all of your selected options in the configuration wizard, and
  3. the model/version of your upstream router, and/or
  4. the name/location of your Internet Service Provider (ISP).

Yes, that is work. I was not able to track down my issue, because I was not able to reproduce it, yet.

Did some factory resets and just did updates one at a time and that seemed to fix the software boot loop issue. however, after getting openvpn working finally, i now have a shiny new issue :

Getting 500 internal server error when trying to log into Foris

Luci login works, Lan Internet works, Openvpn works , ssh works

On current version of everything

Sorry pepe, im trying over here!

  1. turris version 4.0.3
  2. are you asking about foris wizard options ? if so, did not install anything other than extra luci options
  3. no upstream router just modem
  4. would rather not say

when i go to 192.168.1.1 it gives me the option of foris or luci, luci works, foris gives 500 internal service error, reboot did not fix

Yes, especially your DNS (and therefore for your upstream stuff). However, because you are on Turris OS 4.0.3, it sounds like the auto-updating worked, and then DNS should work as well. In my case, the defaults on the DNS pane did not work and then in the end I lost Foris. I had to go not for my ISP but another option like Cloudflare. Anyway, if Foris gives 500, I am not aware of any other solution than going for rescue mode 6. Perhaps somebody else knows a better approach.

really hoping for a solution that does not require yet another reset. Luci works great, openvpn even working but 192.168.1.1 and clicking foris still pushes 500 internal service error

Someone mentioned something about a command lighttpd ? can anyone shed some light on other things i can do ?

thanks

Since the mod Pepe will only allow 1 thread for all issues no matter how diverse. Here we go again…

I was getting. "Unknown error password not changed " when trying to change password via luci

Changed password via SSH with passwd

Now cant log into luci with newly created password via SSH but it works via SSH.

Now I am locked out of luci, what can I do ?

Also trying to choose foris instead of luci gives 500 internal service error

Im down to only SSH login working.

/var/log/messages reads when trying to enter newly created and working SSH password via luci …

Odhcp 5363 failed to send dhcp message to ff:1:: (permission denied)
/usr /sbin/cron 7827 (root) CMD /usr /bin/ rainbow_button_sync.sh
/usr /sbin/cron 7827 (root) CMD /usr /bin/ notifier

Meanwhile, breathe deeply. Then follow me. I too have a Turris Omnia. Information technology is or is not, there is no middle ground or “bizarre” behavior. My Omnia works for Foris and LuCI. So yours too must work as the same hardware and software. Meanwhile, download the latest version of Turris OS, if you haven’t already done so. The latest is 4.0.5, flash via USB with this medikit https://repo.turris.cz/hbs/medkit/omnia-medkit-latest.tar.gz
Once you believe the operation is finished, access the Foris wizard and check in About which version you are using.
At this point create the password for Foris and the password for LuCI (if you want to create it and you want to differentiate it from the password for Foris).
Set the configuration to connect to the internet.
Now stop. Test all the world with ssh, LuCI and Foris, in various order and make sure everything is working properly.
When you are sure that everything is fine so far, continue, otherwise go back and start again, the problem could be in the use of the medikit or in the basic configuration in Foris.
Confirmed that everything is fine, continue by installing the additional elements you need (also the LuCI extensions, install them only now that you are sure that everything works).
When you install anything beyond the medikit, with every package installed, with every modification of reconfiguration, try again ssh Foris and LuCI.
This is the only way to find the “culprit”.
Follow this simple procedure and let me know. But do not immediately jump to install packages at will, otherwise you will find yourself with the usual error.

Already on 4.0.5. Already did updates. Already have openvpn client working.

This was related to PW change via SSH some how locking me out of luci where now no PW works in luci. But SSH PW works in SSH.

Foris shoots 500 internal service error and has for a while…

Http and ping work fine.

Meanwhile, you can try without openvpn already working, but from a clean and fresh system.
Have you tried changing the password from LuCI instead of ssh? Just to understand something more.

Again…luci will not let me in with Any PW New or old but SSH PW works fine. I am not able to get into luci or foris, only SSH.

The solution cant always be on here " how about just completely reinstalling and factory resetting and starting from a fresh install " that is giving up.

Im here to try to spot fix the issue

The only way to solve is to install it again and not install openvpn and nothing. But install things one step at a time. If you were better than this, you would have already found the problem and solved it. I’m not just telling you to install everything again, but to follow a search procedure. With each step you take, double check your password change. It is the only way to find the culprit.

The community is better than this. Hence why I am here to talk to those better than me.

You are not understanding the issue. Everything was working fine until I changed PW via SSH. That is the cause of issue via luci. Already did fresh install, already did one by one update etc long ago, everything was working fine, until I changed PW via SSH because could not change PW via luci due to " unknown " error.

I can always just do a factory reset, thats not why I come to the forums. Its to Prevent having to do a factory reset EVERY time. Thank you for your help on this, Its noted.

You don’t have to do a factory reset every time. You are only wrong with the order: first you have to try the holy change of the password and then install all the things you want. A step at a time. Something is wrong, but it doesn’t depend on the base or Foris or ssh or passwords. Otherwise it would be unusable for anyone. Either you try to change your password before installing your little things or I don’t see a solution.