Turris Omnia: 2.4 GHz issue for devices (not able to connect, etc.)

approximately for past 3 months I experience issues with wifi on my Omnia device.
I have latest updates and patches, I tried reset wifi and recreated networks with different SSIDs and passwords and wifis are on free channels (I live outside of town so there is no sudden interference).

I have trouble connecting to wifi with devices that had no issues previously.
Once this happens all devices cannot connect to wifi (just “connecting”, or SSID is not visible - depending on OS - Android or windows).

How could this happen and how can I troubleshoot please?

Is your Omnia well otherwise? I.e. no filesystem errors, no weird errors in logs, enough free disk space on the system partition, enough free RAM?

filesystem seems OK

Filesystem                Size      Used Available Use% Mounted on
/dev/mmcblk0p1            7.3G    619.6M      6.6G   8% /
devtmpfs                512.0K         0    512.0K   0% /dev
tmpfs                  1008.1M     20.8M    987.2M   2% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

checked via htop and memory is on 181M/1.97G
My Load average is 0.20 0.10 0.02
so there should not be any performace issues

I checked logs via LuCi interface > System logs and kernel logs and also via SSH var/log/messages but I see no errors except:

root@Yurris:/tmp/log# cat messages |grep err
Sep 28 19:13:19 Omnirouter kernel: [    0.000000] Registering MPIC SoC Error Interrupt Controller
Sep 28 19:13:19 Omnirouter kernel: [    2.133430] sdhci: Copyright(c) Pierre Ossman
Sep 28 19:37:30 Omnirouter updater-supervisor: pkgupdate reported no errors

At the time of this writing I also experienced this behavior today morning 30.sep. so there is nothing in the logs.
Or perhaps I look at the wrong logs.
Can you advise?

That looks good. Hardware-wise is it also okay? (The u.fl antenna connectors to the wifi cards, the antennas to the rp-sma connectors).

Also, try grepping grep -i btrfs on the log.

You can also try switching to the alternate wifi drivers (you will find the option in reforis, package lists).

Thanks for your effort @peci1
I tried to check HW and all seems fine. I also reseated wifi modules inside, just to be sure.
Output is:

root@Yurris:/tmp/log# cat messages|grep -i btrfs
Sep 28 19:13:19 Yurris kernel: [    0.000000] Kernel command line: earlyprintk rootwait  console=ttyS0,115200 rootfstype=btrfs root=PARTUUID=00000000-01 rootflags=commit=5,subvol=@ rw cfg80211.freg=**
Sep 28 19:13:19 Yurris kernel: [    0.000000] Unknown kernel command line parameters "earlyprintk mangled_fs=btrfs", will be passed to user space.
Sep 28 19:13:19 Yurris kernel: [    2.202569] Btrfs loaded, crc32c=crc32c-generic, zoned=no, fsverity=no
Sep 28 19:13:19 Yurris kernel: [    3.847835] BTRFS: device fsid d3cd672d-ea8c-4b98-9099-117a07f334d6 devid 1 transid 12987 /dev/root scanned by swapper/0 (1)
Sep 28 19:13:19 Yurris kernel: [    3.860420] BTRFS info (device mmcblk0p1): using crc32c (crc32c-generic) checksum algorithm
Sep 28 19:13:19 Yurris kernel: [    3.868844] BTRFS info (device mmcblk0p1): disk space caching is enabled
Sep 28 19:13:19 Yurris kernel: [    3.875562] BTRFS info (device mmcblk0p1): has skinny extents
Sep 28 19:13:19 Yurris kernel: [    3.893240] BTRFS info (device mmcblk0p1): enabling ssd optimizations
Sep 28 19:13:19 Yurris kernel: [    3.907755] VFS: Mounted root (btrfs filesystem) on device 0:14.
Sep 28 19:13:19 Yurris kernel: [    3.941217]     mangled_fs=btrfs
Sep 28 19:13:19 Yurris kernel: [    6.645947] BTRFS info: devid 1 device path /dev/root changed to /dev/mmcblk0p1 scanned by mount (698)

I will monitor after the card reseat and if problems occur again I will switch drivers.

But weird thing is that everything was forking for 2 years with no problem. Just recently I have these issues :frowning:

Do you use WPA3 or WPA2 on your wifi networks?

only WPA2
connected devices are Android (also older versions) and Windows PCs.

Do you have disabled 802.11w? By default it is set to optional, try to set it to disabled in LuCI.

Many devices have problems with this.

1 Like

I don’t see anywhere in the settings (or LuCi interface) this 802.11w option.
Can you please write, where it is?
maybe I’m blind but I spend 30 minutes searching for it. :confused:

It is somewhere in advanced settings and its called MFP (Main Frame Protection).

*management frame protection

1 Like

I did not find it anywhere in LuCi settings.
Not Main Frame protection or Management frame protection.

LuCI > Network > Wireless > select desired wireless network - Edit > Wireless security

PS: Sorry for missleading you before, I just didn’t remembered the right location :wink:

Surely you can disable Management Frame Protection (MFP, 802.11w) in LuCI, but from Turris OS 6.1 and later releases, there is no need to do that.

Since Turris OS 6.1, you can easily toggle it reForis (see the screenshot from my router).


1 Like

This is valid for WPA3 only. For WPA2 you have to do it via LuCI.

I had it disabled already.

I don’t know then. Maybe trying clean installation from Medkit and if it will not help, then contact Turris support, or try new wifi card.

You can try, also, to turn your Omnia off for some time to let it cool down and then turn it on. This could hel if there is temperature related problem. There were some complains about such issues few years ago.

We are talking about 2,4GHz or 5Ghz?

Maybe your channel on 5Ghz is set to auto or something and its using DFS channel and disabling itself because of some weather or army radars detected. That was common issue here on the forum. Try setting channel to 32 or 36 i dont remember correctly.

It’s 2,4GHz 802.11n 20Mhz wide channel with no interference from surrounding signals