Turris Mox USB (from module A) not working any more (for mass storage) after TOS 6.0 upgrade

Can someone test USB3 mass-storage with version 6.2.4? Turris OS 6.2.4 is now in the Testing branch
@jada4p did, it’s working for him. But his test probably does not cover the other non-working cases we face in this thread.

Tested 6.2.4, USB3 HDD doesn’t work for me.

1 Like

Also USB 3.0 flash drive still doesn’t work.

Well, I created this thread 4 months ago, and this regression is still there for some (most?) of us.

Turris OS 6.2.2 was promising (and supposed to fix it), but seemed to fix it only for one of us (as far as I can tell).

We’ve tried to give some info about our USB devices, we reported our issue on each new Turris OS release (thanks to those who did that), but did not get any answer from Turris, so far.

I have to admit that I’m loosing faith.
If someone has an idea to help make things move forward, don’t hesitate…

Being stuck in a 5.4.x version is not sustainable.

Even though USB3 is working for me in MOX module A, I still have problems with SDIO in MOX A - which should work according to Turris team - but is not working in my case.

I wonder if there are not some deeper problems regarding MOX module A.

MOX classic, HBK branch (ie. 6.3.0), .5 GB, 2x WiFi, simple config


After changing some SDIO card parameters, according to advice from Turris support, i.e. mode to old regime 802.11b (from 802.11n, via LuCI!!!), and encryption from WPA3 to WPA2 (via reForis) is SDIO card working!

I have no idea how to move forward.
I guess this issue will have to be picked up by kernel developers who produced the patch for this issue [PATCH] phy: marvell: phy-mvebu-a3700-comphy: Reset COMPHY registers before USB 3.0 power on - Pali Rohár
I guess they probably have access to some “lucky” USB3 devices, therefore they though the USB3 issue is fixed for everybody, but apparently it’s not for at least some USB3 HDDs (spinning disks).
Does anyone have an idea how to involve the right people in order to troubleshoot our issues further? I would be more than happy to run whatever test kernel to help identify the root cause.

@Pepe how could we help solve this issue?
Several proposed here to run some tests on their MOX if you give directions.
If necessary, I could even send you one of the devices not working on my MOX (a USB3 stick).

I would say that you need to need to provide such details:

  • Which USB flash drive are you trying to use
    • Most likely the brand, type, and as well the USB ID how it is recognized in the system*
      • * the USB ID can be obtained by issuing lsusb -t command on any GNU/Linux distributions
  • If the USB flash drive is using UASP, that’s important to know, but that could be observed in the system log and if it is there, you can do e.g. disabling UASP in the system,

And it is important to know which filesystem you are using and if all the USB root are visible to the system. That could be known also from lsusb.

Include all these details to the GitLab issue and/or please let the support department know.

Sorry that I can not help you further on this one.

1 Like

@Pepe I’ve opened Some USB 3 devices not recognized in MOX (#404) · Issues · Turris / Turris OS / Turris Build · GitLab with the requested details.


@padam (or anyone else), did you contact the support department on your side? Support - Turris Documentation
If not, I can do it if you wish

@Mossroy I did open the GitLab issue as suggested by @Pepe, I didn’t contact support team via email. Feel free to do so, if you think it can help.
I assumed that when I create similar issue in GitLab like USB 3 devices not recognized in MOX (#391) · Issues · Turris / Turris OS / Turris Build · GitLab it will be picked up and worked on.

@padam I agree with you, but the idea is to give us all the chances we can have, and strictly follow:

So I just sent an e-mail to the support team, pointing to your new JIRA ticket.

I had this answer from support team yesterday:

Thank you for reporting your issue with your USB3 SSDs.

We have stopped working on that issue because all the USB3 devices that we have started to work. We are sorry to read that you keep dealing with that issue.

Nevertheless, if you are able to send us one of that devices for debugging as you suggest, we would be grateful for that.

Could you please send it to the following address with a label that it belongs to this ticket number?


There is a possible workaround to apply in the meantime. If you connect your SSD over a USB2 cable, it should work even with the current Turris OS 6.2.4 version. The speed would not be the same, though.

With kind regards

Stepan Rechner

To be sure I don’t send a USB stick for nothing, I tested again today to upgrade my MOX to latest Turris OS (6.2.4).
As expected, it does not recognize my external hard drive and/or my USB sticks. As usual, lsusb -t and dmesg do not see it.
As usual, reverting to 5.4.4 makes everything work again.

So I’ll send my USB stick (a USB3 128GB Kingston DataTraveler) in Czech Republic, to let Turris test on their side.


Mossroy, thank you very much for providing your hardware for the team to test.

You are not alone with this issue. I own a SanDisk USB 3 Stick (SDCZ430-032G) which is not recognized by 6.2.4 as well.

For info, they have received my USB stick and will test with it:

I want to confirm that we have received your 128GB Kingston flash drive, together with printed instructions on how to reproduce the issue.

Thank you very much for your cooperation. I will pass it on to our kernel-specialized colleges to have a look at it.

1 Like

For info, I’ve asked the support team for news.
They just answered:

unfortunately, we are waiting for the new information yet.

We will inform you, thank you for your patience.

1 Like

They received my USB stick one month ago, so I’ve asked for news and got this answer:

let me apologize for the long response time.

I´ll forward your message to our kernel specialist.


Well, 2 more weeks and still no answer from Turris support. I don’t even know if they tried to reproduce with my USB stick :roll_eyes:

I suppose they don’t consider that issue as a priority.

Instead of asking again for news, I suggest that other people affected by this issue open a support ticket, too. See Support - Turris Documentation. Maybe they believe I’m the only one affected, or that I have some unusual USB device. Give your own symptoms and impact, and give detail on your USB device(s): brand/model and USB ID from lsusb -t.

If you have other ideas to make things move forward, don’t hesitate…

I know that would be just a workaround (and I haven’t read the whole thread history), but did you try connecting the device via a (powered) USB hub?