TOS 5 upgrade changes router hostname (Samba 4 troubles)

I don’t get Samba4 working. I did /etc/init.d/samba4 enable & /etc/init.d/samba4 start. Attached a screen_shot of my old and the new LuCi Samba setup. What am I missing? Please help.

TOS 4.0.5 is not 5.0.0.

Turris Omnia updated from TO4.0.5 to the new TO5.0.0. Now, I can’t get access to my mSATA ssd which is installed in the Omnia.

And did you try select the Interface?

What do you mean with “select the Interface”? How am I suppose to do that. Under Windows 10 I try to access the /mnt/sda1 volume/partition as \OpenWrt\Omnia and this does not work. Here a screen_shot of my mount point settings …

It´s setting from your second screenshot.

Which packages is installed when you find package “samba” in Software tab in LuCI?

Are “smbd” and “nmbd” processes running in same named tab in LuCI?

Here are the packages and process you are asking for …

And did you try set your Interface to “lan”?

Yes, setting interface to “LAN” does not help. By the way, I can access the share via my iPad and a app called FileExplorer. Only access via my Windows clients does not work.

wrong naming convention (lan vs. br-lan) - please see this thread that covers the matter Unable to make Samba4 work on TOS5

Sorry, but this is not same!

Try this command from your Windows CLI (and change x: to free drive)

net use x: \\your_omnia_ip\your_share_name

Also check, if you installed package “fix-samba-migrate-to-samba4”.

Package “fix-samba-migrate-to-samba4” was not installed. I installed it and reboot TO. Did not solve the problem…

But that’s not all I wrote.

Sorry, you are right. I tried “net use x: \your_omnia_ip\your_share_name” in my Windows shell and get an error: “network path not found” …

Can you send the screenshot?

@viktor @mrs.crox can you please help me what I have to set in “/var/etc/smb.conf”. Here is my file:

TO5.0.0_var_etc_smb.conf_file

Can you answer to my last question?

Here is the screen_shot of this message:

I am not expert on SAMBA but this extensive post Maxmilian's notes on smb.conf seems to cover it exhaustively

Try it without “OpenWrt” in command.