TO Updater failed / Luci not accesible

I’ve got a notification about new update for m,y turris omnia yesterday but I havent installed it yet …

my TO system:

Device Turris Omnia
Serial number
Turris OS version 3.11.13
Kernel version 4.4.199-a890a5a94ebb621f8f1720c24d12fef1-0
## Update from 2020/02/05 16:17:44
   Your approval is required to apply pending updates.You can grant it in the Foris administrative interface in the 'Updater' menu.
    • Install opkg 8
    • Install turris-version 3.11.14

and today I’ve got another message

## Error from 2020/02/06 16:57:39
Updater selhal: Failed to provide the approval report: Read-only file system

Luci is not accesible and when I tried to log in I saw in dmesg this error messages

root@turris:~# [1188907.207982] verify_parent_transid: 19696 callbacks suppressed
[1188907.207993] BTRFS error (device mmcblk0p1): parent transid verify failed on 8839168 wanted 2096399 found 2096369
[1188907.219414] BTRFS error (device mmcblk0p1): parent transid verify failed on 8839168 wanted 2096399 found 2096369
[1188907.230136] BTRFS error (device mmcblk0p1): parent transid verify failed on 8839168 wanted 2096399 found 2096369
[1188907.240839] BTRFS error (device mmcblk0p1): parent transid verify failed on 8839168 wanted 2096399 found 2096369
[1188907.251690] BTRFS error (device mmcblk0p1): parent transid verify failed on 8839168 wanted 2096399 found 2096369
[1188907.262465] BTRFS error (device mmcblk0p1): parent transid verify failed on 8839168 wanted 2096399 found 2096369
[1188907.273547] BTRFS error (device mmcblk0p1): parent transid verify failed on 8839168 wanted 2096399 found 2096369

when I’ve checked btrfs I see this:

root@turris:~# btrfs dev stat /dev/mmcblk0p1
[/dev/mmcblk0p1].write_io_errs 0
[/dev/mmcblk0p1].read_io_errs 0
[/dev/mmcblk0p1].flush_io_errs 0
[/dev/mmcblk0p1].corruption_errs 0
[/dev/mmcblk0p1].generation_errs 0

root@turris:~# btrfs scrub start -Br /dev/mmcblk0p1
ERROR: scrubbing /dev/mmcblk0p1 failed for device id 1: ret=-1, errno=5 (I/O error)
scrub canceled for 3009dff1-fd4f-4b45-a942-35a55aca3ed6
        scrub started at Thu Feb  6 17:13:34 2020 and was aborted after 00:00:00
        total bytes scrubbed: 0.00B with 0 errors

Can someone help me what is wrong and how can I fix it remotely? (only SSH/VPN - not sure if it still works after this error.)

thank you

p.s. I hope its not failure of my internal flash drive.

Did you have a look here Controller never released inhibit bit(s) ?

well, that topic is when eMMc died … I hope its not my case, because I dont have skills to do it and unfortunatelly I have to do everything remotely, but I think changing booting drive its not possible to do without physical access to the device.

update: … TO is started to restarting itself …

I pointed to it because of potential similarities.

If you are lucky it is just corruption of btrfs - as opposed to the eMMC failing. Former could potentially be remedied:

  1. Updater selhal: Failed to provide the approval report: Read-only file system [3.7.1], or
  2. purge/reformat the partition and redeploy a medkit image (hopefully some backup is at hand)

It may also just be some temporary btrfs hiccup that goes away with a reboot but chances are probably slim and odds are high that booting will fail.


To get this sorted remotely via VPN may not be feasible

Thank you for your suggestions and ideas, I appreciate it !

TO was restarted by itself and started “properly” (well, all ports were open to the internet ! even if I have them closed) … so I can connect to the SSH/VPN .

  1. if I purge/format the eMMC I will loose all my settings, because I couldnt create medkit from my system … some issue which I’ve reported before and nobody dont know where is an issue or how to fix it.

well, I can do it only remotely … its a bit expensive to buy a flight tickets everytime when I have an issue with TO/MOX … because there is an issue very often :frowning:

That is any easy one - schnapps

export [snapshot] path Export snapshot as a medkit into specified directory
Snapshot argument can be snapshot number or ommited to backup running system

To reinstate that medkit (snapshot) there are two ways:

  1. four-led installation from USB (loaded with that medkit)
  2. if you got a second instance (running from a SSD and USB) on the node booted up purge/format the eMMC , upload the medkit and unpack it to eMMC partition, e.g. this being a very node specific example and file paths/names would need to be adjusted

tar -C /mnt/sdb3/@ -xzvf "/srv/snapshots/hbd/omnia-medkit-1.tar.gz --xattrs-include='*.*' --numeric-owner --exclude='/srv' --exclude='/logs'


All sorted then?

I know schnapps … but it doesnt work for me … Schnapps Export Error

that btrfs error message is not appeared in dmesg, Luci is accesible again so I hope its gone :slight_smile:

but I’m expecting that my TO will die soon and then I will replace it with something stable, secure, user friendly, etc. everything what TO/MOX doesn’t have yet.

1 Like

I see now about the schnapps issue, it might be related to schnapps experiencing trouble when trying to export

but I cannot be sure, neither whether this may not happen with more contemporary versions of the OS. Unfortunately schnapps does not offer to exclude certain paths [1]

There is no easy debug option for schnapps and it would require other tools, e.g. strace, to take a closer look.

Alternatively, since medkit being just a compressed archive, it should be possible to generate one with common archiving tools such as tar.


[1] https://gitlab.labs.nic.cz/turris/schnapps/issues/9

Well, the btrfs failures, they could be actually caused by eMMC errors, and it could take several month for emv to fail completely. That’s what I can tell from my experience.
It doesn’t have to be eMMC failure, but you’d better make a fresh backup just in case.

Is it manageable to get a local assistant? Some friend or relative perhaps?

I also have one more advice for you, not sure if it is a good advice but still:
Don’t update when you only have remote access.

that doesnt sounds good :smiley:

I have issue with schnapps for a long time, TO is restarting randomly and after that crash it start again, but with open ports to the internet (which is a bit unsafe I think) .
now the issue with Read only filesystem which can be eMMC failure …nevermind will be replaced by something else soon. (probably something from Synology)

of course I do updates when Im next to TO/MOX … if you remember it was impossible to stop automatic updates on the beginning, but praise the god it is possible now! :slight_smile:

For me Omnia has no comparison to any other router in terms of power, features and stability. Well, my eMMC has failed, but that was entirely my mistake of running Home Assistant with debug logs enabled. I am happy I can run whatever I want.

My TO probably died yesterday …

I can do a ping to my WAN address, but I cant connect to SSH and VPN (keys refused). so now I dont know what is TO doing, if only VPN and SSH crashed and other features still works, or if TO is opened for everyone on the internet …

TO is nice piece of HW, but its not for daily usage … its only for geeks who want some toy to play. Im very disappointed with TO and also with MOX … this HW shouldn’t been sold in any stores for end-users. TO its probably powerful , but it’s not stable at all and after 2± years will die all of them, because TO team have decided to use internal eMMC and on the begining there were no easy way how to avoid frequently writing to that flash drive. so because their fault now people can wait when their TO will die … its a good tactic from Turris team !

1 Like

Well there are things being offered in TOS that are not typically deployed on a router and not only raising consumer expectation but adding complexity/effort/cost to development maintenance and in user (software) support - resources that might better be spend on the core router development.

IMHO:

  • file hosting server apps, e.g. ftp, samba, nextcould
  • LXC
  • any DB app
  • any torrent app
  • youtube downloader
  • website hosting
  • home automation / robot control

are not at all router related and commonly run on separate/dedicated nodes.

Being offered through TOS however turns the device outside the realm of a router and more into something like a wannabe jack of all trades that raises expectations which not every user finds fulfilled.

I would concur that warnings about the eMMC in conjunction with write intensive applications running on the device (which usually would not if it were just a router, save for pakon perhaps) should have been displayed more dominantly and early on.

1 Like

This is the kernel of all questions, for me. Without this core, the forum would be semi deserted. Not many complaints would be heard.

I agree. TO is far more powerful than a regular router. And it allows you to do more. Even to damage your hardware for improper use sometimes. And I love it for that.

I also agree that TO is more powerful than a regular router, but only power is not the most important thing when you want to use TO as a gate to your local network. issues like random restarts by itself and then local network is publicly shared with internet, or when updates are not going smothly and device will stay in restart loop, or when designers of TO was decided to use internal flash drive but didnt let us know that even if you use only implemented features, that will damage your router … sorry but this very expensive device is something what you can use for playing as same as rPI or arduino etc. not for regular usage.

1 Like

How do you declare that it is more powerful? In what is it? It looks like a common router with several critical issues. Then someone might find it more powerful, someone else won’t. There are “normal” routers you buy on Amazon that are definitely more powerful. It’s more a matter of taste. Surely a router has to do the router, if then it does in addition to the router, it is up to the user to decide if it is a good thing or not.

Well, besides being a router, my TO provides access to tor and i2p networks, runs a mail server, acts as a reverse proxy and https frontend for my little web site, and runs Home Assistant for my home automation. And if I want to install an ssd or a zigbee modem inside it - I can do that. That’s what I meant by being powerful.

I don’t want to go into too much detail. Here is a good description of what essentially a router is: https://en.wikipedia.org/wiki/Router_(computing)
Having read this, you will understand for yourself that what you use is not a “powerful” router, it is a card that can do many things for you other than routing (for this reason they are called routers).
If you feel comfortable with the product of this company we are really happy. But if you keep saying it’s a powerful router, I still don’t understand.
For me a powerful router, manages to route a lot of data traffic between many devices without interruptions of any kind, if then, as in the case of Omnia (in the latest versions) or in some MOX configurations, WiFi cards are included, then I expect high speed also as WiFi access point. This is power. A good surgeon is such because he knows how to operate patients and save their lives, not because he knows how to play football well or paints beautiful pictures. These things don’t make him a more powerful doctor.
Unfortunately, I speak for myself, Omnia is not --for me-- particularly powerful in routing and even less as a WiFi access point (here the line is really castrated). But then it depends on the individual cases. With a few Mb/s lines it will look fantastic too.
In addition, there seems to be a big problem with the disk, which is yes fast, but very sensitive to use: many writings damage it quickly. So there is a lot of space, like 8 GB, for a system with Turris OS / OpenWrt, designed for embedded devices, which at the most uses a hundred Mega and advances a lot of other space, which is dangerous to use with programs that require a large effort to memory. In short, it seems to me a contradiction. Then why should I run mail servers and the like on a router, it is no coincidence that there are servers, which is another thing, and there the disks you can squeeze them well.
As for the other configurations, such as the beloved VPN and similar things, you can do it I think with any operating system, therefore also with Turris OS or OpenWrt. I don’t see exceptionality. But I’m not easily amazed.