Support for Quectel EP06 LTE-A?

TOS v4.0b6. It’s a hardware design limitation. You can workaround it with these if you want:
https://techship.com/products/minipcie-to-usb31-adapter-dual-sim-slots/

1 Like

I was badly mistaken about needing a /bin/sleep for the LM940 - it seems to work out of the box with “option autoconnect 0”. You can just order the modem from the vendor, tape the pins (same as the EP06-A) and use this santza for VZW… it should come up:

config interface 'lte'
option proto 'qmi'
option device '/dev/cdc-wdm0'
option apn 'VZWINTERNET'
option profile '3'
option autoconnect '0'

This is after I used AT commands to set PDP contexts to set vzims, vzadmin, vzwinternet, etc. PDP contexts inside the modem. I am not 100% sure that “option profile 3” is required after all this, but I can’t be bothered to debug after this point because it’s all finally working!

1 Like

Moved the router with the Cat11 modem to a different city today. Now seeing DL speeds of 70mbps with pings of 30ms!

I know, it’s been a long time since your last post, but I finally managed to setup my EP06 in a fresh updated TO (TOS v.5.1) according to your instructions.
For O2 (same for resellers like freenet FUNK) in Germany I setup the following interface:

config interface 'lte'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option apn 'internet'
	option autoconnect '0'
root@turris:~# uqmi -d/dev/cdc-wdm0  --get-signal-info
{
        "type": "lte",
        "rssi": -65,
        "rsrq": -11,
        "rsrp": -93,
        "snr": 170

The modem gets a connection and an IP-address. In interface-section the following interfaces are available:


Therefore I added the following section to /etc/init.d/firewall:

config zone
	option name 'lte'
	option network 'lte lte_4'
	option input 'REJECT'
	option forward 'REJECT'
	option masq '1'
	option output 'ACCEPT'

config forwarding
	option src 'lan'
	option dest 'lte'

I’ve got a stable connection with
grafik
even though I only connected simple 2,4GHz-Wifi-antennas that were by no means adjusted to the next LTE-radio mast.

Note that if you don’t want to have to tape the pins, you could temporarily install the card into an adapter, and run the AT commands listed on this site:

https://techship.com/faq/minipcie-based-cellular-modules-supporting-usb3-are-not-detected-in-the-host-system/

Related AT commands for configuring USB3/USB2 modes:

Telit LM940/LM960 modules:
AT#USBSWITCH=1
AT#REBOOT

For Sierra Wireless MC74 series: (firmware version dependent)
AT!ENTERCND="A710"
AT!USBSPEED=0
AT!RESET

Once you’ve done that you can pop the card into the internal slot and it should work fine forever.

Thanks!

I’m a bit late to the party. How’s your experience with this module? I’m currently desperate with mine since it appears to be working fine over QMI, but it is quite unstable. I’m on firmware EP06ELAR04A20M4G, although I am using the variant embedded into a Zyxel LTE3301-PLUS, which is an EG06-E.

When accessing certain websites or causing certain kinds of traffic the module “dies”, and the only way to recover it is to cut the power to the module via GPIO.

I really tried to avoid waking up this thread, but I’ve been at this for a few months now.