SSD Suggestions

Hello fellow Turris users,

I would like to upgrade my Omnia with an SSD.

Do any more f you have suggestions what SSD’s are known to work good? If possible please post a link.

Thanks in advance.

https://www.alza.cz/kingston-ssdnow-uv500-120gb-msata-d5303675.htm works without issues.

1 Like

I had an mSATA PCIe SSD lying around from an old test from 2012 that I installed when I got the router in 2017. It’s been running flawlessly since then.

Just be sure you put it in the correct slot.

I have https://www.czc.cz/kingston-ssdnow-ms200-60gb/129124/produkt it worked in Intel NUC for years, but it did not work in Omnia right away. I had to isolate one pin, what was not an easy task, since it is tiny, maybe half of millimeter. I followed Switch to force mSata to make it work. Since then it works fine.

KINGSTON SUV500MS120G works well, 6773 hours so far.

My friend purchased this one: https://www.amazon.com/dp/B08245GX5V/ref=cm_sw_r_oth_api_i_-00cFb5GWVGMW.

To install it correctly, watch this video: https://www.youtube.com/watch?v=71_M2N3ga7s

For some reason, the storage plugin wouldn’t correctly format and mount the drive (as /srv), so I had to do so manually.

There is some problems with installing mSata disk …
The problems don’t see in video.

The cable with pigtails is too short to move WiFi card from mPCIe /mSATA slot to mPCIe.

There are not screws in the new positions for mSATA SSD.

Is it only shame that official instructional video show the nonexist way, how to install disk to the router.

The installation worked for me.

You should have had screws for every post to screw down each of the mPCIe cards. If you’re missing them, perhaps contact the Turris folks for replacement? I think they’re m2 or m3 if you need to order them separately.

I don’t remember if I had to move cables around, but the cables all fit in the end. They’re all detachable on both ends, so it shouldn’t be too hard to make it work.

I have an Indiegogo era TO, and the video matched my hardware exactly. I have a Kingston UV500 mSATA SSD installed which works fine (did not need the pin 3 disabled like some older disks). In the UK you can get these SSDs from Novatech at decent price.

I had to move the posts and screws as described in the video. Did you not have posts, or screws, or what exactly was missing?

I also did not have this issue, but I think elsewhere on the forum there were issues like this, perhaps only with certain builds, and juggling cables was required.

Could you possibly post a photo of your board? (Or, as above, contact support)

I had to switch two cables when moving cards around (though for a different reason than SSD). Simple enough IMHO, but I suppose it could be mentioned in some docs.