[SOLVED] Guest network is 30 times slower than other network

solved

#1

Hi,

Thanks to the help from the people in this forum, I was able to set up a guest network that can connect to the internet only.
(see: Need help understanding how VLANs, Ports, Interfaces, and Adapters work together)

But now I’ve noticed the guest network is way too slow for the things I need to do with it:
I will attend some class starting tomorrow, and it will be from home in a virtual classroom with webcam, screen sharing and so on. They’ve sent me a laptop that arrived on Friday. As it is a laptop where I do not have admin rights and with software I did not install, I do not want to connect it to the same network as my own computers.

Today, I wanted to prepare everything for tomorrow, and I ran an internet speed test on the school laptop (speedof.me). As the results were so bad, I re-ran the test with my own computer. First connected to my normal network, then the same computer on the guest network.
Results:
Normal: Download 35 Mbps / Upload 2,9 Mbps
Guest: Download 1.5 Mbps / Upload 0,1 Mbps

I looked at luci as well as foris, but could not find any place where some speed restriction can be configured. But I’ve noticed something else: After manually configuring the guest network according to the advice given in my other thread, foris won’t recognize the guest network anymore: In foris, the option is not checked. Maybe some interference between the things foris is doing and luci has something to do with it.

Now, I’m stuck. I hope I’m not forced to connect the school laptop to my normal network because of this.

Thanks and Regards,
Markus


#2

Sounds more like a hardware issue somewhere on the router, e.g. board, port, connector.

Is the very same cable on the lan ports used for the test or different cables for each port?


#3

It is just wifi guest network (virtual AP set via foris) nothing to do with eth ports.
How many tests did you run? Are you sure there was no other traffic? Another speed tests are the same?


#4

Thanks for the replies. It’s the same cable, the port had no speed issues when it was configured to be part of the default network, and its not WiFi. I’ve made several test runs.


#5

Ok I was confused with foris you mentioned as it sets wifi guest only. So then n8v8r was right.


#6

Now I’m confused :slight_smile:
When setting up the guest network, I originally started in foris, then switched to luci because it did not work as expected. But foris had at least created the GUEST_TURRIS interface, and I used that in luci, just changed the configuration. So I thought that foris is able to create “just a guest network”, with no restriction to a connection method (cabled LAN vs WiFi).
BTW … WiFi is switched off most times and only turned on when I need it for the smartphone.


#7

Guest wifi gives you proper speeds?


#8

I have not tried. The school company recommends cabled LAN, and I don’t even know if the laptop has WiFi at all.
That’s why I’ve only configured cabled guest LAN.

Edit: Just connected the “Turris” WfiFi SSID to the GUEST_TURRIS and tested on the chool laptop:
Download 1.0 Mbps / Upload 0,09 Mbps


#9

If wifi gives you the same speeds as cable then it seems like misconfig not HW problem.


#10

Well … while testing I made it worse.

To rule out a HW problem with the ports of the switch, I’ve swapped the VLAN connections to the CPU / SoC in the “Switch” settings.
Originally, VLAN 1 was connected to “CPU” and VLAN 2 to “Port 6” which is a second CPU port.
Now, VLAN 1 is connected to “Port 6” and VLAN 2 to “CPU”.
The result is:

  • only gust LAN can connect to the internet
  • the PC’s on the normal LAN can talk to each other, but no internet access and no access to the router

This means I’m locked out of the router’s configuration, as it looks like luci is boud to the address of the normal LAN. I’m currently typing on a computer connected to the guest lan.
IP is 10.111.222.211, default gateway is 10.111.222.1 but on this address, luci is not available and I also can’t ssh to this address.

Is there a way to get access without resetting to factory defaults ?

At least, this way the guest network has full speed. So it may indeed be a HW problem with “Port 6”.


#11

If you had made a schnapshot prior to the change you could rollback else reset.

Hard to tell without further diagnosis. Perhaps best to get in touch with the TO support (email ticket) and seek further advise of how to proceed.

But on port 4 you should still get the lan ip range and thus access to LuCI, that is if dnsmasq been changed when the vlan switch was made.


#12

Unfortunately, I can’t connect to the Omnia via Port 4. I’m wrinting this from a computer connected to port 4 and it can only access the internet.
On Port4, the IP is 10.111.222.211, while my normal LAN range is 192.168.1.*


#13

Then dhcp in dnsmasq was not switched when the vlan switch was made. Hence it looks like reset then.


#14

OK, I’ll do a reset.


#15

If you are not familiar yet with snapshots via cli shnapps I would recommend doing so and deploying snapshots when changes are made. This way you can rollback with the hardware button (2 LEDs: Rollback to latest snapshot)


#16

Still I don’t think there is any HW failure. I suspect vlan misconfig (because of what you said "Port 6” which is a second CPU port" which is not true). It’s linked to SOC as you can see on schema but CPU is just port5:

swconfig dev switch0 help | grep cpu
switch0: 10.mvsw61xx(MV88E6176), ports: 7 (cpu @ 5), vlans: 64

Please notice SOC != CPU

So I suggest to schnapps current config, make factory reset a verify all eth ports.
Earlier you mentioned that over guest wifi you have same poor speed as per guest port so it seems like problem of config.
I remember when I was playing with vlans and cosidering port6 as CPU port (which is not) then I had many problems some of them like you mentioned.

Edit: If you want router to see traffic it must go over port5 (tagged if there are multiple vlans going to CPU). Default vlan2 is not assigned to port5 (CPU) but router can see it as it is bridged with vlan1.


#17

After reading your Need help understanding how VLANs, Ports, Interfaces, and Adapters work together seems you are really confused.
Let me explain:
image
Default vlan config means that port0-port3 (4x1Gb) shares port5 (1x1Gb). If you receive traffic 1Gb pear each port0-3 then it will split (not exactly) to 0.25Gb because port5 is bottleneck. If you just pass traffic from port0 to port1 then will not go through port5 because the switch does the job.
Port4 is special case in default because it goes to port6. So port0-3 shares the bandwidth of port5 but port4:port6 is 1Gb:1Gb so this link is fast and not shared. But If you want pass traffic from port4 to port1 it must go through SOC.

So if you want to have port3 separated (guest) your vlan config should look like this:


Post your vlan, iface and firewall settings to check what you have.


#18

Thank you for this explanation. What I was trying to do was to use Port4 for the guest LAN, and have Port 0…3 in the default LAN. No need for Port 4 to be connected to Ports 0…3 in my case. I’m aware of Port5 being the bottleneck.
But this does not explain why I had speed issues on Port 4.

My switch setup almost looks like your example:
VLAN 1: everything “untagged” except “off” on Port 4 and Port 6,
VLAN 2: everything “off” except “untagged” on Port 4 and Port 6
and I don’t have the third line.

But after the factory reset, I don’t even have a separate network on Port 4 and I need to figure out how I did it last time. I just did everything I remember, but something is still missing.
Switch settings: as described above. Physical settings of GUEST_TURRIS: only “Bridge Adapters” and “Eth 1”

What confuses me again is that unchecking the “Bridge” option of GUEST_TURRIS cuts off internet access from LAN also.


#19

And now after factory reset - all ports are OK for speed when in LAN?


#20

Yes, speed is OK

But Port 4 is in LAN instead of GUEST_TURRIS.