[Solved] -ash: mkfs.ext4: not found

root@turris:/# mkfs.ext4
-ash: mkfs.ext4: not found

Hi guys!

How to fix it?

To format a partition, you have to designate the partion also.

So for example if your partition is sda1, it will be something like this.

mkfs.ext4 /dev/sda1
If you want to know what your drive is, use fdisk -l

root@turris:~# mkfs.ext /dev/sda2
-ash: mkfs.ext: not found

I already have partitions:

Device Boot Start End Sectors Size Id Type
/dev/sda1 2048 41945087 41943040 20G 82 Linux swap / Solaris
/dev/sda2 41945088 251660287 209715200 100G 83 Linux
/dev/sda3 251660288 754976767 503316480 240G 83 Linux
/dev/sda4 754976768 976773167 221796400 105.8G 83 Linux

type mkfs and then hit TAB, there you will see what mkfs commands are availaible. See the example, here…

root@K-Router:~# mkf
mkfifo mkfs.btrfs mkfs.ext2 mkfs.ext3 mkfs.ext4 mkfs.fat mkfs.hfs mkfs.hfsplus mkfs.msdos mkfs.vfat mkfs.xfs

mkfs stands for “Make FileSystem”. Then you will get after the dot (.) the filesystem you can choose from. I myself use ext4 with my LXC partition on my mSata disk.

root@turris:/sbin# mkf
mkfifo mkfs.btrfs

done!

I see, you have not installed the other addons.

Type first “opkg update

Then type “opkg install kmod-fs-ext4

This will install the ext4 “addon” to use.

Already tried this way
root@turris:~# opkg install kmod-fs-ext4
Package kmod-fs-ext4 (4.4.150+1-1-0a333a8e606ab056173befac424900d2-1) installed in root is up to date.
root@turris:~# mkf
mkfifo mkfs.btrfs

Can you put the output of this command

cat /etc/turris-version

root@turris:~# cat /etc/turris-version
3.10.5

Can you go to this folder

cd usr/sbin/

and type ls. Give the output of it

root@turris:~# cd /sbin
root@turris:/sbin# ls
askfirst fw3 ifstatus led.sh pivot_root route switch_root udevd validate_data
check_connection halt ifup logread pkg_check rpcd sysctl udevtrigger vconfig
devmem hotplug-call init luci-reload poweroff snapshot sysupgrade udhcpc wifi
devstatus hwclock jffs2mark mkswap procd snapshot_tool ubusd upgraded
fan_ctrl.sh ifconfig jffs2reset mount_root reboot start-stop-daemon uci uqmi
firstboot ifdown kmodloader netifd reload_config swconfig udevadm usbmode

No not /sbin, but /usr/sbin/

Sorry!

root@turris:/sbin# cd /usr/sbin
root@turris:/usr/sbin# ls
6rdcalc conntrack hostapd iptables miniupnpd openvpn sshd ubiformat usermod
ahcpd conntrackd i2cdetect iptables-restore modinfo opkg-key syslog-ng ubimkvol vpnc
arping cron i2cdump iptables-save modprobe pppd syslog-ng-ctl ubinfo vpnc-disconnect
atd dnsmasq i2cget iw ntpd pptpctrl tc ubinize wpa_supplicant
bcrelay ebtables i2cset iwconfig ntpd-hotplug pptpd tcpdump ubirename wpad
br2684ctl fdisk insmod iwlist ntpdate relayd telnetd ubirmvol xtables-multi
brctl fw_printenv ip iwpriv odhcp6c rmmod tinyproxy ubirsvol
cert-backup fw_setenv ip6tables lighttpd odhcpd sendmail ubiattach ubiupdatevol
chat groupadd ip6tables-restore logrotate odhcpd-update sensors ubiblock update-pciids
chroot groupdel ip6tables-save lsmod openconnect setpci ubicrc32 useradd
collectd groupmod ipset lspci openconnect-wrapper sfpswitch.py ubidetach userdel

That is strange. Oke, can you do a

opkg remove kmod-fs-ext4

Then try to opkg update

Then again try to opkg install kmod-fs-ext4

Done:
Configuring kmod-fs-ext4.
root@turris:/# mkf
mkfifo mkfs.btrfs

You could try to wget the package, then locally install the package. But where to get those packages,

Download locally by using

opkg download mkf-fs-ext4

with it, install using opkg install kmod-fs-ext4_4.4.150\+1-1-0a333a8e606ab056173befac424900d2-1_mvebu.ipk

With that, i would also recommend you get the attention of a admin, as this looks rather like a bug or something.

Tried:
root@turris:/# opkg download mkf-fs-ext4
Collected errors:

  • opkg_download_cmd: Cannot find package mkf-fs-ext4.

Sorry, meant to say opkg download kmod-fs-ext4

Still the same result:

root@turris:/# mkf
mkfifo mkfs.btrfs

As far as you are doing, it install it, but somehow nothing is put in that directory. Are the permissions oke? With that command you can see what permissions it has on the directory.

root@K-Router:/# ls -lisa /usr
2044 0 drwxr-xr-x 1 root root 44 May 3 06:58 .
256 0 drwxr-xr-x 1 root root 272 Sep 8 22:18 …
7618 0 drwxr-xr-x 1 root root 4252 Aug 22 22:40 bin
2519 0 drwxr-xr-x 1 root root 11656 Aug 22 22:40 lib
7614 0 drwxr-xr-x 1 root root 148 Aug 22 22:40 libexec
2045 0 drwxr-xr-x 1 root root 2618 Aug 22 22:40 sbin
2191 0 drwxr-xr-x 1 root root 522 Jun 27 11:03 share