Opening LuCI port forwarding page is very slow (40s)

Do you use DNS forwarding? If yes to which server? Can you try a different one?

Hello,
when I apply in the foris/config/main/dns - DNS forwarding the “CZ.NIC (TLS)” the LuCI firewall rules open fast way (<1sec).
Applying the "Use the providers DNS server " implies very slow loading of Firewall rules edit page … (>30sec).

Model: Turris Omnia
Turris OS: 3.11.14
Location: CZ

1 Like

I think the best workaround is… not to “Use provider’s DNS servers”. My favorite mode of operation is to uncheck “Use forwarding”, at least in general case.

For reference, another (old) thread about this: Slow LuCi...5s response time

2 Likes

But this is not a solve to this problem. What if i don’t want to use CZ.NIC DNS ? For this money which i spent on this router i want to set up my router … my way. This is like a bloatware,… the manufacturer which created an open source router pushes me into using their servers and their settings, this is absolutely unacceptable.

I recommended not to use forwarding (to any provider, i.e. not even to us).

This is clearly a misunderstanding. No, this is not even like bloatware or anything else. If the DNS servers, which you are using are most probably broken what we should do about it? LuCI developers know about the issue, but the problem is within DNS. If you don’t want to use CZ.NIC DNS servers, there are others provided in Foris, right? You can also turn off the forwarding at all. By default, there is enabled forwarding to your provider’s DNS server.

If this issue happens that LuCI is loading to you slowly, I suggest trying the provided options. In our documentation, you can see more details about DNS and forwarding. Also, you can check the article for Getting help.