Opening LuCI port forwarding page is very slow (40s)


#1

When opening LuCI interface for Firewall - Port Forwards it took very long time to load - about 40 seconds. I have just one rule there and it works fine. It just take lot of time to load the page. Everything else works perfectly fine and fast I did not found any other problems.

URL: http://xxx/cgi-bin/luci/admin/network/firewall/forwards

This is happening since I bought the router few months ago. Auto updates are enabled.


#2

FWIW, the tab opens quite fast on my Omnia, so it doesn’t appear to be a general problem. Have you tried a different browser to rule out a client side problem?


#3

Thanks for fast response. It is problem with this one GET HTTP request. I tried to execute it with Fiddler proxy and also with curl directly from SSH console of Turris with same result using:
curl localhost:80/cgi-bin/luci/admin/network/firewall/forwards -H "Cookie: sysauth=MYSECRETAUTHCOOKIE"

Wierd thing is that it tooks about 40.5s ±100ms every time I tried it. Even if I executed multiple requests at the same time.


#4

Interesting. Takes about 0.3s on my Omnia.


#5

Tested 3 times now, every time around 5,9second (by curl, lan cable) displaying 8 entries.


#6

It is quite safe to say that there is some specific problem related to this one page. And because of consistency (40.5s±100ms) it can be some kind of timeout set to about 30-40s.


#8

By me in Luci (It has been manifested for a long time) :
Wake On Lan … 54 sec
Wifi edit … 40 sec
FW - forwarding 14-20 sec
Majordomo … 10 sec (Here’s why)


#9

For me it is blazing fast (less than 1s). I dont have any forward rule there, though. What happens if you delete that one rule? Is it still as slow as before? If yes, how about to rollback some snapshots (step by step) or factory reset? Check if it is still that slow in those cases.


#10

It is slow even without any rules. I don’t want to reset configuration of router - I want to find out what happened and do not want to reset all my settings.


#11

By me is ready from v2.6.4 .

Now in 2.6.5 … the same old bad and slow reaktion
¨
Wake On Lan … 54 sec
Wifi edit … 40 sec
FW - forwarding 14-20 sec


#12

I have the same problem with the port-forwarding tab. It takes about 30 sec to open and I have no rules defined. I am running Turris OS 3.9.5.

I have an even longer delay when opening the editing of FW rules (or creating new ones) from the Traffic Rules-tab. This takes about 2 minutes.

This problem existed already when I wanted to add my first own custom rule. All others were configured by the OT itself or via the FW-Zone settings. I have 6 zones connected to 3 LANs and 3 WLANs (2 of them configured for 2.4 and 5 GHz). I don’t know if this has any impact. The WLAN pages were slow when I opened them the very first time. But the rest used to be faster, even with a similar configuration.

Also editing WLAN-configurations opens very slowly (about 50 sec).

I did not check all the rest of the UI but mostly it is responding fast.

I measured both delays now twice and both measurements gave the same results.

Everything seems to work though.

I did reset the router and then reloaded the configuration. Same problem. Any suggestions


#13

Hello,
I have just received my new Turris Omnia, connected it and let it download all its upgrades.
On my way configuring it I found this page to go also very slow without any clue. I have not installed anything yet. I have observed the same issue when configuring the wifi. Other pages go very fast.
When I open the network tab in the browner inspector, it shows waiting for 45.45s, There has to be something on that page that is making it go very slow.

I will see if I can do some research on what is going on.


#14

Looks like I am not the only one affected by this issue. Any ideas how to do diagnostics?


#15

Same problem for me.


#16

Hello guys,

it it affects multiple users, how about contacting and reporting issue directly to Turris team?
A forum is not the best place for this and although they look around sometimes here and there but obviously they cannot track all thread


#17

The faulty slow state has lasted a very long time what I remember in Omnia history … ( Wake On Lan … 54 sec; Wifi edit … 40 sec; FW - forwarding 14-20 sec) . For me, the time to open the options below is changing for no apparent reason.

In the last time about 4 months the status changed 4 times back and forth (quick x slow) . Now pages responds immediately.


#18

Another report here (20+ seconds to open the port-forwarding tab).


#19

@Fenevadkan Have you had a reply from the Turris team yet?


#20

I have asked you all, who have this issue to report it. I haven’t reported anything since I do not have the mentioned issue.

UPDATE: hmm, I checked again and I have this issue as well. It is not as bad as the reporter here with 40s, but it definitely loads slower than other tabs in the firewall section, although I do not have any port forwarding so the page is a kind of empty. Other tabs load in 1s, this one loads in ~15s


#21

Yes, I have reported it. I will post update here when the issue will be closed. They are working on diagnostics now.