Omnia lid hot and LTE connection going down after a few minutes

The Turris Omnia is fantastic for my multiple, portable computer needs. Just that this owner ain’t exactly blessed with the greatest of technical know how :slight_smile: I’m sure that I’m only using 30% of its capability.

I bought the WiFi 6 upgrade kit during the colder months and all has been fine with no Internet connection issues. Don’t know if it’s pure coincidence, but putting my hand on top, it’s now noticeably warmer than last summer. Must state here that the ‘only’ Internet connection I have is through LTE.

The issue: The connection from Omnia to my Arch Linux PC is is always up, but the LTE Internet connection won’t come up until I reboot, then it dies after a minute or so. However, if I unplug the Omnia and leave it to get cold, then upon booting up the Internet might be accessible for 10 minutes before it goes down again.

My assumption is that the WiFi card is overheating. Could it be that there’s an ever so slight difference in height between the newly supplied black metal upgrade kit lid and the original silver one? Maybe that’s causing the lid to break contact with the thermal pad on the WiFi card cooling block Edit: I meant LTE card aluminium cooling block. Difficult to tell as it’s like trying to see if the light is on when you close the fridge door. Reason why that might ‘not’ be the case is that the metal lid is hot… or is that what happens anyway when there is no mating between the thermal pad and metal lid?

Just ordered some soon to arrive thermal pads (a first for me), but any other thoughts would be appreciated.

Question regarding the LTE-connection - is this via a mPCIe-card + the respective aluminium cooling block?
If you do not use this alloy block for LTE it is doomed to die as you just are experiencing.
Your new WI-Fi6 card is getting really hot, and mixing that with the also fast-heating LTE-card will inevitably lead to broken LTE-internet.

I unfortunately do not know what you mean with thermal pad and WiFi card cooling block.

There are several options on how to make sure your device is sufficiently cooled - TO unfortunately was not designed to cope with hot cards. But they at least designed those aluminium blocks, which have the exact hight between mPCIe-card and enclosure and thus can use the enclosure as heat pipe. Yet the enclosure is als not designed to dissipate more heat than the LTE-card + the CPU (which is already connected to the enclosure).
What you can do to work around that is modify your enclosure and add an external fan that is powered on 5V via USB - this is what I did (posted somewhere else on this forum) and thus I am cooling

  • 3 WI-FI 6-cards, that are connected to the enclosure via the mentioned alloy blocks
  • 1 LTE-card + 1 WI-Fi6-card connected to the enclosure via alloy blocks, the third slot is occupied by a mPCIe-to-NVME-adapter to host my NVME-ssd used for security-video-recording in a remote location.
1 Like

Sorry, I meant the LTE card cooling aluminium block that I bought and have always had in place.

Well, I removed the cover and just had a quick peek… didn’t do anything else. The silicone thermal pad was firmly in place and hadn’t moved at all. Then placed the cover loosely back ‘without’ the six case screws inserted. I don’t know why, but the case is now barely warm to the touch, just as it used to be. Uptime for the Omnia is now over 30 mins with no issues. Hurrah! Working perfectly!

Thanks for the reply. Over the weekend I’ll see if putting the screws back in maybe alters (raises) the height of the new cover, causing an air gap. Maybe not at all, but one possibility. Remember, this is the new cover that comes with the WiFi 6 kit, and the first time it has been subjected to summer heat. I’ll experiment and see what happens.

Spoke too soon. Lasted just over 30 mins then Internet lost again. It’s cooler weather today, maybe that’s why.

1 Like

Different from your fridge, Omnia has a way to see the light behind the closed door. It is called sensors. Install it via opkg update && opkg install lm-sensors. Then you can read the temperatures of some parts of the switch. Not sure if the LTE card itself offers temperature measurements, but you can usually see the effects of heating up on all components.

3 Likes

Now away for ten days. Will post results here upon return.

I don’t have LTE card, just trying to help here.
I my case my Omnia was nearly 70°C, I just connected simple cheapest USB fan to the back USB and pointed it to the lid, and the temp dropped by 10 C immediately.

As for monitoring the temperature, you can use collectd with plugins collectd-mod-sensors and collectd-mod-thermal that will be visible in LUCI http://192.168.1.1/cgi-bin/luci/admin/statistics/graphs


Not sure if it will read LTE card though

1 Like

Your reply is much appreciated. From what I’ve read here, the LTE card temperature is not read by any sensors. Would like to be told I’'m wrong on that.

When I’m reunited with my Omnia in just over a week, I’ll try some ‘cooling’ experiments. I feel it must be a temperature problem, as from stone cold the LTE Internet connection will last for up to 30- 45 mins, but thereafter each restart only keeps it up for about 5 -10 mins. It varies each day… possibly the weather.

Of course, I could be wrong on all of this.

Probably out of my league here with this issue, and I don’t want to have everyone babysit me with multiple long replies. Anyway, reunited with Omnia earlier than I thought. Whereas it used to connect via LTE for a while then disconnect, now LuCI Interfaces shows:

Protocol: ModemManager
RX: 0 B (0 Pkts.)
TX: 0 B (0 Pkts.)
Error: Network device is not present

This is now after a stone cold startup. I have no idea what’s up. Have opened the box and re-seated the LTE card.

Edit: Wiped the whole Omnia clean with a factory reset. Upon software reinstall, checked that kmod-usb-serial-qualcomm is installed.

I go to add the lte interface in LuCI and can indeed select the UMTS/GPRS/EV-DO drop down option, but there is no /dev/ttyUSB2 in the modem drop down menu.

I tried to custom add /dev/ttyUSB2 and still get:

Protocol: ModemManager
RX: 0 B (0 Pkts.)
TX: 0 B (0 Pkts.)
Error: Network device is not present

Would I be right in thinking the modem is broken? If it is, not sure I want to spend £80 on yet another lte modem.

Always realised that this device was really for WAN connected use, with lte being an unsupported, customer purchased add-on. If it is broken, I’ll probably just sell and go for an equally supported lte and WAN device.

Unfortunately I have no experience with it, just did you see Installation of LTE modem into Turris Omnia router [Turris wiki] and Supported LTE miniPCIe cards [Turris wiki]
Otherwise I would suggest reach Turris support they may be able to help you Turris - Support

1 Like

Thanks xsys, Yes, I’ve read all the docs. This modem has been working perfectly for years. Then gradually over the last 10 days got worse and worse until it now isn’t recognised.

Was always under the impression that when it comes to LTE, you’re on your own as far as Turris are concerned. I understood that before purchase, so in no way a criticism. They do have some YouTube videos up on the subject, and I’ve taken note from those.

I wouldn’t know how to test a modem to see if it’s broken. Probably don’t want to throw any more money at this ageing unit anyway.

I’ll give tech support a try anyway, just in case they can oblige. Thanks for that suggestion.

EDIT: Sent a bunch of Omia reports as requested by tech support on Friday 5th July. Will post outcome as soon as I receive a reply.

Can’t fix this. I doubt tech support will get back to me for days now. I bought another modem and have exactly the same issues. Gets to the point where it’s pointless spending any more money on it.

Feel like simply trashing the thing - that’ll be a hammer to it - and move on. I cannot be without a connection for so long, and with each reply from tech support taking so long. Just not worth my time.

Your modem coukd show up as /dev/ttyACM0 or /dev/wdc-eter or something like this. Depending on the model or protocol. You cannot simply type ttyUSB2 if it doesnt exist

Fact… Iamnowloco :slight_smile:

I get too frustrated over mechanical things that don’t work… I know. Especially as I changed nothing. One day it was working (after years of flawless use); the next, nothing. Yep, I figured you can’t just type it if it isn’t in the drop down menu. Gave it a try anyway, just in case. In fact, /dev/ttyUSB2 used to always be an option. Now it isn’t there, but was earlier this afternoon, before I did another factory reset. I’m just clutching at straws here. At some point I’ll probably throw it against the wall and go buy something else.

Thanks for that tip. I’ll try the two options you suggested. All the documentation says /dev/ttyUSB2, but I’ll give your idea a try when back home tonight.

Here are the docs I’m referring to:

https://wiki.turris.cz/en/howto/lte_modem_install

Dont try what I told you.

Just do

ls -la

In /dev directorynand seee what there also what dmesg prints about devices

Sure thing. Command line no problem. Thanks again.

Because you are trying top level thing of abstaction like connecting to actual modem and you should first see if its even detexted in the system

Than see what devices it provides install required kernel modules for that device see again and then try to connect

Because you just said it doesnt work. In linux you have logs you could provide the model of the modem and things like that.

It used to be connected, then nothing. Leading up this the connection would drop after the machine/modem heated up. Then it would go down after 5 - 10 mins or so. If I let it cool down for an hour, the connection would stay up for 45 mins or longer. Then ten days ago, nothing at all, and the LuCi interface since then always says ‘not detected’ (or something like that).

The longer I keep posting, the more petulant and annoyed I’ll probably sound… I know :slight_smile: After tomorrow, as no way ‘support’ will get back to me before Monday, I’ll start looking elsewhere. Probably Teltonika 5G routers. Being truly portable appeals as I hardly ever use a fixed landline.

Edit: Emailed support a complete zipped up batch of diagnostic tests. That was days ago. Then just earlier today, another requested batch of the same.

Have to repeat that this setup has worked flawlessly for years, until now.

You’re right. All of the tty’s end with either a number or the letter ‘S’. Also, nothing there like the other options you described. Looks like the LTE modem isn’t being seen at all. And this is the replacement modem that arrived today.

dmesg says nothing about Quectel (modem brand), or the Qualcomm chip it’s based on, nor LTE. To be honest, that’s all that I’d know to look for. Getting close to the limits of my knowledge and skill here.

Maybe Turris OS 7 doesn’t work with the Quectel C25-E modem anymore. Thing is, I’ve just wasted £20 on a replacement modem I didn’t actually need, and wouldn’t want to spend another £100+ on a third modem, only to find that doesn’t fix it either.

When I emailed Turris support last Friday, they got back to me on Tuesday. Will assume the same again.

Hurrah! The issue has been solved. Rather than wait until Tuesday (four days from now) for a reply from tech support and the ‘possibility’ of a fix, I’ve bought a Teltonika router instead.

Thanks for all the help here. The cause of the problem will have to remain a mystery forever.