NTP server choice removed?

I’m sure you used to be able to choose which NTP server you wanted to use by typing in the domains?
Was this functionality removed from LuCI?

LuCI development is managed/done by upstream OpenWRT and not the the TO team.

Perhaps the question is better placed with OpenWRT.

According to screenshots I’ve seen from searching, it still exists in OpenWRT. I have not personally verified the latest version however.

Foris also does not seem to allow editing the entries used, you can only view them.

That is correct but might be worked on

They may not reflect the current LuCI state, which does not provide the option any more - I do remember it used to be possible as it was to install ntpd - which now is handled by systnpd (busybox) however.

There would be also luci-app-ntpc with ntpclient but that will create just an conflict with sysntpd

So just to be clear, this was actually removed from LuCI and (for now) the only way to edit them is via SSH?

that is the short of it indeed

1 Like

You can still change the NTP servers in OpemWRT LuCI in 18.06 and master.

1 Like

Oops, that it is interesting. It would imply that TO is patching LuCI and remove the option. Just what purpose that serves is a bit of mystery, preventing the access to the option via UI.

Could you share perhaps a screenshot?

Why we would remove the option? We are patching LuCI mostly for branding and no patch removes the option.
In OpenWrt 18.06, we have 5 patches for LuCI and no one does that.

  1. backport: luci-app-transmission to allow user to define custom web ui
  2. branding: remove uhttpd dependency
  3. branding: add webapps
  4. branding: use by default our server for LXC containers
  5. wip: don’t use opkg --force-overwrite

Look here: https://gitlab.labs.nic.cz/turris/turris-build/tree/v4.0/patches/luci

In OpenWrt 19.06 and OpenWrt master, we have just two patches:

  1. branding: remove uhttpd dependency
  2. branding: add webapps
    Look here: https://gitlab.labs.nic.cz/turris/turris-build/tree/master/patches/luci/
That is how it used to look in LuCI

And if am not completely mistaken for that part it requires ntpd being installed and not just busybox’s sysntpd implant.

I found the culprit.


If there is no /usr/sbin/ntpd, then it isn’t shown in LuCI. Once I created symlink, it’s there.

symlink -s /sbin/ntpd /usr/sbin/ntpd

It seems that it should work. I checked to provide NTP server and I see that it should be running:

root@turris:~# netstat -l | grep ntp
udp        0      0 :::ntp                  :::*

This is an issue across all Turris OS versions.


It runs also without the link being set but at least now shows in LuCI.

In LuCI here is a hard coded path, but it’s the same as it should be in OpenWrt:

Unfortunately, this was caused by one of our patch, which moves busybox binaries to /{s,}bin from /usr/bin.

I prepared a pull request to fix this in Turris OS:

1 Like

Fixed in the Turris OS 3.11.6, upcoming next version of Turris OS 4.0 and as well with Turris OS 5.0 (branch HBD, based on the cooking OpenWrt 19.07) and I shouldn’t forget also Turris OS 6.0, which is daily build on branches master of OpenWrt.

Thank you for your reporting.


4 posts were split to a new topic: NTP: add a list to choose from in Foris/LuCI