Nextcloud issues after updating router

FWIW my update to T5 here wrecked Nextcloud, among others, in such a manner that I cannot even reinstall it, even when deleting all the hosted data (which is more than a pain in itself)

But consider you lucky, you got a reaction : for me, I got absolutely no answer on this forum, one month after my post.

This is a concern, because I retain the impression that Turris is a thing for daring geeks ready to trash anything and restart from square one at any time, and not at all something one can rely on.
I am in a situation to recommend it to (only) a couple of users : at this time I just cannot risk they call me back next update with all their data disappeared.

Now if anyone here can react on my post from last month… Otherwise I’ll search around here for a procedure to completely factory reset everything -but even this, is not obvious to find.

Thank you Viktor.
Do I understand there is just no way to properly reinstall just the NextCloud part?
Is Nextcloud only working with the previous version of Turris OS?
Thank you!

Nextcloud works with TOS 3 and also 5. Current TOS 5.1.2 supports Nextcloud 18. Upcoming TOS 5.2 could support Nextcloud 19.

Thank you Viktor!
But I see the second link says ‘After doing this update, it is required to reboot your router.
Because then it couldn’t find anything at IP/nextcloud.
And once you do restart, it guides you to update it, and since then
it works flawlessly.

This I tried various times before posting here, but it didn 't work.
At this moment I have even reinstalled the external HD (deleting everything on it, I suppose) but this too doesn’t help : I just don’t have the possibility yo update, just saying NextCloud is already installed, but no instance appears when I try to connect to the NC url.
Anyway : I’ll try again, scrupulously following these directions, but in a couple of days because I am away at the moment.
Thank you again, I’ll come back to describe the result.

P. S. I react lately because the forum was down yesterday, but it’s visibly back today.

1 Like

I am sorry, but if you are seeking for any official response from our team, you should start with Getting help article as a forum is a place, where the community helps each other.

Cross-post from your thread, which you mention:

Can you check if your external storage is mounted correctly? Are you using USB flash disk drive or HDD/SSD? Were they plugged during the update? This is important. If it gets unmounted somehow, then the update of Nextcloud goes proceed on eMMC, which is not wanted.

And this is the issue at all. Nextcloud does not provide support and they don’t even suggest it to skip major versions of Nextcloud. You should be following it one by one and this is what we are currently doing in minor Turris OS releases.

Thank you Pepe!
I am away from the machine at this time, I’ll be back on sunday and perform these checks.
I can say already that

  • as concerns the external storage, it’s an HDD that wasn’t unmounted during the update. After a while I accepted the idea of losing all my Nextcloud data and tried to re-install this external storage, which apparently was done successfully, but whenever I then ask to install Nextcloud again the only message I get is that it’s already installed.
  • on your last point, updates, to be clearer that’s Turris updates I am talking about. I never updated Nextcloud through its own updating process, I just somehow expected it would be updated through Turris updates. When I say a long process with reboots etc. it’s fhe Turris updating I am talking about.

OK, everything still fails when I apply the “reset to 2 DEL” method.
I consider trying the “reset to 3 DEL”, factory config, but will this delete all my settings, networks, passwords etc?

Any Solution ?


No. This is a wifi I need to work, so I continued without Nextcloud, nor with any further updates.
In a couple of months I may get mor time to reset everything.
In the meanwhile I installed a Nextbox, separately, and I also use a community-hosted Nextcloud.

1 Like