MOX Vlan6 on WAN

Hello there, got the MOX today. Initial setup was a bit wonky, but got it running over present LAN network, and updated to latest beta7.

But now i like to have the WAN straight to the internet…and this is the protocol : FTTH • PPPoE via VLAN6 (802.1Q) according to my ISP. So that means PPPoE with user/pass.
My ISP uses VLAN6 for internet, and 4 for IPTV… so i need to have it on 6.
Now, i cannot find the VLAN setting like the TO, and i think i have to do it in LUCI > Network interf >WAN > edit >physical settings …make vlan6 wan,

and then i’m lost. Anyone ?

Scroll all the way to the bottom in the list, and there should be a text field where you can put in a custom device name. Enter eth0.6 there.

Isn’t WAN on eth1? Then it would be eth1.6

well, got it sort of working in luci with replacing eth0 with eth0.6 on the WAN, but as soon as i went to forris>WAN, it was telling me no connection.
And in forris in network adapters the WAN was not assigned.
So, it does work on the hardware side, only i need to find the right configuration in the luci>network>interfaces sections.

ok. still no progress. May i suggest that the developers make the VLAN option in forris at the WAN section? Since many potential clients are forced to use vlan by the ISP.

thank you.

Ha! The solution is to luci>network interfaces> add new interface
protocol PPPoE ( instead of modifying the present WAN interface )
goto physical settings & make custom eth0.6
wait, and then go back to forris and set WAN correct.
Still a bit buggy, but works now.

edit. Remove the original WAN netw interf before making new one. Keeps giving trouble in Forris, but in luci it runs stable.

still buggy. takes about between 50 min and 5 hours to reconnect after reboot.

this goes on for about 50 mins, and then :

Aug 11 14:41:29 turrisMOX pppd[28723]: pppd 2.4.7 started by root, uid 0
Aug 11 14:41:36 turrisMOX insmod: module is already loaded - ppp_generic
Aug 11 14:41:36 turrisMOX insmod: module is already loaded - pppox
Aug 11 14:41:36 turrisMOX insmod: module is already loaded - pppoe
Aug 11 14:41:36 turrisMOX pppd[29111]: Plugin rp-pppoe.so loaded.
Aug 11 14:41:36 turrisMOX pppd[29111]: RP-PPPoE plugin version 3.8p compiled aga inst pppd 2.4.7
Aug 11 14:41:36 turrisMOX pppd[29111]: pppd 2.4.7 started by root, uid 0
Aug 11 14:41:43 turrisMOX insmod: module is already loaded - ppp_generic
Aug 11 14:41:43 turrisMOX insmod: module is already loaded - pppox
Aug 11 14:41:43 turrisMOX insmod: module is already loaded - pppoe
Aug 11 14:41:43 turrisMOX pppd[29370]: Plugin rp-pppoe.so loaded.
Aug 11 14:41:43 turrisMOX pppd[29370]: RP-PPPoE plugin version 3.8p compiled aga inst pppd 2.4.7
Aug 11 14:41:43 turrisMOX pppd[29370]: pppd 2.4.7 started by root, uid 0
Aug 11 14:41:43 turrisMOX pppd[29370]: PPP session is 2838
Aug 11 14:41:43 turrisMOX pppd[29370]: Connected to xx:xx:xx;xx:xx;x via interf ace eth0.6
Aug 11 16:41:43 turrisMOX kernel: [84215.903448] pppoe-WAN: renamed from ppp0
Aug 11 14:41:43 turrisMOX pppd[29370]: Using interface pppoe-WAN
Aug 11 14:41:43 turrisMOX pppd[29370]: Connect: pppoe-WAN <–> eth0.6
Aug 11 14:41:44 turrisMOX pppd[29370]: PAP authentication succeeded
Aug 11 14:41:44 turrisMOX pppd[29370]: peer from calling number xx:xx:xx;xx:xx;x 5 authorized
Aug 11 14:41:44 turrisMOX pppd[29370]: local IP address xx.xxx.xxx.xxx.
Aug 11 14:41:44 turrisMOX pppd[29370]: remote IP address xxx.xxx.x.xxx
Aug 11 14:41:44 turrisMOX pppd[29370]: primary DNS address xxx.xxx.x.xx
Aug 11 14:41:44 turrisMOX pppd[29370]: secondary DNS address xxx.xxx.x.xx
Aug 11 14:41:44 turrisMOX pppd[29370]: local LL address xxxx::xxxx:xxxxx:d0b0:00 46
Aug 11 14:41:44 turrisMOX pppd[29370]: remote LL address xxxx::xxxx:xxxf:xxxa:xx a5
Aug 11 14:41:44 turrisMOX netifd: Network device ‘pppoe-WAN’ link is up
Aug 11 14:41:44 turrisMOX netifd: Network alias ‘pppoe-WAN’ link is up
Aug 11 14:41:44 turrisMOX firewall: Reloading firewall due to ifup of WAN (pppoe -WAN)
Aug 11 14:41:50 turrisMOX firewall: Reloading firewall due to ifupdate of WAN (p ppoe-WAN)
Aug 11 14:41:56 turrisMOX firewall: Reloading firewall due to ifup of WAN_6 (ppp oe-WAN)
xx@turrisMOX:~#

What is happening (going wrong) during that time (logs)? Which OS version is this?

this is 4B7 and now 4B8 on a MOX classic.
Whats going wrong is that the PPPoE connecting sequence is in a 50 min loop, and then suddenly decides to connect.

Without additional data it will be difficult to get to the bottom/cause of the issue.

Do you know how to connect via ssh from a router client to the router and modify files on the router over ssh?

did remove the #, and then it took 5 hours to connect…

So put the # back, to get online again.
I removed the # again, but have to wait till tomorrow to have it logging, otherwise the internet is down :slight_smile:

with -l /sys/class/net :
lrwxrwxrwx 1 root root 0 Aug 10 17:18 br-guest_turris -> …/…/devices/virtual/net/br-guest_turris
lrwxrwxrwx 1 root root 0 Aug 10 17:18 br-lan -> …/…/devices/virtual/net/br-lan
lrwxrwxrwx 1 root root 0 Aug 10 17:18 eth0 -> …/…/devices/platform/soc/soc:internal-regs@d0000000/d0030000.ethernet/net/eth0
lrwxrwxrwx 1 root root 0 Aug 10 22:24 eth0.6 -> …/…/devices/virtual/net/eth0.6

when that line pops up, it connects.

btw, on this openwrt page, it tells me what my ISP want for settings:

https://openwrt.org/docs/guide-user/network/wan/isp-configurations?s[]=xs4all

''did remove the #, and then it took 5 hours to connect…""

ok, test nmr 2, if i remove the # , it won’t login at all. Something is buggy…

But is should provide more verbose log info (as opposed to debug being commented (#)) of what is happening, does it not?

nope, same info in the syslog. And not connecting at all.

did you reboot the device or restart the network after the changing the debug flag? On my node with the debug flag enabled PPP prints at lot of info in the log.

Yes. I removed it , and rebooted. did that overnight, in the morning still offline. So, put the # back, I had to stop the WAN in net interfaces, and restart it , then it came online.

btw this is the setup needed Inkedconfig_1_LI