Mox reboots randomly after TOS 6.0 upgrade

My Mox was very stable in previous versions.

Now it suffers unexpected reboots every few hours.
It’s also reported by some other users: Turris OS 6.0 is released - #120 by dadall


Related to this: A3720 CPU random crashes (#372) · Issues · Turris / Turris OS / Turris Build · GitLab

1 Like

I’ll probably have to revert to TOS 5.
Those reboots are incompatible with telework and self-hosting

Same here. Its irony, because more than year my MOX was bug that still freeze after reboot and i always had to unplug power everytime. Now reboot from web-admin working, but MOX randomly reboots.


Same here! I somehow tolerated the manual powercycling, some might say that for far too long. But this rebooting is extremely annoying specially with telework and… basically all online activities.
Waiting for an update on this. Hopefully something comes quick…?

1 Like

Exactly the same. It also ran into trouble (“Out of memory”) during the initial upgrade, producing a non-functional router after reboot (ought to have left it), but fortunately the system seemed to retry the upgrade successfully some time later (while I was searching for software downloads to install from card or usb).

1 Like

Is there a log that survives over a reboot I can inspect after a crash/reboot to see the cause?

I can muddle through because the crashes aren’t currently that frequent, but it’s a nuisance having to re-establish VPN links if they time out over the reboot.

1 Like

Same feelings about that so long waited reboot :smiley:

You have to connect a USB drive and configure syslog-ng to use it as a second log location.

I have the Same Problem is there any solution for it. After I go back to a pre 6.0 snapshot I’ve to flash my MOX. where can I download the 5.4.5 Version of Turris OS?

After flashing with 6.0.1 I didn’t install any aditional package and the Issue still exists.

I uploaded my log-file to GDrive: srv/log/messages.


Same here. Reboots randomly. :frowning: On the other hand soft reboot finally works. :slight_smile:

1 Like

Ok, I can’t take it anymore… Will rollback the upgrade and disable automatic updates for the time being.


Thanks, I might try that. It turns out that it’s rebooting roughly every 2 to 3 hours (last time just 15 minutes ago), which gets to be a pain if I need the office VPN.

Any sign of rescue by The Management?

Not that I am aware of, unfortunately. Except the gitlab issue mentioned at the very beginning of this thread.

I’ve tried to ask in another thread (Turris Mox USB (from module A) not working any more (for mass storage) after TOS 6.0 upgrade - #12 by Mossroy), but got reprimanded about cross-reference.

I understand the situation is probably complicated for Turris staff, I’m not trying to blame them.

However, I’m surprised that these Mox issues have not been mentioned in the “aftermath” thread: Turris OS 6.0 aftermath

Like some other ones, I did a rollback on this upgrade, and disabled automatic upgrades until there is a more sustainable solution. See Turris OS 6.0 is released - #143 by Mossroy


Thanks for the roll-back instructions. How long did you wait before rebooting?

I am 1 of the early backers of the indiegogo campaign and ever since I got the mox, every time it does a soft reboot after an update it hangs. I normally worked around this by doing a power cycle.

However, since the latest update my router gets rebooted randomly and because of the hanging problem on reboot, it can’t boot up properly, forcing me to power cycle the thing constantly. I have since rolled back to TurrisOS 5.4.4 or 5.4.5, not sure if it would solve the problem.

If I get a brand new module A, will I still be experiencing the hang on soft reboot problem? Does this problem still persist?

My configuration is AGBEE with the PoE and 1GB RAM upgrade together with the miniPCIe wifi card

Maybe one minute.

It should be very fast, as I suppose it’s mostly switching to a btrfs snapshot

Thanks that all worked.

At least rebooting now without unplugging, it is progress.

1 Like