Monitoring Omnia with NetData

I just saw the new release v1.5 of netData, a system for monitoring Linux based serves (now also other OSes possible). This looks so damn juicy, I’d like to try it on the Omnia.

Has somebody already done it or experience with netdata?
Also similar monitoring system could be worth a look…

3 Likes

Hello,

yesterday I installed netdata in an Ubuntu 16.04 LXC container running on turris omnia. It works nicely but I am not sure that it will gather all metrics of the host - but certainly most of them.

hostname netdata
apt-get update
apt-get install zlib1g-dev uuid-dev libmnl-dev gcc make autoconf autoconf-archive autogen automake pkg-config curl
apt-get install python python-yaml python-mysqldb python-psycopg2 nodejs lm-sensors netcat
apt-get install wget
git clone https://github.com/firehol/netdata.git --depth=1 ~/netdata
cd ~/netdata
sudo ./netdata-installer.sh

Basil

1 Like

Oh no, that’s bad news. I was so happy to dinf such a nice and sleek monitoring frontend.
Do you guys know anything similar?

Hi guys. Nice you like netdata.

The only hard requirement to run netdata on a linux host, is libuuid.
It would also be nice to have zlib, but even this can be disabled.

Of course, you are going to need a linux kernel with /proc enabled.

Nothing more. This is it.

2 Likes

Hello,

Amazing!

We have everything! So it should be possible.
/proc works

root@TurrisOmnia:~# opkg install libuuid
Package libuuid (2.25.2-5) installed in root is up to date.

root@TurrisOmnia:~# opkg install zlib
Package zlib (1.2.8-1) installed in root is up to date.

But we can compile it manually, but in OpenWRT is already compiled. and it is also in TurrisOS. :slight_smile:

It’s running!

1 Like

Thank you so much for sharing, took 5 mins to spin this up! I tried this and it looks nice, from your list apt-get install git is missing when I followed steps.

For my setup so far I see there is very little info about discs /proc/vmstats, the rest seems to be there.

Hello Pepe, where could it be find in TO? I tried to find it using LuCI -> Software -> Filter: netdata, but nothing was found :frowning: opkg didn’t help as well - unknown package [nN]et[dD]ata :frowning:

Hello,
Use:

opkg update
opkg install netdata
netdata // with this you will start it

Then you should see it on http://192.168.1.1:19999

9 Likes

Nice! Only I had to start it, of course :wink: Thanks a lot!

Oh I forgot to mention that:-)
Added to my previous post.

Installed and running! :slight_smile:
Really nice.

Then you should see it on http://192.168.1.1:19999

not https://

Awesome…up and running with ease.
Thx for the hints.

hm… the version you have installed is pretty old. Are you sure you have the latest?

Hello,
It’s the latest available on OpenWRT. I saw that there is already pull request for 1.5.0 on OpenWRT
Hopefully soon it will be merged and then I ask someone from Turris developers to merge. I hope it will be on test branch soon.

I installed it the latest version from git on Odroid U2 its really better. Nice progress!
Youre doing great job man.

Is there some way how to securely acess this via https? (after port forwarding is done)

You could try if proxy solution would work with lighttpd:

https://redmine.lighttpd.net/projects/1/wiki/Docs_ModProxy

Lighttpd with SSL in front of NetData.

I am just thinking about setting openvpn server on turris and openclient on machine I am online at right now.

And I feel it is more secure than proxy server, isn’t it?

That sounds fine and if you want even more security you can implement both.

I have got a
root@turris:~# netdata
17-02-03 11:32:36: INFO: netdata: Listening on all IPs (IPv6 and IPv4)
17-02-03 11:32:36: ERROR: netdata: IPv6 bind() failed. Disabling IPv6. (errno 22, (null))
17-02-03 11:32:36: INFO: netdata: Listening on any IPs (IPv4).
17-02-03 11:32:36: ERROR: netdata: IPv4 bind() failed. (errno 22, (null))
17-02-03 11:32:36: FATAL: netdata: Cannot listen socket. # : Invalid argument