Intermittently dead ethernet ports

My Turris Omina seems to have a problem with its ethernet ports. When I connect my MacBook via ethernet cable, OSX reports that the interface is “not connected”. The lights on the front of the router don’t indicate a connection either.

The above is true about 80% of the time. If I power-cycle the router enough times, or keep plugging the cable into different ports, sometimes one of the ports lights up and OSX reports that ethernet is plugged in and a DHCP lease has been acquired. But if I reconnect the same cable to the same port it almost always doesn’t come back - OSX and the router lights indicate that the ethernet is not connected.

Anyone else having this problem? I’ve tried “Rollback to factory reset” (3 lights), and “Re-flash router” (4 lights) with no luck.

This is with a laptop and cable that’s been 100% reliable with my other router and with this laptop for more than a year.

I have 3 of these kind of cables currently running on my desk. One connects my phone to my router and one waits for some raspberry pi. They only have 2 pairs and won’t give a connection between 2 gigabit ports on most devices. I even have one that did gigabit full duplex between my pc and my old switch (R.I.P.) but did not work with any other device. It only had 3 working pairs. VDSL with 1 of the 2 wires broken is not working? It works but will put your data rate quite a bit down without any visible cause. Nothing is 100% reliable.

Just get another cable, then report back.

I tried a few cables and you’re right - some of them work. Actually, what appears to work is keeping the laptop plugged into the same power strip than on battery power in a different room. Maybe there’s a grounding problem?

I am seeing the same issue with my macbook + thunderbolt GE, plugging and unplugging the cable from the Omnia, putting it on different ports seems to make it work but it is quite annoying.

I’m also experiencing the same issue. If connected during boot, the Ethernet ports remain “disconnected”. I need to physically disconnect and reconnect them (either to the same or to a different port).

Confirmed, but for me this issue applies only to my switch, which I have to power off/on for a while to make it be seen by TO again.

Just to add to the comments. I have had similar issues on my setup! It has driven me BatSh*t Crazy thinking it was something I had done wrong. it takes ages before I can get my Linux Server to fully register on an interface after the it has been unregistered for whatever reason. My current predicament is due to the DHCP Lease expiring. although it says the Interface is up and I can see the MAC is registered, things just are not getting through to the Server which is on a separate Subnet / VLAN2 Eth2 Interface from VLAN Eth0.

Its been driving me NUTS!! :slight_smile:

What kind of cables are we using? I was having this problem with this 15m CAT.7 cable. I don’t need CAT.7, but I bought it because I figured it was backward compatible and more or less the same price as cat5e. Maybe there’s a problem either with the cable length or the cable type, but a 1m cat5e works fine for me.

I am using Cat6 as I am for all my LAN Connections to and from the Turris Box

This is a duplicate report of the posting:

DHCP/Network up seems to be flaky

Hi All,

This is being reported by more and more people in more threads. For me router is unusable and totally unreliable in this state. I believe it is HW issue and sent my router for warranty repair. I strongly suggest to inform turris team about this on and to prove that there are more occurrences of this really annoying issue.


What makes you think its hardware and not software? Are you a hardware professional?

No I’m not HW professional but behavior is strange. Like when you disconnect router from power for 5 seconds ports are working after start, when you disconnect for more than 1 minute they are not working after start. For me it seems like when whole system is fully discharged - longer time without power supply ports are not working. But this is only my speculation will see the response from Turris team from warranty repair process.

I have the same behavior. If I restart my router the LAN ports appear to be disconnected. I have un-plug them and replug again, ALL OF THEM. This is not nice. Already do factory reset and same thing. I think is a software issue but I can’t find why this is happening.

Any of you can test if happen the same?

@miska could you please say something about this?


@enavarrocu I can say something: I have big hopes that the software i currently develop should fix this for the moment. It should be ready in a few hours. Swich ports offline if plugged during boot
You may be one of the first ones to try it.

Thanks @adminX, just let me know when is ready.

It is there:

I’m having a problem with an intermittent wired connection from my PC to the TO. When I power up the computer, it connects to the internet, but the connection keeps on dropping temporarily. I’ve tried the cable in both Gigabit sockets on my PC, and in two different ports on the TO, but the problem persists. Any ideas please? Let me know if you need any more info.