Insanely weird connection issues with LTE modems (but issue is with TO)

Ok, so issue is weird and I’m slowly losing it.

I’m using TO since February 2017. I used it with an USB LTE modem with success for a year, but wanted an upgrade, so I bought an LTE modem (Sierra Wireless EM/MC7455), pigtails and antennas. My modem is actually weird one with Dells custom firmware, but managed to get it working around February 2018. And this is when issues started to happen.
Every full hour, around 5-8 minutes past I am experiencing very weird connection issues. That is:

  • Already established TCP sessions work normally (external ones, to the internet)
  • ICMP goes through normally (to the outside and inside)
  • I am able to initiate new TCP session to the router and devices within the local network
  • I am able to talk UDP to the router and devices within the local network
  • I am unable to initiate new TCP session (to the outside world)
  • I am unable to send any UDP packets (for example DNS resolution) (to the outside world)

When I say “I am unable” I mean that roughly 90% of affempts fail. Issue is not occurring in exactly same moment. May start 4 minutes past as well as 8 minutes past. It lasts 2 to 5 minutes usually, sometimes with some “echoes” for next 10 minutes.

There’s no cron process nor anything I was able to track down easily. (unsure whether I checked everywhere thoguh, ideas?)

Issue goes away after few minutes or upon a reboot. Initially I blamed my new internal modem, however I came back to my USB one, that I used with no issues in 2017 and issue was still there. Both modems work well and without issues when connected to other device (tested on another laptop).

I tried restoring TO snapshot to earliest I have, that is
70 | pre | 2018-02-28 13:41:13 +0100 | Automatic pre-update snapshot
But no luck, in fact it feels (not sure) things got even worse.

Hardware seems to be okay, nothing is overheating, making any noises or smelling weird.

At this point I’m totally lost. Please advise what can I check or try.

Honestly I’m rather to blame software, but issue is so weird and seemingly related to hardware, I decided to use this category. Mods - feel free to move that accordingly.

Hi rhqq,

I’m also familiar with this behavior. I had also established the Internet connection via LTE - but via a USB modem.

I have noticed that in my case these connection breakdowns did not affect all devices at least. Weirdly, it mainly occurred on iOS/Mac devices. I had a guess (shot in the dark) that it was a firewall thing or related to knot-resolver. A SSH connection to the router was always possible.

Unfortunately I did not had the time to find a solution. I switched to another platform.

1 Like

I should have been more specific. I updated my initial post with more details about issue

there could be some issue as other users seems to experience such as well

@anon50890781 @Alex8781 thing is, during the “outage” I am unable to resolve any DNS (that is send successfully an UDP packet) from within TO as well. So it is definitely happening on the TO itself.

There is a guide for DNS debugging Turris Documentation

Else if there are network outages such should leave a trail of pointers in the syslog (LuCI → Status → System Log)

This is not a DNS issue of any kind, I’m certain about that. I am unable to establish any new TCP (v4, I didn’t test IPv6, I have it disabled for specific reasons) session via IP address only.

Okay. Was a direct connection to the router still possible? (SSH for example)

Does your problem occur only in Wifi or via wired Ethernet also?

Yes. All local network traffic is unaffected. I can SSH to router, I can slam it with insane amount of DNS requests for records from internal zone. I am connected via ethernet cable. Issue is independent from WAN traffic (happens with low and high uplink saturation)

You have exactly the same problems I had! But I probably can’t help you solve the problem.

WAN ran over LTE/O2 (DE) and ipv4 only.

Thing is it worked well last year…

and there is nothing in the router’s system log related to the issue?

might this help LTE Modem -- disable "Roaming" -- Select the cellular network operator manually?

My USB modem is a “router” on its own. It’s a small linux box that just identifies itself as USB network adapter, so this makes the “LTE” part of the problem independent from actual issues.

I think, my problems started with version 3.8.5 last year.

As far as I can remember, I was still able to access the Internet from my router. i.e. ICMP worked directly from the router to a domain; but not for the clients.

Perhaps the chain of events was not clear, I probably focused rather on the part of FEB’18 and the new modem.

Not sure to which extent you are willing to take this but you could evemtually flash the router with omnia.medkit and start from scratch and a clean slate, perhaps first with the previous modem and if that works then with the new modem.

There are no routing issues between these two. Please read precisely my initial description. This USB modem/router worked well last year. Issues started to occur most likely around beginning of this year. There’s absolutely nothing in the log, but if you’re insisting - for your pleasure:

Again. This is very irregular. Issue does not start at a full minute (I’m synced with ntp, and I’ve been observing that very precisely last weeks), nor at exact same time evey hour. What’s more I’ve made sure this is not some exact time from the reboot (so uptime, even in seconds does not match the pattern in any way). Issue is network traffic independent, and happens to all devices (including TO) in the network simultaniously. It happens when I’m connected via USB modem (that in fact just creates new ethernet device that I link wan FW rules to, so it is most likely not related to source of external connectivity) AND when I’m using mpciex modem that you talk via /dev/ttyUSB2 raw terminal.

edit: for anyone curious about dmesg:

Last and extreme resort might be to flush the router with the omnia.medkit and start from a clean slate, see if it works with the previous modem first.

Else contact TO support, maybe they are better suited to solve this

I thought forum is the “support” channel for this :slight_smile:

I’ve been thinking about re-flashing my device, but I’m not certain how to grab the latest image (like 3.10) to do so.

Turris Documentation - see 4 LED and the link

The forum is mostly for user to user support. Else

Before you write us, please try to find the answer in the, documentation, or on our forum.
Email addresses

for general questions
for technical support:
for security issues and incident reporting:

Oh, right, didn’t notice that medkit is actually updated frequently. I hope it’s like latest of the latest. I’ll try to upgrade it today and I’ll come back with my findings. I don’t like the idea of losing my settings, but well. Working internet is worth much more than that :stuck_out_tongue: