How to set up WAN. (help please. DHCP ERROR)

I have read the manual and all connections have failed. DHCP times out and PPPoE with connections settings for BT comes up with unexpected error has occurred. The setting used are as followed password left blank or putting in bt fails with this error… the manual configuration bt won’t help with so can’t try this out. Any advice would be greatly appreciated to just get even a Internet connection on my bt infinity home broadband. Many thanks

Please stop spawning new threads, that’s considered inpolite.

What is the setup of current router? In case you need PPPoE, you have to reflash your router using a new image, as there is a known bug.

1 Like

Very sorry I was trying to be more clear in the problem I was having. Didn’t mean to be dis-respectful.

Thank you so much. I reflashed the router with the new image and it solved my problem.

I have the same issue, I reflashed the router and still the same.
My ISP is Virgin Media

Thanks in Advance

Have you tried putting your super hub from Virgin Media into modem mode?

I did, it just does not pick up an IP.
If I connect any device to the virgin super hub2 and it is set to dhcp it picks up an IP.
If I connect any device to a hub that has dhcp routed through it, they pick up an IP address.
The Turris router does not. it reports WAN Port has no link, your internet connection probably won’t work.

I have even assigned the IP to it from a cascaded routed network and it still reports no connectivity, even though there are 6 or 7 devices happily using tat network, including te one I’m typing this on.
Ifconfig reports that has been assigned to the WAN interface.

OK from what I am read, my issue is probably that the Omnia ia set to half Duplex.
Every article I am reading say correct this with MII-Tool or Ethertool, which are not installed.
how do I get these on to a router that will not connect to the network
and does not seem to support apt-get ?

root@turris:~# apt-get update
-ash: apt-get: not found
root@turris:~# ifconfig eth1
eth1 Link encap:Ethernet HWaddr D8:58:D7:00:44:62
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@turris:~# apt-get update
-ash: apt-get: not found
root@turris:~# ./scripts/feeds update luci
-ash: ./scripts/feeds: not found
root@turris:~# ./scripts/feeds install -a -p luci
-ash: ./scripts/feeds: not found

My ISP is Virgin Media as well. The router worked briefly but now it doesn’t pick up an ip over DHCP from the VM modem reporting that the WAN port has no link and my internet connection probably won’t work (indeed…)

Got the router a few days ago. Went through config ok. Started playing with Wifi config to check speed with and download speed is very slow… I’m on Virgin Media D:200Mbps/U:12Mbps in the UK and with my Netgear R7000 with Macbook Pro and iPhone 7 on 802.11ac I can get 150+Mbps Download. With Turris max between 1 and 10Mbps. Then somehow I couldn’t connect over Wifi anymore… Then I can’t even get a WAN link now… Switched back to Netgear R7000 all works at full speed… If I use the reboot function of the Turris it doesn’t reboot… Can’t even connect to it with a CAT cable… I have to unplug the power supply and plug it again… Even without the WAN link up I can only connect to the Turris with a CAT cable… The led number 2 at the front is not flush… I had the loose antena connector problem as well… I was super excited to get this but frankly so far it’s been a bag of hurt… So what now? Factory reset? Is my Turris completely buggered?

Have you managed to get connected yet? I ave even tried a crossover cable and still can’t get the WAN to work, everything else is OK

Yes. Resetted the Turris Omnia to Factory settings. Then switched off both the VM modem and the Turris Omnia. Waited 5 mins. Then switched the VM modem back on. Waited for the syncho. Then Turris Omnia on. Connected CAT6 cable to My Macbook Pro and went through the initial setup again. It’s been mostly ok with the 5 GHz WiFi crapping out on a regular basis. I’m putting up with it because I waited for the damn thing for 10 months! But if I wanted peace of mind I’d go back to my Netgear R7000… But I want the Turris Omnia to be my router of choice so I put up with it for now :slight_smile:

Similar problem. Can’t get the router to communicate with my ISP’s network. Set up the config. then get this every time: “WAN port has no link, your internet connection probably won’t work.” even though 10 seconds before, with the cable plugged into my Apple Airport Extreme, it works just fine. What’s the problem? Emailled tech support and they say they’ll get back to me “in a few days”. Not happy.

What kind of connection do you have? Do you see the WAN port light when you connect the cable?

Thanks for the reply.

It’s a PPPoE connection with a Static IP address on a nbn FttP service.

WAN light flashes for about 15 sec after plugging in the cable, then goes steady, so it’s seeing the connection at the NTD on the other side. But Windows 10 network icon shows “no Internet access”

Here’s the config page from my ISP:

I just saw this in a post above “In case you need PPPoE, you have to reflash your router37 using a new image, as there is a known bug37”

Is this still required? The bug report isn’t dated!

If you haven’t reflashed your router since delivery then yes, you should do it. AFAIK all routers came from the factory with same image.

Thanks, but why wasn’t this bug identified and everyone notified when it was discovered? I just wasted an entire day of my life trying to get the connection to work and it turns out this might have saved that had I known. Not happy!

And the reflash instructions are not clear.

The documentation for re-flashing the firmware is extremely unclear – does “4 LEDs: Re-flash router from flash drive” refer to four LEDs including the Power LED or the Power LED plus the 4 LEDs that are marked 1,2,3,4? Not at all clear. Needs to be clarified!

If you have an old modem/router that is still working with your ISP connect Omnia’s WAN to that modem/router and then configure your Omnia without PPP. As part of the initial setup it will upgrade the firmware. After that remove the old modem/router and configure PPPoE with Foris UI.

It has been comminucated through the Indiegogo update three months ago. What else channel of notification would you propose?

Well, if you read the first three paragraphs of mentioned guide, it gets clear:

LEDs represent a counter. The number of shining LEDs (regardless of the color) indicate the current mode. The last LED transition from green to red. When it turns red, next LED lights up and the counter is incremented. When the counter reaches 12 (number of LEDs) it restarts from 1.

I agree that numbers above LEDs are quite misleading and maybe there should be some more clear explanation (and maybe also link for the video).

Have re-flashed the router and tried every possible option again.

Today, the owner and principal engineer of my ISP came to my house and also tried and was unsuccessful.

He re-flashed the router again with the downloaded firmware and tried all options.

Even though the error message from the router says that there is no connection on the WAN port, (“WAN port has no link, your internet connection probably won’t work.”) he used his remote login software to the ISP’s servers (over LTE) and confirmed that the ISP server is seeing an attempt to authenticate from the router and all authentication data (user name and password) are correct, and the ISP servers are responding correctly, however the router does not authenticate the connection and does not connect.

He advised that there is nothing further that they can do to assist and that the router is simply not sending the correct information to authenticate the connection over PPPoE. He also tried using Static IP and DHCP and neither protocol would connect, even though when we removed the WAN cable from the router and plugged it back into the previous router (Apple AirPort Extreme) it works perfectly.

ok, so why dont you plug Turris Omnia behind Apple Airport and leave it to update to latest release and try it again?