How to make DNS resolv working in Majordomo?

Hi All,
can somebody guide me how to make IP address resolving to DNS make working in majordomo?
I would like to see destination adress in readable form (e.g. =

I found Make lookup of reverse DNS records - Enabled option, but it does not work for me.
Many thanks in advance.

1 Like

This is not problem of Majordomo. It’s common problem of Omnia DNS where reverse DNS resolution doesn’t work. I have reported the problem few days ago and nobody cares see

maybe because a forum is not a bug tracker (just saying)

It seems that when I changed DNS service from kresd to unbound then reverese dns resolution is working. Anyway majordomo is still showing only IPs.

Can confirm I have this issue also on my Omnia.
I can compare it with my previous Turris, where it works like you want.
Turris team should look at it :slight_smile:
You should write them about this issue via email ->

I have reported the problem to Turris technical support so we will see next week.

My reverse DNS seems to work but my DNS resolv in Majordomo still does not work. It looks like the majordomo lua script does a (‘busybox nslookup’ … addr). Doing that gives this:

busybox nslookup
Server:    (null)
Address 1: ::1
Address 2: localhost

Address 1:

Yet my majordomo_serialized_ptr remains blank.

@Radovan_Haban did you hear anything back from tech support?

Have same issue, DNS resolv works generally, but not in majordomo statistics. I use

dnsmasq port 54
kresd port 53
odhcpd disabled
unbound disabled

In active connection statistics DNS resolv works correctly, or on clients.

same problem here, i tried to start from the scratch - with the factory reset and fresh flash image, but its seems to be broken by design… (?)

Any progress in this topic?

Well actually there is.

We just have to wait for it to hit us, or you can apply said fix manually (just know that just this one probably won’t help you, there are other dependencies). But they are working on it.

Update: actually that pretty much fixes it, statistics name resolving isn’t a whole lot fast, but it populates it in time with appropriate domain names.

Not fixed in last 3.3 update?

It seems that the 3.3 update fixed this issue (at least for IPv4, I have not tested IPv6 on on my Omnia yet). Most of the destination addresses are now resolved properly in Majordomo (I can see e.g. in the Destination address column). The addresses which are in Majordomo displayed numerically cannot be resolved using nslookup or host commands.

Well, nslookup works, but in majordomo not. I checked one sample, attached.

1 Like

It does resolve some adresses for me. Didn’t really have tie to check every address in majordomo, but seemed fine to me. Are you sure you config isn’t messed up in some way?

Config is for sure OK. I use only one special thing, I do store data to my NAS, instead of router memory.

Therefore I have mounted /mnt/majordomo_db as link to shared folder on my Synology NAS, so data are not gone after router restart.

All the rest is standard.

Damn, I do have 3.4 Turris but this is not working on my side.

1 Like

Can you tell us what exactly is doesnt work?
This is how it looks in 3.5 (nightly):

yeahh but this is not gonna happend in my case. Only IPs, not resolving.

For me also not resolving, database is on msata card.