How do I set up the router

Hi. I am trying to set up the omina router and not having much luck. Can anyone help. I am based in the UK.
Many Thanks


here you have the manual for the first setup.


or watch this first setup tutorial:

The problem us with WAN DHCP is coming as error. We don’t have the information for the static ip address and BT won’t help.

You try LuCI for first configuration.

edit: Sorry, i didn´t see this same thread and it is solved:

Is there any advance with the use of a LTE connection to do a basic set up?

I ask because I will have to make a long trip to a wired location to do this.

Or, maybe Hell will freeze over and I will get my Satellite service in Northern Australia :wink:
Thanks for massive amount of information being put up, great reading and learning!

Further to my previous, I finally recieved my router’s and another xmas surprise was installation of Australian Satellite receiving equipment so I was able to connect one Turris Omnia to the Sat. Modem for a fast cable connection and a few minutes later, two wifi connections one each on 2.4ghz and

Hi mate, I’m also in Australia (Western Australia) and trying to get my Turris Omnia connected to an nbn FttP connection. On a static IP, PPPoE connection, but the router just doesn’t want to talk to the ISP network over the nbn NTD. Curious what protocol and settings you used to get your Turris to connect?

Many thanks for any advice you’d be willing to offer.

Best wishes,


try to clone your MAC adress in omnia from your old router

Thanks @BuloZP. Worth a try but still no-go. :frowning: There must be something that’s incompatible between my ISP’s authentication method and the protocol being used by the Turris. I guess I’ll just have to wait until they recognise that there’s a bug and fix it in a future update before I can connect the router to the ISP’s network. Cheers mate and thanks again.

t try to call on tech customer support line to your ISP and tell them you have new router with new MAC adress they must register it…

I also must doing it with one omnia router for my parrents

Thanks @BuloZP. Something’s still askew with the authentication protocol. I actually had the owner of the ISP some to my place after more than an hour he couldn’t get it to work. He could remotely log into the ISP’s servers and see the attempt to authenticate; the ISP servers are recognising the PPPoE credentials being sent by the Turris correctly but the Turris is just not connecting once the servers return the authentication response. Running out of options. Not sure where to go from here. Also, have cloned the address from the working router into the Turris–didn’t make any difference…

I just got a Turris Omnia and am trying to connect to NBN too. No luck so far. Found this thread and so am very keen to heard if WayOutWest succeeded in the mean time (it’s been two months almost). I’m on the phone to ISP now as I write, listening to music on their wait loop.

For what it’s worth the WAN light flashes on intermittently when I plug the NBN cable into the WAN port. But the Omnia interface nor the Luci interface provide any meaningful feedback or diagnostics just don’t succeed in connecting.

I would love to hear from Turris if there are CLI commands on the router (OpenWRT) to attempt a connection with tracing or debugging enabled to see a trace of what is happening and failing.

Hey mate, yeah, got my Omnia working eventually. Turns out, there was a software bug in the firmware that they eventually fixed in the most recent update. You need to follow the modem reset protocol for the Four LED sequence after you have downloaded the firmware onto a USB stick and put it in the router. Takes a few minutes for the upgrade to load so be patient. My issue was inability for the router to authenticate on PPPoE/CHAP. After the upgrade it’s worked flawlessly–no issues. Let me know if you need more help.

How’d you go with your Turris? All good?

WayOutWest! Awesome. Thanks for the feedback. I got distracted. Way busy on all sorts of projects. But this is also a priority. You could help me by checking the firmware version you have, and I’ll check mine. Reason being I just got mine in the post and it may have the latest firmware and so I might save myself barking up this tree. I hope not to be honest, as if all I need is a firmware update and she rolls I’ll be over the moon, The alternative is more cryptic diagnosis ;-). Nothing like an easy solution. But as I’m away this weekend and way busy on a construction project, I thought I’d ask in case you reply before I get to look at the router again!

Hey Bernd, No matter what version is shipped on your router, you want to update the firmware as the first thing that you do. This is recommended by Turris because of some bugs in the software that was shipped on all machines.

Update the firmware, make sure you follow the update instructions exactly – the counting LED thing is not entirely clear in the written instructions. Count ALL the LEDs including Power. (watch the YouTube vid and you will see) Until you can get it to authenticate, none of the other settings are relevant.

You have to manually download the current firmware to USB stick from a working router connection and perform the re-flash to ‘4 LED mode’:

Firmware download location is here:

I spent hours and hours stuffing around with all the settings when I first got mine, got little help from the Turis folks at all–not even an acknowledgement that there was a flaw in the firmware, then when the new firmware was released, everything worked perfectly from then on. But, the key to getting mine working was re-flashing the firmware. However, this is only relevant if you are authenticating via PPPoE/CHAPS.

BTW, you can’t connect the nbn fibre directly to the fibre port on the Turris–you have to go through the nbn Network Termination Device with the fibre then connect the Turris to the NTD via ethernet cable. I didn’t have to change anything in the router settings after re-flashing in order to get it to connect. Just added the login credentials and Voila!

When you do the re-flash, make sure you give the re-flashing plenty of time before you assume that it’s finished. Took mine a few minutes. There no really simple way to tell that it’s done. Best is just wait at least 5 min before re-booting. Hope that helps.

1 Like

You can always set up the router yourself. Confidence in this added me this site 192.168.l.l login. Everything is detailed and shown in the photos. I’m sure that everything will fine. It’s very simple.

WayOutWest, thank you enormously for the update. I will schedule a reflash effort and then reconnect attempt. Been flat chat on distractions so far, but this is slowly a priority too. Need to get value out of this router!