Chromecast disappears after few hours

Hi to all,
I need help. I use two different Chromecasts (classic one 1st gen and audio) connected to 2,4 GHz wifi network. My issue is, that I can’t see both of them after few hours (tested from different devices). They are still in network connection list, so they are not disconnected.

I already tried to change settings of the network - switch off wmm mode, change channel, etc. Nothing helped.
Before Turris I used Apple Airport Extreme without problems.

Any idea?

Thank you

Just a random guess, try to turn off IGMP snooping in the LAN. In the file /etc/config/network:

config interface 'lan'
    option igmp_snooping '0'

Thank you. I did it and rebooted the device. Now I have to wait few hours… :slight_smile:

Unfortunately that did not help. Do you have any other idea? Chromecasts (both of them) disappeared again after few hours. They were still listed in DHCP but I can’t find them in the network.

Fact, that device is listed in DHCP doesn’t mean that it is connected. Check LuCi Network -> Wireless -> Associated Stations menu, or try Spectator. DHCP show only leases.

Sorry, I ment this list, not DHCP. Chromecasts are still listed in Asociated stations but there are invisible to the network. It happens only with touris. So I’m trying to find a solution.

ok, I have similar problem with Samsung printer. Did you try ping chromecast device from router (ssh)? My printer was not accesible from my computer, but from router it worked. I am trying to figure out if we have same problem.

I’m not sure if this is the same case. Chromecast works for few hours as normal but than hides and stays only in the Asociated stations (so I expect, it’s still connected).


Have you already solved your issue with chromecast? I have the similar one. It seems, that my Chromecast audio also disappears from time to time when streaming audio.

Also, my Macbook Air wifi connection is dropped when I download something large from NAS. According omnia syslog, it seems that router drops the connection because of missing ACKs. I will post logs here once I got it again.

unfortunately the problem is still not solved. Nothing helped. I’m also experiencing another problem last days with crashing miniDLNA service. I’m waiting for reply from Turris support and I’m disappointed with this device…

These things happen, you cannot expect everything to work flawless. All these applications are mostly made/supported outside NIZ.CZ.

Give the Omnia-team also a brake. I mean those guys are still busy with whole shippment stuff. I received my Omnia (black 2GB version) just today, so give another week or 2, then we can expect almost everybody have received their Omnia. So the Omnia-team will focus their attention on bugs and other software-problems.

Have some patience :).

1 Like

I would advice you to also create a account on openwrt forum if you haven’t done that yet. There you can also receive a lot of help. Those guys will help you maybe even better then other backers or the Omnia-team it self.

Ok, I’ll try. Thank you

anyway, I have similar problem with KDE Connect. Device is disconnected after some time.

I tried to ask on but I did not find solution. I turned off wifi module and switched on my old router. Technical support still without answer.

I am still setting up my Turris Omnia (several problems to be solved till I will be able to use it in ‘production’) but I am afraid I am affected with the very same Chromecast behaviour… :frowning:

I’m using chromecast for a week now and no problem. Perhaps check the router logs and see if something (like radio interference) is interfering and kicking it off?


I had an iPhone that kept on reconnecting even after a complete wipe of network settings. The other iPhone had no issues whatsoever. I changed the channel for the 5ghz network and now it looks ok. I don’t have an explanation. Perhaps try to do the same. As an added benefit the new channel permits much higher output power for me so I’m hoping that it will help with the signal level too. I don’t know if this list is accurate but it might give you some hints.


Same here, chromecast audio works reliably without issues.

Chromecast 1st generation is not able to see 5GHz network