Can't get 1Gbit on Mox Classic

Hello,
I can’t get even close to my internet connection 1 Gbit/s download speed with my Mox Classic.
My setup is as follows:
Cablerouter in bridge mode over Cat5e to Turris Classic with two WIFI Cards one 2.4 one 5Ghz.
With both Wifi cards disabled and just one device connected over ethernet I just get between 150 and 300 Mbit/s. In the months since I have my mox I couldn’t get more than 1/3 of my theoretical max bandwidth.I checked today again that I can get the full bandwidth from trough my cable router if I disable bridge mode.
The Mox is running Turris OS 4.0 and just the standard configuration it came up in the Install wizard.
First I thought the device is thermal throttling (it got really hot this summer) so I cooled with an USB Fan but the problem is still existing.
I’m new to the Turris ecosystem and the whole custom router/home network game,
so if you have any ideas/help how to fix the bottleneck I would really appreciate it.

Ben

I haven’t tested throughput with my MOX yet, but i like the netdata package, have a look at CPU and the network interfaces while doing a spead/load test.

Thanks for the tip Netdata looks awesome but a bit overwhelming.
While I tested again the cpu load seemed normal with loadpeaks of max 50% but still just around 200mbit/s. Would be helpful to know what kind of throughput other Mox users achieve.

I did a quick test with iperf3 over Ethernet: [Turris Omnia] <-> [Switch]<-> [MOX] <-> [Laptop]

  • down from TO to Laptop ~880 Mbit/s
  • up from Laptop to TO ~670 Mbit/s
  • down from TO to MOX ~920Mbit/s
  • up from MOX to TO ~910Mbit/s

Edit: MOX is configured in Router Mode so TO is WAN and Laptop is in LAN.

I can get 980 MBit/s with a MOX with PC connected to MOX WAN (MOX in access point mode) with iperf2.

Because of your replies I first tested the LAN bandwidth over Ethernet between 2 devices with ipfer3
~950 Mbit/s
The LAN/Ethernet module C seams to be fine.
Then I installed iperf3 on the MOX trough LuCi and ran the test again. (PC over lan to Mox)
~800Mbit/s
I don’t know how to configure the MOX as an Access Point to test WAN bandwidth. @ssdnvv if you could share your setup in more detail I would really appreciate that.

edit: my first iperf3 test between PC and Mox was to low because I accidentally used WLAN…

I’d suggest a quick look at output of top or htop during the test.

While testing the cpu 1 min load peaks to 1.4 if I have the the LuCI realtime charts open.
If I just use Netdata to monitor the 1 min load peaks are only 0.5
Or I don’t understand for what i should look out in htop?

I’d look mainly at CPU utilization. 50% will typically mean one fully busy “process”. If that happens, I’d look at which process causes that.

Over 50% i get only with internal LAN tests running who come close to the theoretical 1Gbit. While i do external tests like fast.com, Netmetr, speedtest.net the CPU utilization is below 20% and the speed max 300Mbit/s

1 Like

I got local WAN testing with iperf3 done and only got ~400 Mbits/s. Thanks again for the help so that i could narrow down the problem to the WAN connection. But there is nothing more I could do to fix it. Maybe a reset but that didn’t worked the last few times i tried…