Adblock package release for turris omnia


#131

@paja: any chance of getting upstream adblock package into repository?


#132

Hi, right now there is version 3.5.1 in our repo (this should be latest upstream version) https://repo.turris.cz/archive/omnia/3.10/packages/packages/adblock_3.5.1-1_all.ipk


#133

Just add the following domains to your local blacklist and you’re done:

facebook.com
facebook.net
fbcdn.com
fbcdn.net
fbsbx.com
fb.me
fb.com


#134

So we add

facebook.com
*.facebook.com
facebook.net
*.facebook.net
fbcdn.com
*.fbcdn.com
fbcdn.net
*.fbcdn.net
fbsbx.com
*.fbsbx.com
fb.me
*.fb.me
fb.com
*.fb.com

#135

No, please only add the domains that I’ve already mentioned above to your local blacklist, the wildcard char “*” is not allowed / not needed. These wildcards will be automatically added to the resulting rpz-list for kresd.


#136

Thank you, works great!


#137

Have just installed the new update:

Everything works. However, I have a question regarding:

luci:

  • archive sub-categories (shalla & ut_capitole) are now configurable
    via LuCI CBI template

Based on your address (http://www.shallalist.de/categories.html) I’ve got me an overview. Great feature! However, I miss “ut_capitole” and “urlhaus” in the CBI template list.
Did I miss something?

Edit:
I found the mistake. The other two were included in the new configuration file, but it was saved as -opkg when it was installed. Have merged the differences.
Edit 2:
One of the new blocklists seems to be blocking Github. After I enabled the new lists with default values, it does not work anymore. Countercheck with smartphone has worked, page is immediately available. Can I somehow see if a domain is on the list?

Otherwise, usual great work! Stay tuned and keep up the good work!

Best regards


#138

Yes, that’s right - it’s (currently) the new urlhaus source … it tends by design to false positives (see details in the screenshot):

I’ve added the following two domains to my whitelist:

github.com
githubusercontent.com

Unfortunately you can’t directly detect the source of a blocked domain, cause all domains get merged in one big blocklist file without back reference. Of course with the domain query you can simply check, if a false positive is in your blocklist to whitelist them afterwards …


#139

Many Thanks! That explains a lot. I added your two exceptions. Or is this list generally still a bit unsure about that?

When I went to Query for testing I got this:

Best regards


#141

@freshdax There is no fix for Turris atm.

In LuCI a new function luci.util.shellquote() was recently introduced which encloses the given string argument in single quotes and escapes any embedded single quote
characters. This function is used by adblock 3.5.2 when interpolating untrusted input into shell commands.

Turris Omnia is still on Chaos Calmer release level and doesn’t include this new function.

Options for you:

  • Stay with adblock 3.5.1 (officially supported)

  • Use adblock 3.5.2, but only use the domain query via command line interface … the query function will probably be supported with turris 4.0, when turris goes upstream … :wink:


#142

Thank you Dirk!

Will be option 2 and will switch to the command line. Now everything has been set up ready and it would be nonsense just because of this lack of functionality to dispense with the improvements.

Everything works except for this function, which is also fulfilled by command line. And that is rarely the case.
Keep up the good work, I like it!

Best regards


#143

Hey @dibdot!

I have just done a vanilla install of Foris v3.10 on my TO. I have switched from kresd to dnsmasq (just by changing port #s, really).

I installed v3.5.2 of adblock (before I realised v3.5.1 is part of the TO’s own packages).

Anyway, I noticed when adb_dns='dnsmasq' that:

2018-05-24 18:31:24 err adblock.sh[15811]: Usage: killall [OPTION]... [--] NAME...
2018-05-24 18:31:24 err adblock.sh[15811]:        killall -l, --list
2018-05-24 18:31:24 err adblock.sh[15811]:        killall -V, --version
...

Further troubleshooting indicated that:

  • killall -HUP dnsmasq didn’t work (it threw the error message, above), but
  • killall -s HUP dnsmasq was the right syntax

I wonder if the TO is using a different busybox? [EDIT: I see it’s part of psmisc package, v22.16-1]

In any case, even the right syntax didn’t kill dnsmasq! [EDIT: I misunderstood HUP]

I’m curious, what was wrong with: /etc/init.d/dnsmasq stop and /etc/init.d/dnsmasq start?

[EDIT:

root@sr-router:~# opkg files busybox | grep killall
root@sr-router:~# opkg files psmisc | grep killall
/usr/bin/killall

#144

Well, OpenWrt upstream uses the current ‘killall’ busybox applet, a dedicated psmisc package is no longer available. Current psmisc tools (v23.1) uses the same syntax like busybox. Hopefully TO will some day also switch to the busybox default applets and drop this quite old psmisc package …

A kill -HUP will reload the dnsmasq configuration/adblock files just fine - this will also preserve long term history about dnsmasq caching and DNS failures.

As long as this does not work properly with TO you can set/enable the old restart behaviour with the ‘adb_dnsflush’ option.

Hope this helps!
Dirk


#145

Yet another example of cz.nic doing something a little odd with the Turris port of OpenWrt. (I have a 2nd TO on the way, so I plan to trial the ‘pure’ OpenWrt on a TO.

Oh, I get it - I mistakingly thought you were stopping dnsmasq, then restarting it later, after updating the hosts file. I will make a little hotfix until Turris v4…
sed -i '/killall/ s/killall -q -HUP/killall -q -s HUP/' /usr/bin/adblock.sh

Thanks!


#146

Just installed the adblock package and works like a charm, thanx!
I went through “all” of lucis menus and don’t seem to find adblock any of the menus.
Where should the pretty admin ui show up or is it all cli config now?


#147

Did.you install luci-app-adblock?
Then under Services there should be Adblock.


#148

If you’ve installed luci-app-adblock then try to reset the LuCI caches (rm -rf /tmp/luci-*)


#149

i had only searched and installed adblock.
Tried again with luci-app-adblock now it works :wink:


#150

Hello,

have the latest version of adblock installed, which is 3.5.3:
https://downloads.lede-project.org/snapshots/packages/x86_64/packages/adblock_3.5.3-1_all.ipk,
also the Luci extension
https://downloads.lede-project.org/snapshots/packages/x86_64/luci/luci-app-adblock_git-18.176.34901-0d9a64b-1_all.ipk.

Everything works great, but the Luci extension causes errors in rendering

Would have to make the configuration in the config file, but since I left everything so there is no need for action. Is the Turris extension sufficient in the repository?

Edit: The view is with the Luci bootstrap design

Best regards


#151

@freshdax

That’s expected … you can’t use frontend > 3.5.2 on turris devices. Few weeks ago, there was a treewide LuCI change to convert HTML tables to div based markups (together with additional styling changes). These changes are not in openwrt 18.06 tree and of course not in turris tree.

Solution:
Stay with the 3.5.2 frontend. You can use this together with 3.5.3 backend without any problems. For a download look here: https://downloads.openwrt.org/releases/packages-18.06/x86_64/luci/