[Workaround] Nextcloud (v. 28.0.2) suddenly wants 64 bit: "Your Composer dependencies require a 64-bit build of PHP"

Hi there,

this weekend I encountered an issue with my good old Turris Omnia:
Out of sudden I got notifications from my mobile it was unable to sync contacts and calendars with my Nextcloud.
Everytime something like that happens I try to call the Nextcloud page directly in the webbrowser to get further information. I just outputs this message:
Composer detected issues in your platform: Your Composer dependencies require a 64-bit build of PHP. Internal Server Error The server encountered an internal error and was unable to complete your request. Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report. More details can be found in the server log.

Since I use the “Update approval needed” setting of the updater I can say there were no updates done between the point where everything worked fine and the Nextcloud was broken.

I don’t know how I could fix it… What I tried so far was copying the content of the nextcloud installation zip file from Index of /server/releases (versions: 28.0.2, 27.1.6, 26.0.11 and 24.0.9) into my www directory to overwrite the installed files. The error still remains whatever I do.
I also removed all folders under “apps” folder that are not present in the installation zip file with no success.
I even uninstalled (Uninstalling Nextcloud - #3 by Michal_Smolak) Nextcloud and reinstalled (Nextcloud - Turris Documentation) again… Note: I did a “dirty” reinstall without erasing the complete nextcloud folder beforehand because the data folders size is about 60 GB.

Here is some information about my TO:

Device Turris Omnia
Serial number xxxxxxxxxxxx
reForis version 1.4.1
Turris OS version 6.5.0
Turris OS branch HBS
Kernel version 5.15.146

I need any idea of what happened and what could I try to fix the issue.
Every idea/hint/advice appreciated.

Kind regards
Chris

Have a look at the other recent discussion: Nextcloud outdated? - #4 by peci1 .

1 Like

This was my guess too: Nextcloud updates itself via cron job.
But in this case shouldn’t I’ve done a successfu repair by installing the old 24.x.y version over the existing one?
If I understand correct the issue is the use of an updated Nextcloud version while running on a 32 bit OS? Is the “1.6 GHz dual core ARMv7” CPU 64 bit architecture?

Any ideas how to address the issue? If your linked topic is about the issue I encounter (which sounds plausible to me) this thread should go kind of viral in the Turris Omnia community, right?

Turris Omnia certainly does not have a 64-bit CPU (in this sense).

2 Likes

Btw when will new Omnia be launched? Haven’t heard for a long time, once named as Omnia 2022.

So one can tell the latest Nextcloud version running on Turris Omnia will be 25.0.13? (Update on 32-bit support: decision to block the update on Nextcloud 26 reverted - 🎁 Releases - Nextcloud community)

Am I right assuming this is the current version I should use to restore my Nextcloud instance?

Do you have any advice how to bring things back to life…?

Thanks in advance!

Kind regards
Chris

One more time I found a workaround myself. :sunglasses:

As mentioned above Nextcloud has its own updater and I thinnk it updated itself from v. 28.0.1 to v. 28.0.2.
Now how can we downgrade the Nextcloud instance inspite this is not supported at all?

  • SSH to your Turris Omnia
    Now execute the following commands:
    cd /srv/www/
    wget https://download.nextcloud.com/server/releases/nextcloud-28.0.1.zip
    opkg update
    opkg install unzip
    unzip nextcloud-28.0.1.zip
    cd /srv/www/nextcloud
    find . -type d -exec chmod 0755 {} \;
    find . -type f -exec chmod 0644 {} \;
    chown -R nobody *

  • After that this should disable the updater:
    sudo -u nobody php8-cli ./occ config:system:set updater.release.channel --value=disabled

  • Edit your config file’s (/srv/www/nextcloud/config/config.php) version line to something like this:
    'version' => '28.0.1.1',

  • Done :slight_smile:

Hope that helps other people, too.

Kind regards
Chris

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.