WLAN Fast Roaming between Turris Omnia and Mox

I am trying to get Fast Roaming (ieee80211r) between my Turris Omnia and my Mox working since days without luck.

Is there someone using this successfully?
Some infos and logs:

Omnia: Turris OS 3.11.16
Mox: Turris OS 4.0.5

Both systems are connected to 3 VLAN (Management, Trusted, Untrusted) and serve two SSID’s (Trusted and Untrusted).
The Omnia serves two 2,4Ghz SSID’s additionally.

The interfaces all look fine, I can see traffic (out of the correct VLAN using tcpdump).

The wireless configuration looks like this (only one SSID for briefness):

Omnia:

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2+tkip+ccmp'
	option key 'VerySecretPassword'
	option network 'TRUSTED'
	option ssid 'BlackPenguin-5G'
	option ieee80211r '1'
	option mobility_domain '1337'
	option ft_psk_generate_local '1'
	option pmk_r1_push '1'

Mox:

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'BlackPenguin-5G'
	option network 'TRUSTED'
	option encryption 'psk2+tkip+ccmp'
	option key 'VerySecretPassword'
        option ieee80211r '1'
        option mobility_domain '1337'
        option ft_psk_generate_local '1'
        option pmk_r1_push '1'

When I now connect a Client to the 5GHz i get tons of logs on both systems…and a network connection for only some seconds.

Logs on the Omnia (repeating all the time):

2020-04-09 18:01:12 info hostapd[]: wlan0: STA a8:34:6a:1f:24:50 WPA: pairwise key handshake completed (RSN)
2020-04-09 18:01:13 info hostapd[]: wlan0: STA a8:34:6a:1f:24:50 IEEE 802.11: authenticated
2020-04-09 18:01:13 info hostapd[]: wlan0: STA a8:34:6a:1f:24:50 IEEE 802.11: associated (aid 2)
2020-04-09 18:01:13 info hostapd[]: wlan0: STA a8:34:6a:1f:24:50 RADIUS: starting accounting session 0020EB2F56C448DB

Logs on the Mox (also repeating all the time):

Apr  9 16:08:22 turris hostapd: wlan0: STA a8:34:6a:1f:24:50 IEEE 802.11: disassociated
Apr  9 16:08:23 turris hostapd: wlan0: STA a8:34:6a:1f:24:50 IEEE 802.11: disassociated

What could I have missed in my configuration?
Someone got Fast Roamint to work using Turris OS?

Thanks for the help.
best,
Stefan

1 Like

I have never done the kind of setup but with little of research I found 2 posts that might be helpful and useful to dig into.


1 Like

I already read the reddit link several times. Also tried using the mentioned NASID parameter without change of the outcome.

During my research I think I’ve also stubled over the second link and some others mentioning installing wpad is necessary to get it to work.

It seems the Omnia has a very old wpad installed (wpad - 2016-12-19-8), the Mox uses wpad - 2018-05-21-62566bc2-8.0.
Could the version difference be a problem here? Should I upgrade my Omnia to TurrisOS 4?

Well it was the first thing I thought of. I believe having both of the devices on the same Turris OS including packages version would be a great start imho.

You need at least TOS v4.x on all machines to get this easily working.
As there is an unsolved vulnerability in this protocol when used in combination with WPA2 encryption (search this forum for 802.11r), you should also use really strong passwords (63 characters alphanumeric case sensitive).

Omnia (HBL) and Mox (HBK) on TOS 5.x, same wpad version below and cofiguration above (no VLANs, WAN Mox port wired connedted to LAN port on Omnia) not working.

root@omnia:~# opkg install wpad
Installing wpad (2019-08-08-ca8c2bd2-2.0) to root...
Downloading https://repo.turris.cz/hbl/omnia/packages/base/wpad_2019-08-08-ca8c2bd2-2_arm_cortex-a9_vfpv3.ipk

root@mox:~# opkg install wpad
Installing wpad (2019-08-08-ca8c2bd2-2.0) to root...
Downloading https://repo.turris.cz/hbk/mox/packages/base/wpad_2019-08-08-ca8c2bd2-2_aarch64_cortex-a53.ipk

If I were you guys I would start with stable branch (HBS). Once it works switch to something newer.

Two days of fast roaming testing with MOX

1 GB MOX with default configuration

  • MOX A with SDIO (original supplied)
  • TOS 4 (HBT), wpad (2018-05-21-62566bc2-8.0), kernel 4.14.167
  • MOX A+C+G with SDIO and mPCI card (original supplied with G addition)
  • TOS 5 (HBK), wpad (2019-08-08-ca8c2bd2-2.0), kernel 4.14.172

Experiences

  • Roaming between SDIO and mPCI card is not working
  • Roaming between two SDIO on 5 GHz are very unstable
  • Roaming between two SDIO on 2,4 GHz is possible
  • SDIO often lost contact with board (no concussion)

Wireless settings

  • Second card (if avaliable) and guest mode (or other SSID) is off

/etc/config/wireless

config wifi-device 'radio1'
        option type 'mac80211'
        option macaddr 'my_mac'
        option country 'CZ'
        option channel 'auto'
        option hwmode '11g'
        option htmode 'HT40'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option wpa_group_rekey '86400'
        option key 'ssid_pass'
        option ssid 'ssid_name'
        option ft_over_ds '1'
        option pmk_r1_push '1'
        option mobility_domain '1234'
        option ft_psk_generate_local '1'
        option ieee80211r '1'

Also works well with TOS 5 (HBT). Both MOX have wpad (2019-08-08-ca8c2bd2-2.0) now.

Also works between:

  • MOX A with SDIO (TOS 5, HBK) and Omnia (TOS 5, HBL) at 2,4 GHz
  • MOX A+G+mPCI (TOS 5, HBK) and Omnia (TOS 5, HBL) at 5 GHz

Compatible cards:

  • MOX SDIO (AzureWave AW-CM276NF/Marvell 88W8997) and Omnia mPCI (Compex WLE200N2)
  • MOX mPCI (Compex WLE900VX) and Omnia mPCI (Compex WLE900VX)

Good idea for next releases:

In the end Ive MOX Power WiFi with Omnia connected through cable. But unfortunately connectivity isnt better at all. Any idea what might be issue from configuration perspective? Is the port on Omnia important for connectivity between MOX and Omnia for this setup? No VLAN, guest in place. Only additional SSID on Omnia for 5GHz network

Omnia
config wifi-device ‘radio1’
option type ‘mac80211’
option hwmode ‘11g’
option macaddr ‘04:f0:21:31:82:c5’
option country ‘CZ’
option disabled ‘0’
option htmode ‘HT40’
option channel ‘auto’

config wifi-iface ‘default_radio1’
option device ‘radio1’
option network ‘lan’
option mode ‘ap’
option disabled ‘0’
option encryption ‘psk2+ccmp’
option wpa_group_rekey ‘86400’
option key ‘STRONG_PASSWORD’
option ssid ‘Turris’
option ft_over_ds ‘1’
option mobility_domain ‘1234’
option ft_psk_generate_local ‘1’
option ieee80211r ‘1’

MOX Power WIFI
config wifi-device ‘radio1’
option type ‘mac80211’
option macaddr ‘d0:c5:d3:33:ea:df’
option country ‘CZ’
option hwmode ‘11g’
option htmode ‘HT40’
option channel ‘auto’

config wifi-iface ‘default_radio1’
option device ‘radio1’
option network ‘lan’
option mode ‘ap’
option ssid ‘Turris’
option encryption ‘psk2+ccmp’
option wpa_group_rekey ‘86400’
option key ‘STRONG_PASSWORD’
option ft_over_ds ‘1’
option mobility_domain ‘1234’
option ft_psk_generate_local ‘1’
option ieee80211r ‘1’

wpad 2019-08-08-ca8c2bd2-5.0