WLAN-channels 149 - 169 not supported by clients in auto channel mode

@turris-admin
The Qualcomm Atheros QCA9880 WLAN-module offers channels 149 - 169 and uses mostly channel 149 in AUTO-channel mode with “de” country-profile.

These channels are only allowed for registered network providers in Germany !!!

WLAN-connections are not possible with channels 149-169 as WLAN clients ignore it.

1 Like

I definitely won’t argue (I am not familiar with GE regulations) but… what exactly is this?

Didn’t know that document, yet.

Basically it says commercial internet services can use 5755 MHz – 5875 MHz without special registration. They just need to be registered as network providers with the Bundesnetzagentur. Running private APs in this frequency-range is illegal. I assume this was made for cellular providers to offload cellular traffic to WLAN.

As most WLAN-clients do not support this frequency-range I suggest to make it optional - especially in auto-channel mode.

Just what I see, it’s perfectly legal to have device capable of these frequencies, but it is illegal to you to use them if you don’t use it as described.
Still, maybe I am wrong.

P.S.: I’d never use AP in “auto-channel” mode.

Yes, if you’re a registered network provider you can use it with your devices and probably customers of registered network providers can use that network on channels 149-169, too. So I assume having the device is not illegal but running a private network probably is.

There are good reasons for automatic sidestep to another channel

  1. if a channel becomes overcrowded by other WLAN domains (e.g. housing areas)
  2. if radar is activated on the current channel (802.11h DFS)

In both cases the WLAN would fail until manual re-configuration without “auto” channel-mode.

OK, no further question.

I migrated from TOS3 to TOS5 and afterwards my Google pixel android phone couldn’t connect to 5Ghz WIFI. All other devices connected, 2 dell laptops running linux, nokia android phones … The problem was that Google Pixel running android 10 ignored channel 149, replying that WIFI network is not in range. I manually changed the channel to 116 to fix it. Router is in CH country profile. The AUTO channel configuration should be fixed to prevent using channels 149 and above: https://en.wikipedia.org/wiki/List_of_WLAN_channels

You can define which channels should be used when channel is set to auto in /etc/config/wireless:


config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option macaddr 'XXX'
        option country 'DE'
        list channels '100-140' #This is the important line
        option htmode 'VHT80'
        option channel 'auto' #Must be auto
        option legacy_rates '0'
1 Like

The question is why is this not default?

Instead channel 149 is included in the auto config by default.

According to Publication in accordance with Article 1(3) of Commission Decision 2000/299/EC which is valid for Switzerland as well, frequency band 5 725 - 5 875 MHz is reserved for Non-Specific Short Range Devices and not Wireless Access Systems including Radio Local Area Networks (WAS/RLANs). Good example of setup is included in the linux drivers: https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt?id=HEAD

Transmission power is lowered to 25mW on channels 149+, so I think regulations are met.

See this link:

„Local Area Networks“ is mentioned as an example use case for a short range device.

Btw did you configure the correct country code for your wifi device? If set correctly local wifi regulations should be met (based on the database you mentioned I believe)…

I changed it back to auto.

cat /etc/config/wireless

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ‘11a’
option distance ‘8’
option htmode ‘VHT80’
option country ‘CH’
option macaddr ‘04:f0:21:23:fa:9b’
option disabled ‘0’
option channel ‘auto’

so the wireless config shows CH. It also shows CH in Luci., but when I run this command:

iw reg get

global
country CH: DFS-ETSI
(2400 - 2483 @ 40), (N/A, 20), (N/A)
(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
(5725 - 5875 @ 80), (N/A, 13), (N/A)
(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#1
country US: DFS-FCC
(2400 - 2472 @ 40), (N/A, 30), (N/A)
(5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5730 - 5850 @ 80), (N/A, 30), (N/A)
(57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
(2400 - 2472 @ 40), (N/A, 30), (N/A)
(5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5730 - 5850 @ 80), (N/A, 30), (N/A)
(57240 - 71000 @ 2160), (N/A, 40), (N/A)

If phy0 and phy1 are radio0 and radio1 then it should show CH, shouldn’t it?

RLAN transmit power at 25mW is definitely not great for home 5GHz wifi.

wifi status

Shows correct country code for me and I checked my wifi some time ago with a wifi scanner on a windows client which showed correct country code, too. I‘m not sure how to interpret iw reg get but my output is similar to yours…

You‘re right, that‘s why I don‘t use these channels, too, but as long as it is legal to use them I think they should be used for automatic channel configuration by default…

There is actually shown configuration for DE :slight_smile: , there are some external sources as well.