Wireguard broken in latest 5.1.4?

configured wireguard as https://doc.turris.cz/doc/en/public/wireguard
Omnia rebooted - still…

root@turris:~# ifconfig wg0
ifconfig: wg0: error fetching interface information: Device not found

some debug:

root@turris:~# lsmod | grep wireg
ip6_udp_tunnel         16384  1 wireguard
udp_tunnel             16384  1 wireguard
wireguard             126976  0

root@turris:~# cat /etc/config/network
...
config interface 'wg0'
        option proto 'wireguard'
        option private_key '###--priv.key.here---###'
        option listen_port '1234'
        list addresses '10.0.10.1/24'
        option ifname 'wg0'

config wireguard_wg0
        option public_key '###--pub.key.here---###'
        option preshared_key '###--pshrd.key.here---###'
        option route_allowed_ips '1'
        list allowed_ips '0.0.0.0/0'
        option persistent_keepalive '25'
        option description 'client1'
....
root@turris:~# cat /etc/config/firewall
...
config rule
        option target 'ACCEPT'
        option proto 'udp'
        option dest_port '1234'
        option name 'Allow-Wireguard-Inbound'
        option src 'wan'
config zone
        option name 'wg'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option masq '1'
        option network 'wg0'

config forwarding
        option src 'wg'
        option dest 'wan'

config forwarding
        option src 'wg'
        option dest 'lan'

config forwarding
        option src 'lan'
        option dest 'wg'

config forwarding
        option src 'wan'
        option dest 'wg'
...
root@turris:~# cat /etc/turris-version
5.1.4

some more info
after issuing

root@turris:~# ip link add dev wg0 type wireguard

logread outputs

Dec  8 13:39:52 turris netifd: Interface 'wg0' is enabled
Dec  8 13:39:52 turris netifd: Network device 'wg0' link is up
Dec  8 13:39:52 turris netifd: Interface 'wg0' has link connectivity
Dec  8 13:39:52 turris netifd: Interface 'wg0' is setting up now
Dec  8 13:39:52 turris netifd: Network device 'wg0' link is down
Dec  8 13:39:52 turris netifd: Interface 'wg0' has link connectivity loss
Dec  8 13:39:52 turris netifd: Interface 'wg0' is now down
Dec  8 13:39:52 turris netifd: Interface 'wg0' is disabled

what else is missing ?

The interface address does not seem good to me. Drop the /24 part and test.
Remember that the interface address/subnet needs to be different to your lan address/subnet

        list addresses '10.0.10.1/24'

Here is a working setup but for site to site vpn:

config interface 'wg0'
option proto 'wireguard'
option private_key '###--priv.key.here---###'
option listen_port '4321'
list addresses '10.200.200.4'
option delegate '0'

config wireguard_wg0
option public_key '###--pub.key.here---###'
list allowed_ips '10.200.200.0/24'
list allowed_ips '192.168.1.0/24'
option route_allowed_ips '1'
option endpoint_port '9876'
option persistent_keepalive '24'
option endpoint_host '###---host.here---###'

thanks for the reply - still no go after fixing `list addresses ‘10.0.10.1’ and network restart

root@turris:~# ifconfig wg0
ifconfig: wg0: error fetching interface information: Device not found

you need to bring up the interface first

ifup wg0
ifconfig wg0

One more thing, do you have haveged installed? If not, do so as the interface might not come up if there is not enough “randomness”. Maybe you will even need to have your wifi up also.

solved here https://forum.openwrt.org/t/wireguard-setup-broken/81621/2