Wifi Ping times high, jitter


#1

Hello!

My Turris Omni has been performing admirably for quite some time until just recently when the ping times from wifi clients to the router have gotten very jittery.

64 bytes from 172.16.6.1: icmp_seq=240 ttl=64 time=1.746 ms
64 bytes from 172.16.6.1: icmp_seq=241 ttl=64 time=0.797 ms
64 bytes from 172.16.6.1: icmp_seq=242 ttl=64 time=1.957 ms
64 bytes from 172.16.6.1: icmp_seq=243 ttl=64 time=232.944 ms
64 bytes from 172.16.6.1: icmp_seq=244 ttl=64 time=427.375 ms
64 bytes from 172.16.6.1: icmp_seq=245 ttl=64 time=158.704 ms
64 bytes from 172.16.6.1: icmp_seq=246 ttl=64 time=151.413 ms
64 bytes from 172.16.6.1: icmp_seq=247 ttl=64 time=0.915 ms
64 bytes from 172.16.6.1: icmp_seq=248 ttl=64 time=1.030 ms
64 bytes from 172.16.6.1: icmp_seq=249 ttl=64 time=0.832 ms
64 bytes from 172.16.6.1: icmp_seq=250 ttl=64 time=244.646 ms
64 bytes from 172.16.6.1: icmp_seq=251 ttl=64 time=439.423 ms
64 bytes from 172.16.6.1: icmp_seq=252 ttl=64 time=170.951 ms
^C
--- 172.16.6.1 ping statistics ---
253 packets transmitted, 238 packets received, 5.9% packet loss
round-trip min/avg/max/stddev = 0.695/225.850/2352.015/318.992 ms

This occurs on both the 5ghz and 2.4ghz networks. The 5ghz environment is pretty free, only three other networks in view. 2.4ghz is rather crowded though.

Any ideas? Config below:

root@turris:~# iw reg get
country US: DFS-FCC
(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A)
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS
(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 63720 @ 2160), (N/A, 40), (N/A)

root@turris:~# ethtool -i wlan0
driver: ath10k_pci
version: 4.4.51-627f0117679bc72ef5e58881
firmware-version: 10.2.4.70.54
expansion-rom-version:
bus-info: 0000:02:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no

root@turris:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
	option disabled '0'
	option country 'US'
	option distance '20'
	option channel '40'
	option txpower '23'
	option htmode 'VHT80'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'myssid'
	option encryption 'psk2+tkip+aes'
	option key 'SECRETPASSWORD'
	option disabled '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'HT20'
	option txpower '19'
	option channel 'auto'
	option country 'CZ'
	option disabled '0'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+tkip+aes'
	option key 'SECRETPASSWORD'
	option ssid 'myssid'
	option hidden '0'
	option disabled '0'

#2

I’ve isolated it to a specific laptop. It just went in to get repaired, and I think the wifi antennae were not correctly connected afterwards.

Feel free to disregard.


closed #3