Wifi Gone Bye, bye

Hi all. I’ve been using my Omnia Turris for a few months. I really like the hardware so far. But I have a persistent issue that has plagued me for quite some time, even before the Omnia…

My wi-fi will slow, lag, and drop completely at times. It has started to become more frequent; almost everyday. Sometimes I can turn off/on my mobile/PC/Mac wifi and I am good to go. At other times I must reboot or reset the router. I know there are a LOT of variables, but why? Why am I getting this? Is there anything I can do to fix it?

I am looking at adding a wifi expander but my Omnia is almost perfectly centered in the house with little effort to get full bars wherever I am.

Could I be blanketed by other wifi around the neighborhood? I see a lot of wifi networks. How can I address this?

I know, a lot of naive, noob questions. But I’ve gotten to the point of questioning everything I think I know. If you have come across a good troubleshooting guide, I’d like that.

Thanks in advance for the mentoring ones.

-T

By as is no crystal ball. 2,4 Ghz or 5Ghz …what chanel, what power, what wide of channel (80Mhz not the best choices) ?
Signal strength in the apartment is good?
Some error message in log ?

1 Like

Thanks for responding. Here is what I’ve gathered. Obviously the strength can change when in different locations. But location doesn’t seem to matter. I am also seeing 23+ more wifi networks within my range.

         channel      signal str       width       mode         max rate
2.4GHz     11          -26 dBm         20 MHz     b/g/n        450 Mbps
5 GHz      36          -40 dBm         80 MHz      ac           1300 Mbps

let the radio0/1 to decide what channel and power should be used, when you have country-code correctly set you should have values within country norm/required limits …

the metrics for signal/signal-to-noise and so on, that depends on how many devices are around, how many devices are trying to connect and if you are broadcasting around or not. use some speed testers.

sure you can be deflected by more powerfull signals around, but 5G should be fine within your flat, 2,4G one might get issues, but there should not be much users on that frequency.
Now if you can have more power you can increase dB output or short the range (so you are not broadcasting too far.) 5G is fine when you are in same room, to get max power you should be within 2m from router, in next room it might be better to switch to 2,4G one.
I would not fiddle with channels (use auto if you can), because you pick one during morning (totally free) and during night it is opposite (totally full) and if you do not have auto you always pick that one …
you can have some script to check the occupation of used channel and wifiup/wifidown the AP in that case so autochannel hit in and pick correct one.

If you have strong penetration by one ISP providing some fixed setup (like UPC …where you have guest wifi autoconfigured and WPS active and own wifi and own guest …voila you have lot of APs broadcasting around from each flat :((( )

in my case i have 1,2G speed on interlwirelesspro wifi card (that one with dual interface). even if the AP shows only like 350M …due MIMO there was lik 2-3x380-650M + 1-2x38-54M +1-2x6-12M, based on distance those changes so when far from router there was only 1-2 mimo active and then signal drops and speed get slower. FYI and my metrics in luci or statistics seems like garbage, like i have no signal or speed (max there is 200M, but i know it can do more == so more informative values are aside each client in dhcp overview for each wlan …there you will see speed per each mimo channel)
When you have another device active , it atract the signal in same way, so it can steal some of the “mimo” channels and your speed seems slow.

If you have guest wifi on one of your wlans you share the resources …, so you have to consider all aspects of your lan/wlan.

Thank @Maxmilian_Picmaus. I’ve considered your reasoning and recommendations. Here is what I found, and eventually am trying…

I have a house full of IoT devices, computers, smart TV’s, mobile phones, etc. I monitor DHCP leases regularly and have ~30 devices connected at any given time. Most are using virtually no bandwidth.

As noted, I have dozens of wifi around my dwelling. I can’t do too much about that. Their signals vary in strength and their channel use is all over. The picture I included earlier looked actually good for me on that day. Usually it is much worse.

My router is pretty centrally located. I try to use 5 GHz when I can. The 2.4 GHz seems more stable. However, I have seen both dropped before. I have no guest network set up. I have left the channels for both radios alone.

I am not familiar with changing radio cards (I’ve done it on laptops but only a couple of times) and don’t know what to look for. Is there a lot of advantage to change what I have in my Omnia?

I pulled out a WRT3200ACM out of the closet and set it to bridge mode. I placed it at the extreme edge of my house and a physical LAN line back to the Omnia. After a little fiddling (even in bridge mode, the WRT3200ACM decided to become the DNS authority for my hone LAN! I lost port forwarding from the outside world. It took a reboot of both routers for this to clear itself up). I have had this running for almost 24 hours now. No drops but it is too early to tell.

I am now experiencing extremely slow internet. On wifi .73 Mbps down, 9.88 Mbps up. On LAN 4.73 Mbps down, 10.7 Mbps up. This is on a 100 Mbps connection. I think this is unrelated but I’m looking into it…

-T

Things are getting… worse? I was getting no more than 9.8 Mbps download. When I go direct wire to my internet provider modem, i get 116 Mbps. I slowly backed out my custom OpenWRT settings and finally did a complete reset on the Turris Omnia… twice! I am now getting right about 60 Mbps download.

I have added back in Dynamic DNS and port forwarding for HTTP, HTTPS, and SSH. No bandwidth QoS, nothing! Still I can’t see above 60 Mbps.

This is all on a wired ethernet connection. No Wi-Fi. What gives?

i am not good at explaining some tech stuff in english , so maybe this article might help ?

  • what HT(VHT) modulation you have ? 20,40,80,160 ? in combination with mode (a,n, ac …)
    • country_code (defines what combination of modulation/mode you can use legally)
    • i would hide the AP , no need to broadcast its presence :slight_smile: (for iot and your stable devices)
some notes ....

I have VHT80/11ac(cz)(normal+isolated guest) and HT40/11g(cz)(single ap).
note: and not all setups needs laters wifi features, so for iot ? 2,4G should be totally fine, for some streaming and gaming devices 5G and in each room with repeater/extender …(5G from behind the wall can not be fast , simply, no need to try to get 1,3G over 1m wall to 5 devices :))) , if you will get 12M lucky guy :slight_smile: ).same for the vht/ht mode, you have to decide if you want to be wide or thin signal spread …

So how does this relate to my wired Ethernet connection tests?

i focused on wlan stuff mainly and replying to that post above that one mentioning the “wired” issues. But if you have wired one with poor performance, that is hard to guess what might be wrong and where.

Ahh, gotcha. Ok. Thank you.

I’m very upset about this throughput issue. I was on a zoom meeting this evening and the internet completely dropped 5 times in 40 minutes!!! I finally cut over to an LTE connected iPad.

some time ago i was using this https://iperf.fr/ to check/stress test my network …(samba,sftp,ssh)
edit: i like this LED color based on bandwidth usage , i found it very handy , so no need to check luci stats/graphs …just the rainbow on leds :smiley:

UPDATE

Struggling along. I thought that moving my 5g to ‘ac’ had fixed my throughput issues. That was only change. THEN my 2.4GHz wifi has disappeared. The card shows ‘off’ in Foris and LuCi shows the card but won’t start it. The LED’s on the front also show slot 1 off.

lspci output:

root@turris:~# lspci
00:01.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:02.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:03.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
01:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
02:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter
root@turris:~#

Is my hardware bad? I purchased this in January 2020.

can you post the uci config for wireless setup ? (remove the “token/passwords” from it)
what you have in syslog when wlan is going up/down?

Btw: i have very same output of lspci, so i do not think your hw is bad.

I have this in my rc.local to get boot-up dmesg buffer in extra file before syslog-ng hits in and you lose the info
## catch boot log to separate file
echo "====[dmesg]====" > /srv/logs/boot.log && dmesg >> /srv/logs/boot.log
there you find what is happening with “radio” chips …, but do not be scared with failures some are wanted and expected …there is some sequence when radio is in init phase…many failures are self-fixed later on (maybe that’s why in default setup it is not saved to messages log file, so users are not scared , there will be soo much asking why that, why this … :DDD

… also did you checked the wiring ?


(some users found the cables not fully connected or on wrong pin …) , but that was for the early batches. It does not hurt to check it :slight_smile: (notice that on the small pcbs there are indicators for 2,4 and 5 so ensure you have it right).

if you have hw issues and you suspect that you have bad piece, issue service ticket to support officially
https://wiki.turris.cz/doc/en/howto/error_reporting

btw: what is the expected behavior/health/troughtput of your wlan networks anyway?

Good luck mate :slight_smile: