Where is nmap? Seems missing form the available packages

I’d like to install nmap on my router. But opkg can’t find it (nor can LuCI of course). I think it’s available on OpenWRT:


And I could try install that, but I’m curious why Turris OS doesn’t have it in its package repo?

[code]root@oolong:~# opkg install nmap
Package nmap (7.12-2) installed in root is up to date.
root@oolong:~# nmap google.com

Starting Nmap 7.12 ( https://nmap.org ) at 2017-06-14 14:33 CEST
Nmap scan report for google.com (
Host is up (0.0081s latency).
Other addresses for google.com (not scanned): 2a00:1450:400e:800::200e
rDNS record for ams15s21-in-f14.1e100.net
Not shown: 998 filtered ports
80/tcp open http
443/tcp open https

Nmap done: 1 IP address (1 host up) scanned in 19.60 seconds


# opkg install nmap
Unknown package 'nmap'.
Collected errors:
 * opkg_install_cmd: Cannot install package nmap.


# cat /etc/opkg/distfeeds.conf /etc/opkg/customfeeds.conf 
src/gz omnia_base https://repo.turris.cz/omnia/packages//base
src/gz omnia_lucics https://repo.turris.cz/omnia/packages//lucics
src/gz omnia_management https://repo.turris.cz/omnia/packages//management
src/gz omnia_openwisp https://repo.turris.cz/omnia/packages//openwisp
src/gz omnia_packages https://repo.turris.cz/omnia/packages//packages
src/gz omnia_printing https://repo.turris.cz/omnia/packages//printing
src/gz omnia_routing https://repo.turris.cz/omnia/packages//routing
src/gz omnia_telephony https://repo.turris.cz/omnia/packages//telephony
src/gz omnia_turrispackages https://repo.turris.cz/omnia/packages//turrispackages
# add your custom package feeds here
# src/gz example_feed_name http://www.example.com/path/to/files

Can you repeat second command and report results?

Did you opkg update ?

1 Like

The NMAP package is here for Turris 1.x and here for Turris Omnia.

Try to add the “https://repo.turris.cz/omnia/packages/packages” path to the “/etc/opkg/distfeeds.conf” file as a custom package feed and then try type “opkg update” and “opkg install nmap” to the command line (via SSH)

I have turris Omnia. I did run opkg update and then installing was working.
So you do not need to add anything as custom package.

Thanks, just tried that too and it worked! Doh! I tend to associate opkg update with new things on the scene, and perceived nmap as an old friend, not a new kid on the block, hence didn’t even think to try that. It’s what I’d do if someone said “hey there’s this new tool to …” and if opkg didn’t find it; it, I’d try and update and then ask for a repo if that failed.

But thanks heaps for the pointer!

1 Like