Webgui not accessible 404 Not Found nginx/1.10.1


since some weeks I can’t access the webgui anymore. SSH is working and everything else seems to run fine.

I just see 404 Not Found

as error message. Why is the webgui not working and how can I fix it? thank you!

WebGUI normally uses lighttpd as web server, so disable nginx and try to restart lightttpd.

I tried to restart lighttpd but get an error port 80 is already in use.

**root@turris:/etc/lighttpd# lighttpd -f lighttpd.conf**

** 2017-10-16 14:34:34: (network.c.464) can’t bind to port: 80 Address in use**

I killed nginx process but it seems it gets restarted when starting lighttpd again which lead to the error message port 80 in use.
I disbaled nginx with this command:

/etc/init.d/nginx stop

Is nginx needed? If not can I remove it?

you can disable it
/etc/init.d/nginx disable
or remove it
opkg remove nginx

1 Like