WAN VLAN tagging - Swconfig list empty on turris omnia hbs

root@turris ~# swconfig list
root@turris ~#

root@turris ~# modprobe swconfig
failed to find a module named swconfig
root@turris ~ [1]# opkg files kmod-swconfig
Package kmod-swconfig (4.14.245-1-67f70e2f39f8e8859c56d42cced0b0b3) is installed on root and has the following files:
root@turris ~# cat /etc/modules.d/41-swconfig

root@turris ~# opkg files kmod-switch-mvsw61xx
Package kmod-switch-mvsw61xx (4.14.245-1-67f70e2f39f8e8859c56d42cced0b0b3) is installed on root and has the following files:
root@turris ~# cat /etc/modules.d/42-switch-mvsw61xx
root@turris ~# modprobe mvsw61xx
failed to find a module named mvsw61xx

Not surprised, tho.

HBS is the TOS 5.x and this is running the DSA, not the old swconfig.

What is your question at all?

I see… is it the same for hbl?

Hello @luginbash, yes, the same applies for all TOS 5.x releases.The swconfig has been deprecated by the upstream - OpenWrt - and all the switching related tasks are now under the DSA.

What do you want to achieve? Are you looking for info about VLAN configuration, or is there anything else?

understood, I was just trying to tag vlan on wan, my upstream is using a trunk.

the bridge vlan works, thanks for the clarification.

Can you please elaborate more about the bridge vlan?

By the way, there is a simpler way how to do the VLAN tagging on wan. Modify the WAN interface settings - Physical Settings tab - and create interface eth2.vlan_tag and that’s it.

So by example, if you select eth2.848 - the wan traffic leaving port eth2 is tagged with 848.

I have a vlan650 on an upstream firewall, the configuration looks like this:

# show interfaces ge-0/0/1
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members wallplates; # just a name for vlan650

What I’m trying to achieve here is simply tag everything with vlan650 and pass it to the upstream, so everything goes through the firewall.

Got it. So, use the dot notation. Setting the wan interface as eth2.650 is sufficient.

Yep, that works! Thank you for the guidance!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.