Wan port (Turris) does not talk to CD8000 Cable modem

I’m having a strange problem. I have a Turris Omnia OS Ver 6.3.2, it was working well connected to my internet DSL modem for many years. However the DSL modem died and the service is no longer available forcing me to switch to a cable modem. The DSL setup was a modem and router all in one and was at IP address, not sure if the cable modem has a NAT or router built in. When I connect a windows 10 machine set for DHCP directly to the cable modem I can see the following addresses from the windows 10 command window. When I attempt to connect the Turris Omnia from the WAN port to the cable modem it does not work. For some reason it does not see the cable modem even with the WAN LED flashing like mad. To make it all work I used an old router (very slow and want to get rid of) that acts as a NAT between the cable modem and the Turris Omnia. It’s address is, now my internal network has internet. ANY IDEAS?

Did you reset your TO?

No, and how do I do that?



Well… Google is your friend :wink:

Ok…Did I reset the “Turris Omnia”…Yes,I reset it, reset it to factory defaults, reloaded it with a fresh copy of the latest firmware…I’ve jumped up and down, put tin foil on my head. nothing seems to work. Plug the “TO” into the spa122 router at address “”, no problem everything works. Plug the “TO” into the cable modem at…nothing

Have you tried setting a fixed IP on the TO WAN interface instead of DHCP?

Yes, same result nothing happens. THE SPA122 router is connected to the cable modem and getting an address via DHCP. The “TO” is far better than that crappy SPA122. Why can’t it pull an address from the Cable Modem?

You could try exchanging the ethernet cable.
Can you post the output of “dmesg” from console?

Experience with UPC:

  • cable modem in Bridge mode
  • TO plugged directly to modem

When first client gets public IP address, another one gets nothing. You need to reboot cable modem.
Another option could be cloning SPA122’s mac address.

Winner,Winner…Chicken Dinner! Thanks That was it!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.