WAN interface does not work

I’ve a Turris Omnia (2GB, first generation). I tried a few things related to moving wifi modules among the PCIe slots and eventually I could not get any longer WAN access to my modem. In Forris/WAN I get the message: “WAN port has no link or it hasn’t been configured yet. Your internet connection probably won’t work.”. I’m using “DHCP (automatic configuration)” and “Disable IPv6”. This issue happended under TO4x and I let it rest a while (it was not time critical, since I have two other TO’s (one 1st and one 3rd generation) which work fine and I really don’t need this “broken” third one).

Nevertheless, in order to make progress on the “broken” one, I now installed TO5.0.0 HBS by using med_kit and the “4 LED” reboot method. TO5.0.0 installation went flawless and the guided Foris set-up process was no problem too.

But still; no WAN access to my modem - same message. Also, here a screen_shot of the LuCI interfaces:

As written, the two other TO’s work on the modem with the same configuration just fine. Any idea whether, even after a med_kit clean install, the TO keeps some old configuration which could cause my problem?

?? eth1 or eth2 ??

image

1 Like

Strange. I have eth2 as WAN too (and works).
eth0 and eth1 are LAN (switch) ports.

BTW. I can’t see switch settings :-/

EDIT:
with TO3.xx:

...
config interface 'wan'
    option ifname 'eth1'
    ...
...
config switch
    option name 'switch0'
    ...

after upgrade to TO5.xx:

...
config interface 'wan'
    option _orig_ifname 'eth1'
    ...
    option ifname 'eth2'
    ...
...

(“switch” and “switch_vlan” sections missing at all in TO5 as well as “swconfig” command)

Is known for almost a year https://github.com/openwrt/luci/issues/2798 and likely not going to be implemented any time soon.

For me (and not just for me, I guess) it is only three days with no clear explanation.
And transition was from TO3 to TO5, no OpenWRT between.
I am aware TO is based on OpenWRT, but I use TO not OpenWRT.
Also when new stable version is released it is a good habit to release also changelog since last stable version, not just what happened since development version plus link to somewhere into wild.

1 Like

with TOS5, the WAN port is connected to ETH2.
I don’t know which internet provider or modem you use, but I use PPPoE with a Speedport Entry2 and after a new installation or changes at the ETH2-Port I have to restart the modem to get a connection. Otherwise the link is up, but no connection available.

Are you using VLAN on your WAN connection?

Maybe you inadvertently damaged something on the board whilst tinkering with the unit. Least considering that

Thank you for clarifying. Yes on my working TO5.0.0 devices it’s ETH2 too. Just to make sure, I tried on the “broken” TO ETH1 as well, it did not work either.

I am using Vodafone/Kabel_Deutschland and Technicolors TC4400 DOCSIS3.1 modem. But as written, it works with the other two Omnia’s and on the “broken” one I did a clean TO5.0.0 med_kit install.

I noticed same behavior on my Omnia. This is simple - there is renamed device eth1 and eth2. So, after replacing eth1 and eth2 in configuration, router started to work. No cable swapping neccesary. 3 hours lost by searching where is problem…

1 Like

@mrs.crox You might be right, the hardware might be broken. But since - even if it’s many years ago - I learned Digital Electronics and studied Computer Science, I am trained on how to handle hardware and therefore it’s unlikely that I caused this fault by playing/tinkering with this unit.

Yet it happens to the best. Anyway, it seems like a hardware failure somewhere along the line from WAN port to CPU.

but if there was a hardware failure, you could switch to another lan-port by removing it from the lan-bridge and changing it on the wan port.
I have to use ETH2.7 (with vlan7) for my Telekom DSL.

EDIT2
But as I see on your screenshot there have been data transferred. So the shouldn’t be a hardware failure.

1 Like

@Blacky83 Thank you, good points. Tomorrow I try to use one of the lan-ports and will report back. Yes since there is this data transfer going on I thought too - it can’t be a hardware issue.

1 Like

Hi @Tom, did you get this to work?
I think I’m running into the same problem: Turris Omnia 2020 with TC4400 and Vodafone Kabel Deutschland - none of the WAN settings I’ve tried so far seem to work :frowning:

The ISP used to provide ds-lite connectivity, is that the case with your subscriber line?

https://openwrt.org/docs/guide-user/network/ipv6_ipv4_transitioning

Hi @LorbusChris, no I did not get it working. But in my case it is a TO from the initial generation (2016), but since I own two other TO’s which work just fine, it’s no priority for myself. I would be curious how to reconfigure the switch to use LAN4 as WAN port in order to see whether eth1 on the SoC might be broken. But my skills arn’t sufficient enough to get this done …

@mrs.crox yes, it was ds-lite – there’s no option to configure it for the WAN port in Foris and I couldn’t configure it via LuCI because I didn’t have the AFTR address.

I phoned Vodafone and they activated IPv4 for me, giving me full Dual Stack - it works flawlessly now with DHCP auto conf (I only had to disable DNS forwarding for resolving in LAN to work).

I’m still curious what I should’ve done to get ds-lite to work properly, any ideas?